amd64 java

 ( Tsab | 2005. július 4., hétfő - 1:52 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

az meg sz@r ...

semminel jobb :wink:

IBM-nek is van 64bites JDK-ja

sikerült valakinek megnézni a fenti paraméterekkel a honlapot mit ajánlottam? ha igen hogyan?

Nekem sikerült, bár nem a fönti paraméterekkel.

Gentoo linux, blackdown-jdk-1.4.2.02 (amd64), mozilla 1.7.7 (amd64)

Az 1.5-öset én hanyagolnám:
- sok minden nem fordul le vele (legalább is itt gentoo alatt)
- nincs mozilla plugin

Üdv!

A tux.org-on lévő java 1.4.2-t "használom" amd64-en fiefox-al. a mozilla/plugins könyvtárba frankón be van linkelve a /use/lib/j2se/...

ám a http://balage.ath.cx -en lévő java alkalmazás nem megy, a chat.hu-n pedig amikor elkezdenék belépni a chat-re kilép az egész böngésző...

valakinek van valami furfangja erre?

[quote:758bfb4552="Tsab"]Üdv!

A tux.org-on lévő java 1.4.2-t "használom" amd64-en fiefox-al. a mozilla/plugins könyvtárba frankón be van linkelve a /use/lib/j2se/...

ám a http://balage.ath.cx -en lévő java alkalmazás nem megy, a chat.hu-n pedig amikor elkezdenék belépni a chat-re kilép az egész böngésző...

valakinek van valami furfangja erre?[/quote:758bfb4552]

Használd a [url=https://jsecom15c.sun.com/ECom/EComActionServlet;jsessionid=50B6427033ACA8EE1BFE2E007A1D6E94#] J2SE(TM) Runtime Environment 5.0 Update 4[/url]-et.
Linux AMD64 Platform - J2SE(TM) Runtime Environment 5.0 Update 4

viszont abban meg nincs mozilla plugin
szal marad blackdown

Sziasztok.

Egy kis problémába ütköztem. Eddig semmi gondom nem volt a java-val 64bit-en, de ma gondoltam, felnézek a chat.hu-ra, egyik barátommal beszélni, mert nincs semmi más "csevejkliense" még fent, na, és ekkor jött a pofára esés. Keresi a java-t, majd kiírja, hogy nincs, pedig van:

# java -version
java version "1.6.0_0"
OpenJDK Runtime Environment (build 1.6.0_0-b11)
OpenJDK 64-Bit Server VM (build 1.6.0_0-b11, mixed mode)

A sun java test oldala is megtalálja, és más oldalakkal nincs gondom (bár sok java-s lapon nem járok ;) ).

Mi lehet a gond? Opera-t is próbáltam a szitu ugyanez :(.

köszönöm a tippeket

<= Powered By Ubuntu & Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

A böngészőbe épülő Javához nem elég a Java JRE (amit a "java -version" lekérdez), hanem egy úgynevezett "plugin" is kell, ami a böngésző és a virtuális gép közötti kommunikációért felelős (egyszerűen megfogalmazva).

Ilyen plugint kell telepíteni.

Sajnos a Sun a 64 bites Javához nem csinált még plugint.
A lehetséges elvi megoldások:
- 32 bites böngésző használata és ahhoz a 32 bites sun-java6-plugin csomag telepítése
- 32 bites plugin wrapper (flash-hez van, de nem tudom Javával működik-e)
- Az openJDK-hoz van egy plugin kezdemény, ami még nem egészen kompatibilis, de rengeteg dolog már működik vele. Ki kell próbálni. Ubuntu Intrepid-en az icedtea6-plugin tartalmazza. Ezt telepítsd és a Firefox-Addons között "IcedTea Web Browser Plugin" néven megjelenik.

Interneten vannak leírások, hogy melyiket hogy kell csinálni, nekem még csak az utolsó változat sikerült.

Köszi, megnézem az Interpid-es dolgot, hátha rá lehet heggeszteni Hardy-ra! Minden esetre, természetesen böngésző plugin-em most is van, anélük a sun java test-je sem futna, ezért is furcsállom, hogy máshol nincs gondom, csak a fenti oldalon! Nem lehetne vhogy kikerülni azt az ellenőrzést?

<= Powered By Ubuntu & Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

Huh, ezt nem egyszerű felerőszakolni Hardy-ra :(. Vki, aki intrepid-et használ, megnézné, hogy alatta megy-e a chat.hu, mert ha nem, akkor nem is kinlódok vele!

köszi

<= Powered By Ubuntu & Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

Ezt a feuture-t liveconnect-nek hívják, és az icedtea plugin tudja vmi alpha experimental állapotban (ez van a interpid-ben), ami a hardy-ban van, az vmi gcj plugin, csak icedtea-s java-t használ, az nem tudja! Egy napos kinlódás után nem foglalkozom azzal többet, hogy az icedtea plugin-t felrakjam experimental liveconnect support-al, mert szívás lefordítani, az interpid-es csomag nem megy fel, mert minden függ mindentől :(. Így a végső megoldás az lett, hogy feltettem egy 32bit-es böngészőt (flock, mert swiftfox ugyanazt a könyvtárat használja, mint a firefox, ergó, egyszerre a kettő nem futhat, firefox32-vel ugyanez a helyzet), és 32 bit-es java plugin-t (sun féle), így ha vmit ilyesmit akarok csinálni, indítom a flock-ot, ott van rendes java (na, meg flash, bár ez nlspluginwrapper-el van firefox64-ben is), egyébként meg minden másra ott a firefox64 ;).

<= Powered By Ubuntu & Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

Állítólag a legújabb Java SE 6 update már támogatja (10-es sorszámmal), lásd http://hup.hu/cikkek/20081017/java_6_update_10

Tisztan elmeletben:
Fel kell tenni a java SDK-t, majd a megjeleno oldalbol ki kell banyaszni a megfelelo iframe URL-jet (login.php?= -vel kezdodik).

Ezutan Alt + F2, appletviewer http://chat.hu/javalogin/ majd paste a kinezett url-t.

Szerk: win alatt valamiert nem megy.
--

()=() Ki oda vagyik,
('Y') hol szall a galamb
C . C elszalasztja a
()_() kincset itt alant.