diff-pdf

 ( Zahy | 2018. július 18., szerda - 9:25 )

Megjelent $subject a FreeBSD-portsban. Nagyon örülök, remélem az itt is tevékenykedő uzsolt nem
e miatt érzett múlhatatlan vágyat a portolásra.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Nem - szerencsére a politika és mindenféle politikai bulvár a látókörömön kívül esik.
Inkább csak kíváncsi voltam, hogy a diffpdf-hez képest mit tud - (tantárgyfelosztásos) excel-táblázatokat kapok az órarend készítéséhez, és mivel már kb. rögzítve vannak a FET-ben az órák, az újabb verzióból csak a változás érdekel. A legegyszerűbb megoldásnak az tűnt, hogy az excel fájlokból pdf-t készítek, és azokat hasonlítom össze. Az ötlet inkább innen eredeztethető.

" A legegyszerűbb megoldásnak az tűnt, hogy az excel fájlokból pdf-t készítek, és azokat hasonlítom össze. "
És ha Excelből CSV-t csinálsz, és CSV-t diffenél mondjuk ezze: https://github.com/paulfitz/daff ?

Nem jó, ui. sok egyesített cella van, és ezt tényleg jobb vizuálisan látni - meg a színeknek is jelentése van (bár taláb a diff-nél mindegy lenne).

cool, köszi uzsolt :)

Igazán nincs mit. Nem is gondoltam, hogy ennyi embernek érdekes lehet. És ez még csak Magyarország, annak is egy eldugott kis portálja :)

Yuri elcseszte a commitot. Ma reggel kaptam egy nagy rakás hibaüzenetet:

checking for wxWidgets version >= 3.0.0... no (version 2.8.12 is not new enough)
configure: error: wxWidgets is required
===>  Script "configure" failed unexpectedly.
Please report the problem to  [maintainer] and attach the
"/wrkdirs/usr/ports/graphics/diff-pdf/work/diff-pdf-0.2-27-gc4d6722/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Persze én a 0.2-es verziót küldtem be, melynek README-je szerint:

As for dependencies, diff-pdf requires the following libraries:

* wxWidgets >= 2.8.11

Ő meg a trunk-ot (vagy head vagy mi is a fő ág) rakta be a ports-fába, aminek a README-je szerint:

As for dependencies, diff-pdf requires the following libraries:

    wxWidgets >= 3.0

Persze én USE_WX=2.8+-ot állítottam be.

Frissítettem a Makefile-t, de a webkit-gtk2 build-je még zajlik. Ha a teszt rendben van (legalább én tesztelem), akkor beküldöm a javítást.