(megoldva) lilo - rácsodálkoztam - nem tud egy másik Linux -ot bootolni?

 ( tovis | 2008. május 5., hétfő - 23:17 )

Van egy hdd:

hda1 ntfs 20GB - WinXP
hda5 swap 2GB
hda6 ext3 15G - Debian Linux Stable
hda7 ext3 15G - Debian Linux testing szeretne lenni
xG szabadon

lilo -bval pompásan bírok bootolni winxp -t és a hda6 -on lévő Linux -ot, viszont vagy nem tudom, hogy kell, vagy nem, lehet(?) bootolni a hda7 -en lévő Linux -ot. A lilo valami olyat mond hogy nem találja a boot jelzést (sign) a partición!? Egyébkénmt ugyanaz a "kopasz" telepítésű stbale de ezt majd szeretném dist-upgrade -ni.
Most lehet vagy sem ilyet, hogy két aprtíción is Linux van de a lilo nem bootolja csak az egyiket?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Lilot evek ota nem hasznaltam, de annak alapjan, amit mondasz, a boot flag hianyzik neki a hda7-rol. Ehhez fdisk -u /dev/hda, aztan 'a', aztan 7, aztan asszem 'w', aztan reboot. Ja, es hogy valami huposat is ideboffentsek: hasznalj grubot :)

+1 a grubhoz,
még annyit hozzátennék hogy a cfdisk jóval barátságosabb a sima fdisk-nél. Van valami értelme fdisk -el "szopni"?

http://gyuszk.homelinux.org

-- There is never time to do it right, but always time to do it over.

tuti lehet, en liloval 2 vinyos osszeallitast is bootoltattam.

hogy csinaltad azt a masik installt? hogy bootoltad fel anno?

Amugy a grubot elvbol utalod?:)

Az fdisk -u
When listing partition tables, give sizes in sectors instead of
cylinders.
hogy segít ez rajtam?

Nem utálom a grub -ot csak nem ismerem és nem is igen értem - értsd a configolását se - ezt akkor meg kellene tanulni!
A lilo -nál először szembesülök hogy valamit nem tudok beállítani rajta. A doklumentációja mag azt mondja, hogy vagy "image" vagy "other" a kettő együtt nem? - így nem tudom megmondani hogy a másik image egy másik partícióban lakik.
Egyébként simán másoltam - azaz nem simán, először betartoltam aztán kibontottam RIP -et használva.

* Én egy indián vagyok. Minden indián hazudik.

lilonal nem tudom hogy van, nagyon reg nem hasznalom mar, de grubnal tutira nem kell boot flag minden particóra. Én mindig csak egy 50 megás particióra rakok. hda1 -> /boot
Gondolom lilo sem igenyli, úgyh mas gond lehet szerintem. Milyen configod van?

Ilyen az /etc/lilo.conf

#
boot=/dev/hda
#
root=/dev/hda6
#
map=/boot/map
#
prompt
delay=100
timeout=100
#
default=Windows
#
image=/vmlinuz
label=Stable
read-only
# restricted
# alias=1
#
initrd=/initrd.img
#
other=/dev/hda1
label=Windows
# restricted
# alias=2
#
# ez itt a próbálkozás
#other=/dev/hda7
# label=Testing
# read-only
# restricted
# alias=3
#
# initrd=/initrd.img

* Én egy indián vagyok. Minden indián hazudik.

Bocs, megvan csak kicsit zűrös a man (vagy a fejem :)
image=/vmlinuz
label=Testing
root=/dev/hda7 # ennyi :D
read-only
initrd=/initrd.img

* Én egy indián vagyok. Minden indián hazudik.