Összezavarodott csomag függőségek

Fórumok

Suse-ről állnék át éppen Debianra.

Az 1.6-os java telepítése miatt felvettem a backports repositorit, azóta kész káosz az egész.
Bár kivettem a backports-ot a sources.list-ből törött csomagok mindenütt.

Hogyan tudnám downgradelni a rendszert?

Más: a Suse alatt ext3-at használtam, de egy áramszünet leölte a Linuxot. Addig sikerült visszaállítanom egy segítőkész kollégámmal, hogy a / alatt az etc stb. könyvtárak mindenféle érdekes nevekkel jelentek meg. Pedig hw raid is volt. Nem mertem vissza állítani, inkább lementettem a fontosabb adatokat, majd újra telepítettem a gépet.
Ext3 helyett ki milyen fájrendszert használ, amit egy áramszünet még nem öl le?

Hozzászólások

ext3. Nállam még nem volt vele baj...
Milyen Debian?
apt-get check : ellenőrzi, hogy vannak-e törött függőségek

ext3 - igaz, 7 szerverből csak 1 nem bírta.

Igen már ezt is néztem:
# apt-get check
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
Ezek kijavításához próbáld futtatni az 'apt-get -f install'-t .
Az alábbi csomagoknak teljesítetlen függőségei vannak:
iamerican: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítve
ispell: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítve
wamerican: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítve
E: Teljesítetlen függőségek. Próbáld a -f használatával.

Pl. a bzip2 telepítési kisérletére a reakció:

# apt-get install bzip2
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
Próbáld futtatni az 'apt-get -f install'-t az alábbiak javításához:
Az alábbi csomagoknak teljesítetlen függőségei vannak:
bzip2: Függ ettől: libbz2-1.0 (= 1.0.3-6) de csak 1.0.4-1 telepíthető
iamerican: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítésre megjelölve
ispell: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítésre megjelölve
wamerican: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítésre megjelölve
E: Teljesítetlen függőségek. Próbáld az 'apt-get -f install'-t csomagok nélkül (vagy telepítsd a függőségeket is!).
:-(

általában itt akadok el:
# apt-get dist-upgrade
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
Ezek kijavításához próbáld futtatni az 'apt-get -f install'-t .
Az alábbi csomagoknak teljesítetlen függőségei vannak:
iamerican: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítve
ispell: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítve
wamerican: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítve
E: Teljesítetlen függőségek. Próbáld a -f használatával.

apt-get update
apt-get upgrade
De melyik Debian verzió? /etc/apt/source.list-ben mi van?

Bocs, Debian Etch-ről van szó.

sources.list:

deb ftp://ftp.fsn.hu/debian etch main contrib non-free
deb ftp://ftp.hu.debian.org/debian-security etch/updates main contrib non-free
#deb-src ftp://ftp.fsn.hu/debian etch main contrib non-free
#deb ftp://debian.sil.at/backports.org etch-backports main contrib non-free

apt-get clean
apt-get autoclean

apt-get update
majd próbálj meg valamit feltenni

Köszi az ötletet.
Az első 3 parancs hiba nélkül lefutott, de az utolsó:

# apt-get install bzip2
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
Próbáld futtatni az 'apt-get -f install'-t az alábbiak javításához:
Az alábbi csomagoknak teljesítetlen függőségei vannak:
bzip2: Függ ettől: libbz2-1.0 (= 1.0.3-6) de csak 1.0.4-1 telepíthető
ispell: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítésre megjelölve
Függ ettől: iamerican de az nincs telepítésre megjelölve vagy
ispell-dictionary
wamerican: Függ ettől: dictionaries-common (>= 0.20) de az nincs telepítésre megjelölve
E: Teljesítetlen függőségek. Próbáld az 'apt-get -f install'-t csomagok nélkül (vagy telepítsd a függőségeket is!).

Manuálisan letöltötten az ftp szeverrről a dictionaries-common összes váltotatát, majd végül a 90-es felment gond nélkül.

Ekkor megszüntek a panaszkodások a iamerican, ibritish stb csomagokra.

apt-get --force-yes upgrade után letörölte az iamerican-t, és beállította az ibritish-t.

Viszont a bzip2 telepítés továbbra sem megy:

# apt-get install bzip2
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
Néhány csomagot nem lehetett telepíteni. Ez talán azt jelenti, hogy
egy lehetetlen állapotot kértél vagy ha az unstable disztribúciót
használod, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.

Mivel csak egyetlen műveletet kértél, ez nagy valószínűséggel arra utal
hogy a csomag egyszerűen nem telepíthető és egy hibajelentést kellene
kitölteni a csomaghoz.
Az alábbi információ segíthet megoldani a helyzetet:

Az alábbi csomagoknak teljesítetlen függőségei vannak:
bzip2: Függ ettől: libbz2-1.0 (= 1.0.3-6) de csak 1.0.4-1 telepíthető
E: Törött csomagok

próbálj már más csomagot telepíteni, arra mit ír ki? Mit vettél fel a sources.list be, és utánna mt csináltál? az apt-get -f install -t próbáltad?

Más csomagra (apache2-őt próbáltam) megy a telepítés.

sources.list:

deb ftp://ftp.fsn.hu/debian etch main contrib non-free
deb ftp://ftp.hu.debian.org/debian-security etch/updates main contrib non-free

# apt-get -f install -t bzip2
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
0 frissített, 0 újonnan telepített, 0 eltávolítandó és 203 nem frissített.

# apt-get -f install bzip2
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
Néhány csomagot nem lehetett telepíteni. Ez talán azt jelenti, hogy
egy lehetetlen állapotot kértél vagy ha az unstable disztribúciót
használod, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.

Mivel csak egyetlen műveletet kértél, ez nagy valószínűséggel arra utal
hogy a csomag egyszerűen nem telepíthető és egy hibajelentést kellene
kitölteni a csomaghoz.
Az alábbi információ segíthet megoldani a helyzetet:

Az alábbi csomagoknak teljesítetlen függőségei vannak:
bzip2: Függ ettől: libbz2-1.0 (= 1.0.3-6) de csak 1.0.4-1 telepíthető
E: Törött csomagok

és:
# bzip2
bash: bzip2: command not found

csak apt-get -f install csomagnév nélkül

# apt-get install bzip2
Csomaglisták olvasása... Kész
Függőségi fa építése
Reading state information... Kész
Néhány csomagot nem lehetett telepíteni. Ez talán azt jelenti, hogy
egy lehetetlen állapotot kértél vagy ha az unstable disztribúciót
használod, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.

Mivel csak egyetlen műveletet kértél, ez nagy valószínűséggel arra utal
hogy a csomag egyszerűen nem telepíthető és egy hibajelentést kellene
kitölteni a csomaghoz.
Az alábbi információ segíthet megoldani a helyzetet:

Az alábbi csomagoknak teljesítetlen függőségei vannak:
bzip2: Függ ettől: libbz2-1.0 (= 1.0.3-6) de csak 1.0.4-1 telepíthető
E: Törött csomagok