mikrotik ros 6.37 l2tp problema - failed to pre-process ph2 packet.

 ( Seth78 | 2016. november 10., csütörtök - 22:03 )

a kovetkezo l2tp setup-om van:

/ip ipsec policy group
set
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-128-cbc pfs-group=\
none
/ip ipsec peer
add address=0.0.0.0/0 dh-group=modp2048 enc-algorithm=aes-256,aes-128,3des \
exchange-mode=main-l2tp generate-policy=port-override local-address=\
0.0.0.0 secret=titok

/ppp profile
add dns-server=8.8.8.8,8.8.4.4 local-address=192.168.60.223 name=L2TP_Profile \
remote-address=L2TP_Pool use-encryption=required
/ppp secret
add name=test password=test profile=L2TP_Profile service=l2tp

tuzfalon 1701, 500,4500 udp , protocol 50,51 szinten engedelyezve vannak, es van egy srcnat 192.168.60.0/24
-re masquerade-elve.

logban ez latszik:

failed to pre-process ph2 packet. , majd phase1 negotiation failed due to time up 109.255.46.47[500]<=>20.10.5.23[500] 7044789ed2ebdaae:a27040cfa2d92c21

elore is koszi a segitseget!

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Mikrotik IPsec-kel egy szívás: ntp csomag az egyikre, NTP szerver ON; ntp kliens a párján rácuppantva az iménti NTP szerveres fizikai interfész címére.
Amíg nem egyezik az idő, az IPsec nem fog összeállni.

koszi.... en egy megbizhato vpn szervert akarok amire macrol es windowsrol be tudok maszni es titkositott... szoval nem routereket akarok osszeloni.
jah ez az allat cloudbol update-el idot, a kliensem amirol csatlakoznek az meg valami M$ ntp szervert hasznal szerintem.

--
{ Nem is kernel az, ami nem fut el egy quartz órán }

"en egy megbizhato vpn szervert akarok amire macrol es windowsrol be tudok maszni es titkositott."

Akkor OpenVPN-t javaslom, esetleg PPTP-t.
Mindkettő megy mikrotiken.

Azért én PPTP-t kb. 1998 tájékán javasoltam utoljára.
(BTW, a Mikrotik + L2TP/IPsec megoldás stabilan működik Windows kliensekkel. Mac-hez nem tudok hozzászólni.)

maccel is

koszonom uraim, megoldottam. az n. leiras segitett vegul. aki kivancsi a configra annak elkuldom, vagy szivesen segitek. megy szifonrol, ablaxrol, es makkosrol is.

http://www.firstdigest.com/2015/01/mikrotik-l2tp-with-ipsec-for-mobile-clients/

nalam annyibol volt erdekes a config hogy kulon vlan-t akartam az iot cuccoknak itthon es kifejezetten erre egy vpn-t.

--
{ Nem is kernel az, ami nem fut el egy quartz órán }

Policy template group hiányzik. Hozz egyet létre, és rendeld hozzá a peer-hez.

/ip ipsec policy group
add name=RW
/ip ipsec policy
set 0 group=RW


/ip ipsec peer
add address=0.0.0.0/0 enc-algorithm=aes-256,aes-128,3des exchange-mode=main-l2tp generate-policy=port-override local-address=0.0.0.0/0 policy-template-group=\
    RW secret=titok