java debianhoz csomagból

 ( szaty | 2004. november 26., péntek - 22:01 )

java debianhoz csomagból

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

sziasztok

olynoktól szeretnék segítséget kérni akik nálam jártasabbak a java mikéntjében.
Az előző 3 órában egy java futató környezetet próbáltam telepíteni de csak hiányzó vagy rosz csomagokkal találkoztam.

a sun-j2re1.5debian
csomagot akarom telepíteni a minek föggősége a
sun-j2re1.5
Package not available
csomag .

Hol lehet ilyet találni?
az 1.4-es java is jó lenne.
Igazábol eclipse-hez kell de javaban nem akarok fejleszteni csak a cdt pulg-int akarom használni.
Előre is köszi.

Az rpmseek.com szerint a debian ftp-szervereken a contrib csomagok között van. Ezek szerint, ha jól van beállítva, akkor az apt-get fel kellene tegye...
(Bocs, ha nem jó, amit írok, régen használtam debiant. Remélem ez esetben valaki kijavít.)

Üdv,
L. Á.

2 sor a source.list -be

deb http://www.cerkinfo.be/debian/ unstable main contrib non-free
deb-src http://www.cerkinfo.be/debian/ unstable main contrib non-free

tudom hogy van egy sun-j2re1.5debian nevű csopmag a contrib között de ennek függősége a sun-j2re1.5 csomag. Utobbira viszont a Package not available jelző van ragasztva. nekem ez kéne.

Először is tedd fel a java-package nevű csomagot, SID-ben benne van biztosan.

Aztán töltsd le a sima SUN java csomagot a sun.com-ról (ne az rpm-et)

aztán make-jpkg sunosjavacsomagneve

ezután keletkezik egy sunjavacsoamgneve.deb

aztán

dpkg -i sunjavacsomagneve.deb

lehet hogy kiir valami függőségi problémát ezeket tedd fel még apt-get -vel, talán valami j2re-debian akármi szokott neki hiáynozni.

köszönöm a tipet én is evel próbálkozom éppen.

Köszönöm mindenkinek a segítséget mostmár rendeen megy az eclipse.
Apt-get el sikerült a megfelelő csomagokat leszedni valahonnan. Most van egy pár fölös javas dolg a gépemen, majd holnap talán letakarítom.....
Mégegyszer köszönöm segítséget

en a helyedben nem vacakolnek ilyen balckdown java csomagokkal, regi tragya es nem a 2.1-es eclipse-et tennem fol, hanem a java-t sunrol lehuzni folrakni tarbol, aztan eclipse 3.1-et

jo, ha nem java feljeszteshez kell eclipse, megertem, de azer az uj cdt pluginek pl nem is futnak csak 3.x-es eclipse-n, azt meg nem tudod csomagbol folrakni, ha meg nem tod, akkor meg a balckdown java nem segit rajtad, mer ugyis meg kell adni a helyet eclipseben, vagyis akkor mar inkabb leszeded 1.5-ot frissen...
oo, remelem erteheto voltam :lol: kicsit hosszu mondatra sikeredett :)