érdekes hiba

 ( lacika | 2004. november 12., péntek - 21:16 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Szép jó estét,

Van egy Woody szerver. ADSL -t oszt meg , fetchmail és proxy szolgálltatást lát el.
Mikor a useradd -m felhasznalo paranccsal fel akarok venni egy új felhasználót, akkor a következő hibaüzenetet kapom:

router:~# useradd -m felhasznalo
Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!
router:~#

Ez nekem kicsit kínai :(
Mi is ez pontosan?
És a passwd parancs is eltűnt.
Felnyomták szegény routert?
Hol és mit keressek a log fájlokban?
uname -a kimenete:
Linux router 2.4.26-grsec #1 SMP Tue Jun 8 09:56:44 CEST 2004 i686 unknown

laci

Közben kiadtam a következő parancsokat:
apt-get clean
apt-get update
apt-file search useradd (kiadta a passwd -t)
apt-get install passwd --reinstall

Ezek után megjavult a helyzet és a passwd parancsom is előkerült.
De akkor is aggaszt egy kicsit a helyzet, hogy mi történhetett. Most vizsgálgatom a log fájlokat, de elég nagyon :( Ha találok valamit megírom, de ha más is tud valami okosat, akkor ne tartsa vissza az infót kérem. Köszönöm előre is!

laci

Rootkitet kerestél? Futass le egy rkhuntert vagy chkrootkitet is!
(csak mert gyanús ez, hogy a passwd volt érintett)

OK!
Mindjárt postolom az eredményt.

Laci

Na frankó, lefagyott vagy megszakadt a netkapcsolat a routeren. Így marad holnapig a keresés :(

Laci