closed connection to service ?! Debian Wheezy & Samba 3.6.6 + Win7

 ( beathead | 2014. szeptember 17., szerda - 9:35 )

Üdv! Wheezy (3.2.0-4-686-pae) alatt a legfrissebb sambával (3.6.6-6+deb7u4) a Windows 7-es klienseknél 2-3 óránként megszakad a kapcsolat, elveszítik az összes felcsatolt hálózati meghajtót. Kliens logban:

[2014/09/17 07:29:50.288591, 1] smbd/service.c:1378(close_cnum)
pchp17 (192.168.17.152) closed connection to service share1
[2014/09/17 07:30:42.611311, 1] smbd/service.c:1378(close_cnum)
pchp17 (192.168.1.152) closed connection to service share2
[2014/09/17 07:46:08.613366, 1] smbd/service.c:1114(make_connection_snum)
pchp17 (192.168.1.152) connect to service share1 initially as user AnonM (uid=1070, gid=513) (pid 10862)
[2014/09/17 07:46:08.630674, 1] smbd/service.c:1114(make_connection_snum)
pchp17 (192.168.1.152) connect to service share3 initially as user AnonM (uid=1070, gid=513) (pid 10862)
[2014/09/17 07:46:08.654297, 1] smbd/service.c:1114(make_connection_snum)
pchp17 (192.168.1.152) connect to service share4 initially as user AnonM (uid=1070, gid=513) (pid 10862)
[2014/09/17 07:51:08.616583, 1] smbd/process.c:457(receive_smb_talloc)
receive_smb_raw_talloc failed for client 192.168.17.152 read error = NT_STATUS_CONNECTION_RESET.

Azért nem gondolom, hogy a samba konfigjával lenne gond, mert ugyanezzel az smb.conf-fal egy Debian Squeeze-en (2.6.32-5-686) tökéletesen működik a samba (3.5.6) win7-tel. :S Hálózati oldalról közelítettem meg először a problémát, cseréltem kábeleket, hálókártyákat, sőt már switchet is, de még mindig leszakadnak a userek. Lehet, hogy ez valami bug lesz a 3.6.6-os sambában?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Amennyiben gépnév-re csatlakoznak a kliensek akkor kipróbálnám mi van ha átállítom ip-re...vagy fordítva.

Illetve minden port nyitva van a samba felé ?

End Point Mapper (DCE/RPC Locator Service) 135 tcp
NetBIOS Name Service 137 udp
NetBIOS Datagram 138 udp
NetBIOS Session 139 tcp
SMB over TCP 445 tcp

Üdv!

Gépnévre, és IP-re is csatlakoznak vegyesen, de ugyanez a gond.

Portok:
111/tcp open rpcbind
137/tcp closed netbios-ns
138/tcp closed netbios-dgm
139/tcp open netbios-ssn
389/tcp open ldap
445/tcp closed microsoft-ds

Az smb.conf [global]-ban megadtam, hogy smb ports = 139 ...
De nem hiszem, hogy ezzel van gond, mert a 3.5.6-os samban, jól megy, és ugyanezek a portok vannak nyitva/zárva.

--
the Beathead