Még mindig utálom az MS-t

 ( zslaszlo | 2014. szeptember 4., csütörtök - 20:39 )

Most épp a skype miatt. Már az elején tudtam, amikor megvették, hogy elkúrják. Csak az volt a kérdés mikorra. Miért kényszerítenek a pulseaudio használatára könyörgöm? És milyen rohadt aljas módon! Egyszerűen be sem enged lépni a skype fiókba, ha nem a legfrissebb verzió van fenn.
Mindegy most frissítettem, persze el is tűnt az összes hang.
Nosza: sudo apt-get install pulseaudio pavucontrol
Indítsuk újra. Eredmény: hanglejátszás van, felvétel nincs. Valami szar gyenge jel lehet, de semmit nem játszik vissza teszthívásnál.
Nosza google. Értelmeset nem találtam, egyébként sincs kedvem az egész szarhoz. Hagyom a francba, majd holnap megcsinálom.
De azért utálom a Microsoftot. Nagyon.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Már az is az MS hibája, hogy Linuxon mai napig nem voltak képesek rendet tenni az audiokáoszban? Fura egy világot élünk.

----------------
Lvl86 Troll, "hobbifejlesztő" - Think Wishfully™

+1

De azért hogy tisztán lássunk, a másik oldalt tekintve sem kevésbé faramuci a dolgok állása:

WaveOut
DirectSound
WASAPI
ASIO

Ugyan elismerem, hogy Windowson meglehetősen keveset kellett olyan programot írnom, ami hangot ad ki vagy vesz fel magából, de valahogy azok az API hívások, amiket használnom kellett, működtek. Mindig. Anélkül, hogy különösebben foglalkoztam volna vele, hogy most mégis mivel szól.

Linuxos oldalról meg mást sem hallok évek óta, hogy a (randomaudioalrendszer) miért fos.

----------------
Lvl86 Troll, "hobbifejlesztő" - Think Wishfully™

Azért én szoptam eleget DirectSound-al. Igencsak fos API-ja volt anno (DX6 környékén). Viszont vicces módon a PulseAudio-val meg vagyok elégedve, teljesen jól megy nálam már régóta, nem értem, mi ez a nagy ellenségeskedés.

A DirectX6 megjelenési időpontja: August 7, 1998 (http://en.wikipedia.org/wiki/DirectX#Releases). Szóval egy 16 évvel ezelőtti API szopást tartasz ma - 2014-ben - relevánsnak?

Amennyire rálátok a témára, a kettőt összehasonlítani sem lehet. Windowson évtizedes kompatibilitás van. Elvben természetesen. Úgy tudom, WaveOut még Windows 8.1-ben is van (emuláció), DirectSoundot pedig Windows 95 óta lehet használni. Összefoglalva: a négy felület közül bármelyiket használhatod.

:)

- (irony not detected)

-1

Az az MS hibája, hogy a szemetek nem hagyják, hogy ne használj a desktop alkalmazásuk egyik funkciója alá egy olyan rendszert, ami 5 éve a legtöbb desktop disztróban default ott van. Rohadt MS, hogy kapná be, fúj. :(

BlackY
--
"en is amikor bejovok dolgozni, nem egy pc-t [..] kapcsolok be, hanem a mainframe-et..." (sj)

Hm... Ebben is van igazság. Erről nem tehet az ms. A Linux platform valahol mindig is fragmentált volt. A nyílt forrás átka?

Inkább a bazár modell a problémák gyökere.

Az MS is utál Téged :D :-/

Csak a buták kedvéért, pulseaudio függőség MS előtt volt a skype-ban.

+1, már a 2.0-s verzióban is azt használtam

De az okosaknak eddig nem volt kötelező ezt használni. Ne érts félre,nincs bajom a pulseaudioval, csak azzal,hogy ha akarom, ha nem rákényszerítenek a használatára.

Most komolyan, szerinted hány különböző hangrendszert kellene támogatnia annak, aki hajlandó Linuxra fejleszteni?

Arról nem is beszélve, hogy a pulseaudionak van alsa kompatibilis felülete is. Persze értem én, hogy itt most épp az a panasz tárgya, hogy miért kell pulseaudiot használni.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Mondjuk nem tudom miért kell a loginhoz bármilyen hang. Én pl. szinte kizárólag chatre használom a skypeot.

A Skype-ot egyben kell tekinteni. Ha csak a kis zöld ikonját akarod nézni az értesítési területen, akkor nem kell hozzá hálózati támogatás meg billentyűzet kezelés sem. Ezzel csak azt mondom, hogy a Skype egy azonnali üzenetküldő és VoIP alkalmazás, ennek megfelelő függőségekkel, illeszkedési pontokkal.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Oke, de ahogy el tud indulni video nelkul is (noha a videochat szinten a kepessegei koze tartozik), ugy elindulhatna hang nelkul is.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Ez viszont jogos. :)


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Volt pulseaudio függőség, de faszán be lehetett lőni ALSA alá is. Most ez már nem megy.

--------------------------

Csak a viták elkerülése végett. Ha nem használok ékezetet, mobiltelefonról írok.

Szerintem már annak is örülni kell hogy viszonylag használható a skype linuxon manapság. Meg hogy van egyáltalán.

Mar ugy erted, hogy mondjuk 5 eve gond nelkul ment? Oruljek annak, hogy meg ma is mukodik?
Nem, nem akarom igy felfogni a vilagot. Jobban orulnek neki, ha valami mukodott 5+ eve, akkor az legyen a termeszetes, hoyg ma is mukodik.

--
http://www.micros~1

+ nagyon sok.

Csak halkan mondom, ma is természetes, hogy működik. Ha desktop Linux, akkor nálam csak a Fedora jöhet szóba, de évek óta semmi baj nem volt a PulseAudio+Fedora kombóval

Talan mar emlitettem, ha elinditom a steam klienst es akarok vmi megvasarolt jatekkal jatszani, akkor
a) a jatek nem fut
b) a skype tobbe nem mukodik, amig a gepet nem restartolom (probaltam csak az X-et, de mindegy volt neki)

Teny, x eve nem volt steam kliensem.

Az is erdekes, hoyg amiota az uj skype miatt pulseaudio van (ami alapbol eszik 30% procit, holott semmi sem szol), a youtube elhal. "hiba a lejatszasban" es paff. Raktam fel regebbi flasht, tokmindegy. Nem akarom kiturkalni, mi a szar ment gajra, hazsnalni akarom, pont. Pont ugy, mint egy eve, amikor nem volt semmi bajom. Lehet, hogy koze nincs a pulseaudiohoz, de gyanusan egy idoben fostak maguk ala a dolgok.

En ecceru ember vagyok, totalisan elegedett voltam 10+ eve az ALSA-val, nem akartam pulseaudiot. De ma, hoyg a skypeot hazsnalni tudjam, kell. Es kozben doglenek az eddig mukodo dolgok.

--
http://www.micros~1

Tetszik ez az "engem nem érdekel, mi van belül, minek mi az oka, csak menjen" típusú hiszti. A világ nem ilyen, mert mindennek oka van. Hülye példa: nem érdekel Newton II. axiómája, olyan autót akarok, amivel ha 240 km/h-val haladva betonfalba ütközöm, kiszállok, leporolom magam, aztán hívok taxit. Jó, nyilván.

A Skype esetében éppen arról van szó, hogy megtették a szükséges fejlesztéseket, az újabb felületre illesztették az alkalmazást. Ha neked nem megy, akkor baj van, mert régi környezetet használsz. ugye, nem várod, hogy 1.0-ás kernel fölött 40 MHz-es i386-oson, 4 MB RAM-mal szerelt gépen is menjen a Skype?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

a te peldaid tenyleg otromba fail-ek. Ha a skype protokollja nem valtozott meg (amint azt fentebb allitotta valaki - bar zero alatamasztast hozott erre az allitasra), akkor magyarazd mar el, hogy miert is kellett *kieroszakolni* az upgrade-et?

--
"A politikat, gazdasagot es a tobbi felsorolt faszsagot leszarom, amig engem nem erint (nem erint)" (bviktor)

A Skype ingyen használható kereskedelmi termék. Megváltoztathatják a protokollját azért, hogy reklámot nyomjanak a felhasznákló képébe, vagy azért, hogy lenyúlják a személyes adatait. Nem emlékszem olyasmire, hogy bárki azt mondta volna, a Skype protokollja az elkövetkező 400 évben nem fog változni.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

ok, akkor foglaljuk ossze csak a te kedvedert:

- a 4.x verzioban total jol ment az audio a 'nem mainstream' linux disztromon is.
- egyszer csak nem lehet bejelentkezni, elmegyunk a skype oldalara, ahol mondjak, hogy tessek upgrade-elni
- ok, upgrade kesz, login: ok, audio: gone
- miutan az ember kianyazta magat, elkezd toprengeni, hogy wtf?

Nezzuk locsemege valaszait:

A Skype ingyen használható kereskedelmi termék -> fail

megvaltozott a protokoll, hogy reklámot nyomjanak a felhasznákló képébe: nincs reklam az ujabb verzioban sem -> fail

hogy lenyúlják a személyes adatait.: a regisztracio soran megadtam, amit nagyon kellett, egyeb adatot azota sem kertek -> fail

Nem emlékszem olyasmire, hogy bárki azt mondta volna, a Skype protokollja az elkövetkező 400 évben nem fog változni.

idezd mar, hogy ki ringatta magat ebben a hitben?

Szoval, lehet, hogy a lonak csemegeje vagy, de az eszevo madarnak tuti nem....

--
"A politikat, gazdasagot es a tobbi felsorolt faszsagot leszarom, amig engem nem erint (nem erint)" (bviktor)

Látom, a feltételes mód értelmezése nehézségekbe ütközik.

egyeb adatot azota sem kertek

Aha, a titkosszolgálatok is úgy szokták, hogy jónapot kívánok, Kovács alezredes vagyok, ne zavartassák magukat, beszélgessenek, mintha itt sem lennék. :) Mindenesetre nagyon elment ez a szál, nem ez volt a lényege.

Amit mondani akartam. A Skype a Microsofté, nem közkincs. Megcsinálták, hogy jobban együttműködjön a pulseaudioval, kidobták az alsa támogatást. És? Mi ezzel a baj? A pulseaudio az aktuális hangrendszer a GNU/Linux terjesztésekben, az alsa a múlt. Ezen felül nincs OSS támogatás sem a Skype-ban. Akkor ezért is szomorkodni kell?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

az alsa a mult Kar, hogy ez igy ebben a formaban hulyeseg. A pulseaudio meg mindig az ALSA-ra epul, vagyis az ALSA meg mindig az aktualis hangrendszer a GNU/Linux terjesztesekben, a pulseaudio az e folott egy felulet. Hogy miert? Hat azert, mert a kernelben meg mindig nincsen PulseAudio modul, ellenben van ALSA. Es a kernelbeli ALSA supporthoz kotelezoen jar az userspace ALSA support is.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

"A pulseaudio meg mindig az ALSA-ra epul"

Or not, pl oss-re...

Nem, úgy értem hogy annak is örülni kell, hogy portolták annak a kis százaléknak aki linux desktopon használja.

Milyen géped van? Én eddig bárhol próbáltam, mindenhol egyből működött a pulseaudio.

Card: HDA Intel Chip: Realtek ALC269
Asus eeepc 1001PX
Egyszerűen felfoghatatlan az egész. Audacity-in elindítottam a felvételt. Látom a bemeneti jelet, de semmit nem játszik le. Telepítettem a pulseaudio managert is. Látom a bemeneti jelet a és semmit nem játszik vissza, holott van hang. Igaz úgy szól, mint a bili. Rakás szar ez!

pavucontrollal programonként állítgathatod, hogy melyik program melyik be és kimenetet használja. Ráadásul ott tudod a hangerőket is állítgatni.
Csaba

+1

Ok. Megtörtént. Miután felhúztam a felvételt 153%-ra és BELEORDÍTOTTAM a mikrofonba, egy kicsit kilengett a mutató és valami halk hangot visszahallottam.
Szerk.: ezt is elolvastam, de nem lettem sem boldogabb, sem okosabb tőle:
http://community.skype.com/t5/Linux/Microphone-not-working-Debian-10-with-Pulse-Audio/td-p/3031902
Szerk2.: ez is igen taluságos olvasmány, főként, hogy épp ebben a cipőben járok. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717897
Azt hiszem itt hagyom abba az egészet. Szarok az MS fejére, majd használok gtalk-ot vagy valami más szart...

Vagy használhatnál desktop disztrót is. Amiben alapból működik a pulseaudio.

Szvsz nincs a Debiannal semmi baj. Az embernek van választása: vagy végigolvassa a pulseaudio dokumentációját és megtanulja bekonfigolni maga, vagy valóban használ "desktop disztrót" ahol ezt megteszik helyette.
Csaba

Nem mondtam, hogy baj van vele, de ha pl. nem tudja beállítani Debian alatt ami teszem azt Ubuntu alatt OOTB megy, akkor használjon azt.

Inkább megtanulom, de nem fogok Ubuntut használni. És hagyjuk már ezt a desktop distro dolgot. Ez egy kis gyenge gép 1G rammal és kevés procival. Olyan összetett és komplex feladatokra használom, mint szövegszerkesztés, zenehallgatás, böngészés. Ehhez egy általam ismert disztrót és egy lightweight DE (xfce) használok teljes megelégedéssel. Nem csillog, nem villog, magam konfigoltam és kiválóan működik. Lehet nem mainstream distro a Debian, de ez az Ubuntu alapja is. És nagyon kiforrott. Lehet, hogy régiek a csomagok, de atomstabil a rendszerem és kézre-áll. Ettől többet nem is várok tőle. Tökéletes az igényeimhez szabva.
Ha nem megoldható rajta a skype, nem használom. Mármint a skype-ot. Emiatt ugyan nem fogok disztrót váltani. Ennyi.

Akkor viszont sem a pulseaudio, sem a Skype "gyártóját" nem kell leszólni. Inkább szép csendben kerestél volna egy alternatív megoldást.

Bocsi, de nincs igazad. Ez nem egy fórumszál, hanem a blogom. Itt nyugodtan sírhatok és szidhatok akit akarok. Még akkor is, ha igazad van és szép csendben keresek alternatív megoldást. Pl. most backports-ból telepítem a 4.0 pulseaudiót. Hátha jobb lesz...

Nem a jogodat vitatom, csak a jellemhibádra próbáltam rámutatni.

Igen. Ezzel nem is vitatkozom. Igazad van.

Ha két gép között kell pont-pont VoIP, illetve több között konferencia, akkor nézd meg a seren nevű alkalmazást, nekem bevált.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Köszönöm, mindenképp megnézem!

Gondolom, van Debianra bináris csomag, arra minden van. :) Fedorára van, nem kellett forrásból fordítanom.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Nem csak beállítás kérdése, de valahol nem normális valamiből a 2.0-sat használni az 5.0-s helyett. Ráadásul nem három hetente jön újabb Pulseaudio release.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

+1

Debian, ősrégi, több éves csomagokkal.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Na, te se vagy olyan, mint a nicked, maskepp nem mondanal ilyesmiket.

Ubuntu-n (ugye megegyezhetunk, hogy a Gnome alapu Ubuntu egy desktop disztro?) egy fos a pulseaudio. Rendszeresen elfelejti a felveteli beallitasokat, a mikrofon hangerejet minden egyes rohadt hivashoz ujra be kell allitanom, mert amugy maxra tekeri a hangerot, amitol rettenetesen torz leszek, nem is ertenek a vonal masik vegen.

Es mindezt egy egeszen standard Toshiba Satellite L300-on adja elo. Ertem, hogy eszmeletlen regi vas, meg dobjuk mar ki a francba (melohelyi gep, nem opcio), de azert ize mar. 2014-ben nem ezt varnam.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Tudod, temérdek lehetőség van: "worksforme", "hardvert venni tudni kell", stb. :D

De komolyra fordítva, az már szánalmas, hogy ezt ennyire nem sikerül megoldani, akár az Ubuntunak, akár másnak. Fedorán megy, eddig minden gépen ment, ahol próbáltam. 2014 van, az oprendszer szállítója tudjon már normális hangrendszert szállítani.

Jó ez a bugreport. A 2.0-ás Pulseaudioról szól, miközben az 5.0-ás az aktuális verzió.

Következőt próbáld ki:

alsamixer -c0

A mikrofonnál valószínűleg lesz valami előerősítő, boost, vagy mi a neve, azon állíts. Amit még el tudok képzelni, hogy a DC táplálás nincs meg a mikrofonhoz, mert vonali bemenetet képzel valamiért, nem mikrofont.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Igen ez is megvolt, köszönöm. F4 Capture Itt van capture és digital, mindkettő maxon. F6 hangkártya választás - default és 0 HDA Intel van, mind maxon. Ja, mint látszik nincs MicBoost
┌───────────────────────────── AlsaMixer v1.0.25 ──────────────────────────────┐
│ Card: HDA Intel F1: Help │
│ Chip: Realtek ALC269 F2: System information │
│ View: F3: Playback F4: Capture F5:[All] F6: Select sound card │
│ Item: Digital [dB gain: 30,00, 30,00] Esc: Exit │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ ├──┤ ├──┤ ├──┤ └──┘ └──┘ Enabled └──┘ │
│ │OO│ │OO│ │OO│ │
│ └──┘ └──┘ └──┘ L R │
│ CAPTURE │
│ 100 96<>96 100<>100 100<>100 100<>100 100<>100 │
│ Master Headphone Speaker PCM Capture Auto-Mute < Digital >│
└──────────────────────────────────────────────────────────────────────────────┘

Mit jelent az, hogy semmit nem játszik vissza? Nem lehet, hogy rossz kimenet van kiválasztva? Ha úgy tetszik, rossz lyukon megy ki a hang, nem ott, ahol várod. Pavucontrollal ezt is meg tudod nézni, illetve röptében változtatni is.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

amig a 4.2-es skype volt fenn, addig nem volt gondom az audioval. Aztan kijott a 4.3-as, amire at kellett valtani. Azota kakukk az audionak. Nem baj, majd tabletrol fogok skype hivasokat vegezni, kossz ms, b+...

--
"A politikat, gazdasagot es a tobbi felsorolt faszsagot leszarom, amig engem nem erint (nem erint)" (bviktor)

Nem értem ezt a sok sírást. Egy szoftverfejlesztő cég (skype, de mondjuk akkor, hogy most már ms) a jelenlegi de facto linux stack-re hozza ki a szoftverét. Bármennyire is ömlik az agyatlanság, a pulseaudio minden mainstream disztribben ott van.

Épeszű, sokakat megszólítani akaró cég nyilván erre a stackre fogja építeni a szoftverét. Ha szar a pulseaudio, ez van, nem a skype, nem az ms hibája.

Egy ms terméket sem használok, de nem is vagyok ennyire buta, hogy mindenáron, ELVBŐL, gondolkodás nélkül ócsároljam őket...

nalam nincs pulseaudio (ok, nem is 'mainstream' disztrot hasznalok), de addig legalabbis mindig megtalalta az audio device-okat, es tudta hasznalni. Kerdes az, hogy egy 4.2.x.x -> 4.3.x.x valtasba tenyleg kellett-e atvarialni az audiot? Az meg kulon erdekes kerdes, hogy vajon miert nem tudok bejelentkezni a 4.2-vel? Valoszinuleg a protokoll is megvaltozhatott...

--
"A politikat, gazdasagot es a tobbi felsorolt faszsagot leszarom, amig engem nem erint (nem erint)" (bviktor)

Nem tudom az arch mennyire mainstream, de nekem semmi bajom a pulseaudioval. Úgy van, ahogy anno évekkel ezelőtt a rendszerrel települt (nem emlékszem, hogy bármit is külön állítgatni kellett volna rajta) és mindennek van hangja, skype is megy.

nem változott a protokoll, ha megpatcheled a binárist, valószínűleg működne
_____________________________
Powered by 1,3,7-trimetilxantin

A csoportos uzeneteknel volt nagyobb protokollvaltozas, a regi tipusu csoportuzenetekrol pl nem jon iPhone-ra se push notification, csak az uj "chatroomokba". Es volt 1-2 het amig a Linuxos kilens nem latta az ujakat, aztan jott az update.

Hát most utánagugliztam, és van aki simán átírta a binárisban a verziószámot, és működött. Igaz csoportos üzenetekről nem beszélt, de majd kipróbálom a hétvégén egy linuxos gépen, ha lesz időm.
Bár a kérdés pusztán elméleti, sokáig ugyse megy :)
_____________________________
Powered by 1,3,7-trimetilxantin

ha nem valtozott, akkor minek kellett forszolni az upgrade-et?

--
"A politikat, gazdasagot es a tobbi felsorolt faszsagot leszarom, amig engem nem erint (nem erint)" (bviktor)

Az a baj hogy ti csak a skype protokollt nézitek, pedig a skype kliens egy rakás dolgot tud azon felül is. Pl. ott az msn, szerintem esélyes hogy amiatt forceolták az update-et.

Az MSN-t pont a héten lőtték le végleg Kínában is, miután 2013. márc 15.-n már a világ összes más részén leállították.

Tudom, épp erről beszélek. De a skype a mai napig megkülönbözteti az msn-ről migrált és a skype-os ismerőseidet, ezért nem tartom kizártnak, hogy máshogy is kezeli őket. Ha pedig így van, akkor könnyen elképzelhető, hogy az msn végleges leállításával bele kellett nyúlni a kliensekbe is, méghozzá úgy, hogy ha nem update-elsz, nem fog teljes körűen működni a szolgáltatás.

nem teljeskoruen != egyaltalan nem
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

nem volt időm rá, de örömmel látom, hogy nem csak nekem jutott eszembe
http://blog.t-rg.ws/20140904/files/file.45/

_____________________________
Powered by 1,3,7-trimetilxantin

En se ertem ezt a picsogast. Az ALSA minden mainstream disztroban benne van, a hangkepzes de facto standardja lett Linuxon, e fole a pulseaudio csak csicsa, semmi mas.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

+1

Az ALSA tökéletesen tette a dolgát nálam is minden általam kipróbált terjesztés alatt, hosszú éveken keresztül. Aztán jött ez a pulse izé, amit legalább régebben tökéletesen le lehetett irtani és be lehetett lőni újra only ALSA alá a rendszert ha nem tetszett az embernek. Most meg némely disztróba úgy bele van drótozva, hogy kigyomlálásával együtt egy csomó minden vele borul.

--------------------------

Csak a viták elkerülése végett. Ha nem használok ékezetet, mobiltelefonról írok.

Mi abban a nehéz, hogy a mai GNU/Linux terjesztésekben már nem alsa van? A legalja, a driver-ek szintje az, de aztán van egy közbenső réteg, ami az alkalmazások és a driver-ek között, van, ez a pulseaudio. Ma már az ipchains is csak emlék. Ez baj? És igen, van systemd is. Botrány! :)


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

"... van a kozbelso reteg ..." - ami szinten ALSA, aztan van e folott egy wrapper, ami a pulseaudio, es az alkalmazasok ezen keresztul kommunikalnak.

Legalabb alapvetoen tessen tisztaban lenni a rendszer mukodesevel.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Te még a tizenöt méternyi beton alatt lévő hullának is tudnál mit tanítani. De legalább megpróbálni biztosan megpróbálnád.

:)

Nem biztos, hogy ertem mire gondolsz. Egyszeruen csak nem birom, ha valaki nyilvanvalo hulyeseggel probal ervelni.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Igen, ott van az alsa, csak az a kérdés, minek. Tekintsd úgy, hogy az semmi más miatt nincs ott, csak a pulseaudio kiszolgálására, és át akarsz nyúlni egy rétegen, amikor egy alkalmazással közvetlenül az alsa-t piszkálod. Éppen ez van a Skype esetében: nincs alsa interface-e. Még mindig nem értem, mi ezzel a baj.

Megint hülye példa: a hangkártyát is kikerülheted, hiszen a hangszóró 3.5 mm-es jack-ébe egyből tudsz audio jelet küldeni. Akkor most kezdjünk azon sírni, hogy micsoda szemétség, hogy kell a számítógépbe hangkártya, amikor hangot enélkül is tud a hangszóró?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Tenyleg botrany.
Ha elfelejtek egy exit 0-t tenni kikapcsolas elott az /etc/init.d/networking fileba, akkor szoptam, bootolhatok vmi live cd-rol, hogy beleirjam es egyaltalan be tudjak bootolni.

--
http://www.micros~1

Nem lehet, hogy inkább úgy kellene közelíteni a kérdéshez, hogy a desktop linux audio alrendszere a Pulseaudio? A Skype pedig ezt használja, mert hangot ad és fogad.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Csak mint laikus kérdem: miért is kell egy működő rendszerhez egy újabb réteget csinálni és azt használni? Hogy bonyolultabb legyen és ne működjön?

Poettering leírta. Vannak olyan interface-ek, amelyeknél egész egyszerűen nem nagyon lenne kezelhető mondjuk 128 potméter, aztán egyszerűbb az API-ja, alkalmazásonként lehet hangerőt állítani, szükség esetén megcsinálja a resampling-et, virtuálisan több device-ra vághatod a hangkártyádat, de több hangkártyából is csinálhatsz egyet. Ezen felül az algoritmus olyan, hogy a lehető legkisebb latency legyen úgy, hogy ne legyen buffer underrun. Van hálózati interface-e is.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Idézet:
Van hálózati interface-e is.

+1, X2Go-val nagyon kényelmesen működik is.

BlackY
--
"en is amikor bejovok dolgozni, nem egy pc-t [..] kapcsolok be, hanem a mainframe-et..." (sj)

De én csak zenét szoktam hallgatni, illetve ha kell megvágom audacity-vel. Erre elegendő az ALSA is. Nem?

Jó, de a programozónak helyesen az a célja, hogy minden platformon menjen a dolog, az nem jó megoldás, hogy a tipikus desktop gépekben jó, máskor meg nem. Tehát legyen a felület általános.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Ha van pulseaudio akkor kell a vlc-pugin-pulse csomag, különben pl. amarok is elkussolhat :-DD

--------

Nem vezetek...Jobb így. Nekem is
meg mindenki másnak is.

Ezt nézted már?
https://wiki.debian.org/skype

(Az apt-get-ből debianra tippelek.)

Nekem több Linuxos gépen megy gond nélkül mind a Skype, mind a pulseaudio. (Fedora és Debian gépek, 5-6 desktop és laptop.)

A pulse megy "nem-sztenderd" konfigon is: HTPC Debian alaprendszeren, szóval nem hinném, hogy azzal lenne a gond.

Csaba

Igen, megvolt, de sajnos semmi eredmény. Azért köszönöm.

Nekem meg a legujabb Lunixos Skype olyat csinal, hogy be vagyok jelentkezve, es nem csongok ki, hanem kapok a vegen egy ertesitest hogy van uj voicemailem. Ki-bekapcs megoldja, de idegesito, es panaszkodnak hogy nem tudnak hivni azelott, mikor be vagyok jelentkezve. OS X-en meg iOS-en mukodik rendesen, kisebb bugokkal, de azokon is indokolatlanul lassu neha, mar csak a Facebook lassabb nala iOS-en. A Win8-as metros Skype meg atan tenyleg nevetsegesen rossz, egy hatalmas UX failure. Egyre nagyobb hulladek, igenis lehet ezert az MS-t hibaztatni. Foleg, hogy regen teljesen jo volt, minden platformon.

No erre próbáltam célozni. És a worksforme jellegű hozzászólások nem igazán töltenek el örömmel. Windows alatt egyébként nekem is works...

1. Ha nem skype-ot használsz, hanem bármi mást / valami parancssori cucc is megteszi, lényeg, hogy hangot vegyen fel /, akkor megy a microphone ??

Ha mással megy, akkor nincs ötletem, nem skypolok. Úgy tűnik a skype-ban kell valamit állítani..., vagy pavucontrol -al a pulseadioban...:-)

(http://www.debianhelp.co.uk/skype.htm)
Innen szedted a skype-ot ?

Itt vannak pulseadio-s tippek:

https://wiki.debian.org/skype

----------------

1a.

Ha mással sem megy, próbáld meg ezt, vagy google alapján amelyik a cuccodban levő realtek chiphez kell.

options snd-hda-intel model=3stack-dig

az etc/modprobe.d-ben az egyik fájlban. Ha van sound.conf célszerű abban.

2. alsamixer-ben azon túl hogy 100-on vannak a felvételi opciók "SPACE"-el ki is választottad, hogy vegyen is fel ?
alsamixer-ben F5 kiadja az összes opciót, amelyiknél szaggatott vonalat látsz space-el ki tudod választani felvételre, illetve ha van "Input Source", akkor az lehetőleg az a dugasz legyen,
ahova a mikrofont bedugtad.

A snd-hda-intel model típusváltás változást idézhet elő a hangerőszabályzó elemeiben, okozhat meglepetéseket. :-))

Általában nem nagyon kell piszkálni BIOS alapján jó 50-60%-ban eltalálja a kernel modul, hogy mi kell, a probléma az, hogy a debian kernel 3.2-re épül, ami alapvetően 2 éves alapokon nyugszik, a hw támogatás nem minden esetben kerül bele megfelelően a 3.2-es kernelfába (sem). ;-)

Ha a cuccod 2 évnél újabb, vagy nem sokkal régebbi, mint 2 év, akkor szükséges lehet ilyen kernel modul finombeállítás.

2b. a debian wheezy backport tárolót felveszed, és felteszel onnan egy 3.1x. újabb linux-image csomagot, hátha az már jobban kezeli a gépedben levő hangcsipet.

--------

Nem vezetek...Jobb így. Nekem is
meg mindenki másnak is.

Vicces. Mondom telepítsünk repópól. Felvettem a sources.list-be telepítem, és a 4.2 települ. Ami pedig egyszerűen be sem enged lépni.
A hangkártya tippeket köszönöm, még megnézem mit tudok állítani rajta, de pl. az audacity-vel is próbáltam felvenni hangot (hint: belső mikrofont szeretném használni!) és érdekes módon veszi a hangot, legalábbis látom, hogy kirajzolja a hullámokat. De lejátszani nem játssza le. Holott, ha megnyitok egy random mp3 állományt, az hiba nélkül visszajátssza. Lehet, hogy a pulse rossz helyre küldi a bemenő jelet?
Mit nem veszek észre?

veszi a hangot, legalábbis látom, hogy kirajzolja a hullámokat. De lejátszani nem játssza le.

Valami egyszerűbb ALSA-s parancssori gönccel kellene felvenni / ami nem "pulse"-al :-), és nem vezet félre grafikai hullámozással :-)) /.

Ha mással sem tudsz felvenni, akkor jó eséllyel nem a skype-al van gond. /vagy nem csak :-D /

http://linuxconfig.org/how-to-test-microphone-with-audio-linux-sound-architecture-alsa

- Valami az alsamixer-ben nem lesz jó szerintem, vagy az "input source" nem jó, vagy csak hangereje van a micro-nak 100-ra állítva, de nincs "Capture L/R"-el kijelölve (SPACE) gomb felvételre, vagy rossz a model típus az snd_hda modulban, akkor viszont először azt kell javítani.

Esetleg be lehet nézni a var/log/kern.log -ba hátha nyüszög valami használhatót a snd_hda modulról, de ez nem túl valószínű.

- Ha ALSA-val jó, de a pulzussal nem, az egy fokkal jobbik eset, akkor csak a pulzusban nem passzol valami. (pavucontrol)

--------

Nem vezetek...Jobb így. Nekem is
meg mindenki másnak is.

Nagyon szépen köszönöm a segítséged!

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf7cf8000 irq 44

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Sajnos a felvétel nem sikerült, illetve hangot nem játszik vissza. A hiba az alsa környékén van. Bár eddig jó volt.

terminal: alsamixer -> F4(Capture) -> z billentyűvel csökkentsd le a Capture bal csatornáját-t 0-ra vagy c-vel a jobbat, esetleg a ; és ' billentyűkkel válaszd ki, hogy melyik legyen a felvételi forrás

Az MS bekaphatja: +1

Egyébként meg leszarom milyen hangrendszer van a gépemen, amíg ha rákattolok a kedvenc zenémre, az dübörögni kezd az 5.1-esen...

--
Fontos! Ha berágok, nem feltétlen személyed ellen szól...
openSUSE 13.1 x86_64

> lesz*rom az egészet, de azért az MS jól dögöljön meg, mert csak

kthxbai

Te legalább érted ;)

--
Fontos! Ha berágok, nem feltétlen személyed ellen szól...
openSUSE 13.1 x86_64

Még egy ok, hogy a skype-ot mindenki elkerülje, mint a pestist.

mondj helyette jobbat, amihez nem kell Linux alatt a pulseaudio...

--
"A politikat, gazdasagot es a tobbi felsorolt faszsagot leszarom, amig engem nem erint (nem erint)" (bviktor)

Még mindig nem értem, mi a gond a pulseaudioval. Gondolom, akkor a systemd is hülyeség, a NetworkManager is, meg persze az udev. Mert ezek mind az utóbbi évtized fejlesztései.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Még mindig nem értem, mi a gond a pulseaudioval

a jo hir az, hogy mar nem is fogod megerteni, sebaj. Talalj ki egy locsemeges semmi koze hozza hulye peldat, aztan egybol jobban erzed magad tole...

--
"A politikat, gazdasagot es a tobbi felsorolt faszsagot leszarom, amig engem nem erint (nem erint)" (bviktor)

>>Gondolom, akkor a systemd is hülyeség, a NetworkManager is, meg persze az udev.

pontosan
_____________________________
Powered by 1,3,7-trimetilxantin

Ha nem is huyleseg, de gaz dolgok. Na, majd husz ev mulva talan rendesen mukodnek.

--
http://www.micros~1

Jól rátapintottál. Ezért ne próbáld megérteni miért. :)

Azért írhatnál érveket is, mi ezekkel a baj. Vagy tekintsük úgy, hogy minden kész, minden jó, már egyetlen sort sem kell írni az oprendszerbe, mert készen van?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Nekem semmi bajom ezekkel, de vannak, akik nem szeretik a változást és ezt többnyire így fejezik ki.

Ja, ha szubjektív véleményről van szó, az más. Magam is hajlamos vagyok konzervatív nézeteket vallani, nem szeretem, amikor felborítják azt, amit végre megtanultam, tudok.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Google Hangouts, de az szarabb. :)

Viber for Linux? ;)

Szabvanyos SIP? Igaz azzal leginkabb csak rendszergazdakkal fogsz tudni beszelgetni.