Apache+virtualhost F***

Fórumok

Apache+virtualhost F***

Hozzászólások

Hi!

Mielőtt élesbe állítottam rendszert 4x telepítettem újra és
teszteltem le a beállításokat meg a gépet, hogy minden
rendben van-e, stb....

Mégis megfogott!

Teszt alatt jól működött az Apache <VirtualHost> lehetősége,
most meg sz***t ezerrel.

Probléma:
-Debian 3, DNS(bind9 name szerver), Apache
-2 domain tartozik a géphez(tesztnél 8-at használtam és minden működött), 1 IP cím van
-van egy www.valami.hu címem a megfelelő DNS bejegyzéssel
-van egy www.masik.hu cím a megfelelő DNS bejegyzéssel

A httpd.conf -ban pedig:
LoadModuel vhost_alias_module /usr/lib/apache/1.3/mod_vhost_alias.so
Include /etc/apache/virtualhosts.conf

/etc/apache/virtualhosts.conf tartalma
NameVirtualHost 192.168.0.37

#valami.hu
<VirtualHost 192.168.0.37>
DocumentRoot /home/www/valami
ServerName valami.hu
ErrorLog /var/log/apache/valami.hu-error.log
CustomLog /var/log/apache/valami.hu-access.log combined
Alias /labda/ /home/www/valami/labda/
</VirtualHost>

<Directory /home/www/valami>
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
Addhandler cgi-script .cgi .pl
DirectoryIndex index.cgi index.html
</Directory>

#masik.hu
<VirtualHost 192.168.0.37>
DocumentRoot /home/www/masik
ServerName masik.hu
ErrorLog /var/log/apache/masik.hu-error.log
CustomLog /var/log/apache/masik.hu-access.log combined
</VirtualHost>

<Directory /home/www/masik>
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
Addhandler cgi-script .cgi .pl
DirectoryIndex index.cgi index.html
</Directory>

A gépet mind a kettő domain-re lehet pingelni.

Ha http://valami.hu/ -t írok a böngészőbe
bejön a home/www/valami tartalma.
Ha pedig beírom, hogy http://masik.hu/
AKKOR IS a home/www/valami tartalma jön be!!!!!! 8O

Ez meg hogy lehet, mit ronthattam el?????
Apache restart is volt, de az sem javít rajta!!
Miért van hogy az előző 4 telepítésnél ment a dolog?
Mindegyik telepítés apt-get-el ment, majd utána mcedit.

Azt a ........................

Érdekes, most hogy 3-szor restart apache legalább
a masik.hu-ra nem a valami.hu jön be.
Már csak a www.masik.hu-ra jön be a www.valami.hu.

Mulder ügynök, hozna egy kávét :?:

a masik.hu virtual hostot bovitsd ki valami ilyesmivel:
ServerAlias www.masik.hu

amugy meg apache doksi olvas.

Olvasásnak itt nincs értelme :), ezt kell tenni ezzel hogy okes legyen szerintem :

#masik.hu
<VirtualHost masik.hu>
DocumentRoot /home/www/masik
ServerName masik.hu
ErrorLog /var/log/apache/masik.hu-error.log
CustomLog /var/log/apache/masik.hu-access.log combined
</VirtualHost>

Most nézem a másik is rosszul van hehe az meg :

#valami.hu
<VirtualHost valami.hu>

Ha ip-t irsz annak szerintem akkor lenne értelme ha több ip-d lenne.
de itt alapvetően a hostok alapján különbözteted meg öket.
Remélem sikerült valami okosat írnom hehe, annyira igyekeztem :).

Köszönöm a hozzászólásokat, a probléma már megoldódott,
valahogy úgy hogy, RTFM, RTFM, RTFM, RTFM, RTFM, RTFM,
RTFM, RTFM, RTFM, RTFM, RTFM, RTFM, RTFM, RTFM, RTFM,
RTFM, RTFM, RTFM, RTFM, RTFM, RTFM, RTFM, RTFM, RTFM.......