Ubuntu kernel függőségi hiba

 ( valek | 2011. december 5., hétfő - 14:37 )

Szervusztok!
Ubuntu 10.04 Lucid Lynx, gnome.
Nem emlékszem sajnos, de a sok automatikus frissítés valamelyike után a következő hibába ütődik az orrom minden telepítésnél:
Hibák történtek a feldolgozáskor:
linux-image-2.6.32-34-generic
linux-backports-modules-alsa-2.6.32-34-generic
linux-image-2.6.32-35-generic
linux-backports-modules-alsa-2.6.32-35-generic
linux-image-2.6.32-36-generic
linux-backports-modules-alsa-2.6.32-36-generic
linux-backports-modules-alsa-lucid-generic
linux-image-generic
linux-generic
linux-image
grub-pc
grub2
E: Sub-process /usr/bin/dpkg returned an error code (1)

Érdekes, hogy ettől függetlenül bootol a gép. Ellenben live CD-n keresztül leszedtem az összes mindent, a ennek ellnére csak akkor indul el, ha ilyen hibásan települve is bár, de a 34-es és 35-ös végű kernel fent van.
Igaz le is fagy szépen kiszámíthatatlanul a rendszer .
A csomagtárolókat szépen leirtottam mind, gondolom az eredeti források vagynak fent.

Hogy lehet kiirtani belőle a korábbi kerneltelepítések rossz hagyományait? Vagy már sosem tudom rendesen ráhúzni a gépre?

Mitől szokott ez előfordulni?
Köszönöm szépen előre is, ha segítetek a megoldás felé vezető rögös úton járni. Őőő. :)

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Ha megnézed az általad írt hibaüzenetet, ezt látod:

  Running postinst hook script /usr/sbin/update-grub.
  /etc/default/grub: 9: splash: not found
  User postinst hook script [/usr/sbin/update-grub] exited with value 127

Nincs splash. Tehát először nézd meg azt a hivatkozott 9. sort, majd javítsd ki. (Ehhez támpont a hibaüzenet és a Google.)

Köszönöm szépen stra a kézi vezérlésed!
A legkisebb bajokkal elvacakolok egy hétig is. Ezzel is.
Pedig csak figyelni kéne csöppet.
A korábban félreszerkesztett /etc/default/grub fájlban kicseréltem a 9. sort ez alapján az eredetire, és csodák csodája szépen megy.