SUSE Linux

Opensuse Leap frissítés 15.3 -> 15.4 ntfs csatolás rw -> ro

Fórumok

Sziaszok!  Az egyik önkori cégnél főleg opensuse van a gépeken, régen volt egy windows "szerver" az abban lévő 6TB HDD volt megosztva, oda mentett mindenki. A windows gép kiselejtezve, a 6TB HDD, majdnem 4TB adat van. Egy infó tanár viszi ott a "boltot". Eddig opensuse Leap 15.3 volt a gépeken amiket 15.4-re frissített. Állítólag így volt felcsatolva az ntfs HDD ahogy a bemásolt fstab-ban látható, mindenki tudott bele írni, most csak a root. Erre mi a megoldás? 2 órát gugliztam kipróbáltam vagy 20 verziót de írni nem sikerül rá.  Mi lehet a megoldás? 

UUID=3254f30a-10a2-41b8-9dca-a85b772c7ad1  /                        ext4  defaults             0  1 UUID=c5397209-2ada-469e-9c01-bb1224df42fa  /home                    ext4  data=ordered         0  2 UUID=D6F82842F82822EB                      /home/megosztva    ntfs  fmask=113,dmask=002,umask=000  0  2 UUID=0b094a07-41ab-4818-82a2-b4dbca5e195f  /home/utilok     ext4  data=ordered         0  2 UUID=2136e867-c598-4f43-8008-87b2b70add91  /home/torrentek  ext4  data=ordered         0  2 UUID=40a2b76d-436a-4d5e-b956-f8d285a7d8b9  swap                     swap  defaults             0  0 UUID=527cf0c2-8c16-42c3-afad-dbd420267539  /boot                    ext4  data=ordered         0  2 UUID=CB8A-1F4A                             /boot/efi                vfat  utf8                 0  2

Salt SLS futtatása SUSE Managerel

Fórumok

Sziasztok!

 

Az alábbi salt SLS fájlal akarom betenni a linux szervereket (OpenSUSE) domainbe (AD)
 

A gond az, hogy a hostnev beallitas utan (ez ez python script, ami a VMware python modul segitsegevel lekeri a VM nevet es azt allitja be hostnevnek) kellene egy restart, hogy a gep folvegye az uj nevet.

Viszont ha jol olvasom, salt-ban nincs arra opcio, hogy egy felbemaradt folyamat restart utan folytatodjon... 

Vagy megis es en nem taltam?

Ui: Az is megoldas lehet, ha valahogy ra tudnam venni az OpenSUSE-t hogy restart nelkul felvegye az uj domain nevet, de ez anno a CentOS servereimmel sem sikerult...

Itt az sls fájl:

###Install vmware connector###  
python3-pyvmomi:
  pkg.latest

###Change hostname###
'curl http://10.51.38.74/pub/hostname_change.py | /usr/bin/python3 > /etc/hostname':
   cmd.run

###Reboot###
system.reboot:
  module.run

###Install AD connection packages###
ad.packages:
  pkg.installed:
    - pkgs:
      - samba-client
      - samba-libs
      - samba-winbind

###Join Domain###
'yast samba-client joindomain domain=domain.local user=<username> password=<password>':
   cmd.run

Uyuni/SUSE Manager - AutoYaST

Fórumok

Sziasztok,

 

Uyuni alatt probalok beallitani AutoYast unattended telepitest, de nem igazan boldogulok.

 

Ha jol ertelmezem a hibauzit telepites kozben, ezzel a configgal van baja:

  <add-on>
    <add_on_products config:type="list">
      <listentry>
        <ask_on_error config:type="boolean">true</ask_on_error>
        <media_url>http://$redhat_management_server/ks/dist/child/opensuse_leap15_4-x86_64/$distrotree</media_url>
        <name>opensuse_leap15_4-x86_64</name>
        <product>opensuse_leap15_4</product>
        <product_dir>/</product_dir>
      </listentry>
     </add_on_products>
  </add-on>

 

Konkretan a <product> szakasszal.

OpenSUSE-t telepitenek, sajnos minden leiras SUSE Enterprise ra van, sehol nem talalom, OpenSUSE alatt mi a Product, amit oda kell irni.

 

Eddig Uyunival Centost, meg Ubuntut hasznaltam, ahhoz Kickstart kellett, azt mar eleg jol megismertem, de most gondoltam ha mar uyuni, akkor, a regi 18.04-es Ubuntukat, meg 7-es Centoseket mar OpenSuse-re migralnam...

CUPS-PDF karakter kódolás iconv segítségével

Fórumok

Sziasztok, CUPS-ban jártasak segítségét kérném. Van egy ősrégi ERP szoftverünk, ami CP-852 kódolást használ. A host, amin fut HU_hu a locale. Feltelepítettem a CUPS-PDF-et, dolgozik is szépen, de az ERP-ből érkező nyomtatásokkal nem tud mit kezdeni, ott nem jelennek meg az ékezetes karakterek. Utánaolvasva készítettem egy egyszerű filtert, aminek a nevét beletettem a cups-pdf ppd leírójába. Maga a filter meghívódik, de üres pdf a kimenet. Többféle verzióban is kipróbáltam a filtert, de az istennek sem akar sikerülni. Hogyan lehetne ezt működésre bírni?
A filter program:


...
echo "DEBUG: texttops argv[$#] = $@" >&2
echo "DEBUG: PPD: $PPD" >&2

if [ $# -lt 5 -o $# -gt 6 ]; then
    echo "ERROR: $0 job-id user title copies options [file]" >&2
    exit 1
fi

# Read from given file.
FILENAME=$(basename $6)
DIRNAMES=$(dirname $6)
echo "DEBUG: sending data $FILENAME to $DIRNAMES ..." 1>&2

if [ -n "$6" ]; then
# Ez működik. A mentésre kerülő file jó ékezetes karaktereket tartalmaz
iconv -s -c --from-code=CSPC850MULTILINGUAL --to-code=WINDOWS-1252 --output=/tmp/$FILENAME $6
# Ez nem működik. Üres PDF a kimenet.
cat - | iconv -s -c --from-code=CSPC850MULTILINGUAL --to-code=WINDOWS-1252 $6
 exec <$6
fi

Az is egy lehetséges megoldás lehetne, ha a MIME típus alapján hívódna meg a filter, sőt még jobb is lenne, hiszen csak akkor hívódna meg, ha ténylegesen tartalmazza a nyomtatás az elfuserált ékezetes betűket, de ott is egy működő filter kellene. Ötletek? Köszönöm előre is a segítséget!

A hálózati interfészek indexelése

Fórumok

Sziasztok!

Van egy hálózat menedzsment programom (https://github.com/csikfer/lanview2) ebben ütköztem abba a problémába, hogy a hálózati interfészek indexe (ifIndex) változó. Minden rendszertöltés után más értékeket kapnak a VLAN interfészek, függetlenül a netplan konfigben megadott sorrendtől. A program viszont arra számít, hogy ezek nem változnak, és az újra számozás sem triviális.

A legjobb az lenne, ha a rendszernek (Ubuntu 20.04) valahogy meg lehetne adni az interfész indexeket, vagy legalább a sorrendet kikényszeríteni. Sajnos erre még ötletem sincs.

Az is egy lehetőség, hogy boot után újraírom az indexeket az adatbázisban (Postgresql 12). De nem vagyok egy SQL guru, és nem tudom, hogyan lehet a port rekordok törlése nélkül átírni az egyedinek definiált indexeket. Ha elkezdem átírni az ifIndex értékeket, akkor amíg a végére nem érek, addig sérülni fog az egyediség. Ha letörlöm, és újra írom a rekordokat, az a relációk miatt nem jó megoldás, mert vagy törölni kell azokat is, vagy sikertelen a törlés. Vannak nyakatekert ötleteim, de érdekelne, hogy erre van-e valami szimpatikusabb megoldás?

Kevés hely a root partíción

Fórumok

Sziasztok!

A segítségeteket kérem. A root partícióm (sda6) 40 GB, a home (sda7) 32, és még ezen kívül van másik 3. Tumbleweed, Lenovo T410.

Már többször előfordult, hogy egy-egy nagyobb frissítésnél gyakorlatilag teljesen elfogyott a hely a root partíción (btrfs). Ilyenkor a zypper clean, a snapper cleanup number, és a zypper purge-kernels parancsokat futtattam, néha elsőre, néha ötödjére, de valahogy csak helyreállt a világ rendje, és visszakaptam az elfoglalt területet. Nagyjából 8 GB szabad helyem volt már elég régóta. Ám a legutóbbi frissítés óta (2-3 hete) nem kaptam vissza, akármit csinálok. Egy tutac parancsot lefuttattam már a szokásosokon kívül, ahol lehetett, tájékozódtam, de semmi nem oldotta meg a problémát (árva csomagok törlésétől kezdve a tmp ürítése stb.).

Most folyamatosan 350 és 90 mega körül mozog a rendszer.

1. Van-e még esetleg tippetek, hogyan kaphatnám vissza az elfoglalt területet?

2. Az egyik partíciót (sda2, 70GB) leformáztam btrts-re, hozzá tudom toldani a root-hoz adatvesztés és bármilyen egyéb probléma nélkül?

Minden tippet köszönettel veszek!

Eszköz     Indítható     Start      Vége Szektorok  Size Id Típus
/dev/sda1                 2048 145035263 145033216 69,2G 83 Linux
/dev/sda2            145035264 290027519 144992256 69,1G 83 Linux
/dev/sda3            290027520 444850175 154822656 73,8G  f W95 kiterj. (LBA)
/dev/sda4  *         444850176 624110761 179260586 85,5G  7 HPFS/NTFS/exFAT
/dev/sda5            373917696 378111999   4194304    2G 82 Linux lapozó / Solaris
/dev/sda6            290029568 373915647  83886080   40G 83 Linux
/dev/sda7            378114048 444850175  66736128 31,8G 83 Linux

-------------------------------------

sudo snapper ls  

                     
   # | Típus  | Előtti # | Dátum                                   | Felhasználó | Használt terület | Tisztítás | Leírás                | Felhasználói adatok
------+--------+----------+-----------------------------------------+-------------+------------------+-----------+-----------------------+--------------------
  0  | single |          |                                         | root        |                  |           | current               |                     
  1* | single |          | 2018. febr. 11., vasárnap, 12:24:57 CET | root        |        68,25 MiB |           | first root filesystem |                     
1394  | pre    |          | 2022. jan. 7., péntek, 16:57:11 CET     | root        |         1,86 GiB | number    | zypp(zypper)          | important=yes       
1395  | post   |     1394 | 2022. jan. 7., péntek, 17:20:24 CET     | root        |        18,18 MiB | number    |                       | important=yes       
1396  | pre    |          | 2022. jan. 10., hétfő, 15:40:19 CET     | root        |        37,34 MiB | number    | zypp(zypper)          | important=yes       
1397  | post   |     1396 | 2022. jan. 10., hétfő, 17:33:42 CET     | root        |         1,12 GiB | number    |                       | important=yes       
1406  | pre    |          | 2022. jan. 31., hétfő, 08:54:52 CET     | root        |       524,00 KiB | number    | yast online_update    |                     
1407  | post   |     1406 | 2022. jan. 31., hétfő, 08:55:38 CET     | root        |       504,00 KiB | number    |                       |                    

 

CUPS print over internet

Fórumok

Káosz van a fejembe, elbizonytalanodtam, a segítségeteket kérném!
Adott egy bérelt vonali hálózat, VPN hálózattal (telephelyek vidéken), a központban egy Cisco router a végpont, fix külső IP-vel.
A központban, a local neten csücsül egy SUSE Leap 15.3 + CUPS, ez a központi gép, ezen fut a linuxos(!) ERP rendszerünk, és ez miatt muszáj minden nyomtatót a linux alá (is) telepíteni, hogy az ERP-ből lehessen nyomtatni rá.
A nyomtatók nagy többsége IP alapú, xxx.xxx.xxx.xxx:9100 eléréssel.
Van egy olyan telephely, ami nincs bekötve a VPN hálózatba. Korábban az OpenVpn-t használtuk itt Windows megosztott nyomtatóval, ami fel volt véve a központi gépen (samba) a CUPS alá, de állandóan gond van vele, gyakran felakadt a CUPs, ha nem futott az OpenVPN.
Most erre a telephelyre kértünk fix IP-t, és azt szeretném kipróbálni, hogy a telephelyen port forward-dal átengedem a három nyomtatót a helyi routeren(tp-link) és a központi telephelyen pedig kérem a szolgáltatót, hogy a CISCO routeren szintén forwardolja a bejövő csatlakozást a központi SUSE gépre... de hova, melyik portra? A 9100-as portra?
Meg lehet ezt valósítani? Hogyan? A telephelyi nyomtatókat milyen portra irányítsam a TP-Linken?
A központba, a CISCO mit továbbítson a központi gépnek? Ez nekem most hirtelen káosz, hiszen minden nyomiga a 9100-as porton figyel...
Köszönöm előre is, ha időt szánsz rám!

A MEGOLDÁS: Egyszerűbb lett, mint gondoltam. A tanácstalanságom oka az volt, hogy a CUPS szerver egy CISCO router mögött csücsült egy NAT-olt belső hálózaton,  míg a nyomtató egy sima fix IP-s előfizetéses elérésen, szintén NAT-olt belső hálózaton. A megoldáshoz elég volt a printer oldali routeren beállítani a port forwardokat, és a CUPS így már gond nélkül elérte, a szerver oldalon nem kellett semmilyen hókuszpók.

Köszönöm a segítő hozzászólásokat!

Touchscreen vs Gnome3

Fórumok

Üdv!

Van egy xplore ix104c5 típusú játszós táblagép, aminek a touchscreen beállításnál elakadtam. GNOME3 alatt, a Wacom Tablet beállításánál jelzi, hogy van, kalibráció viszont nem működik. A tollját érdekesen kezeli, amikor az üres képernyőre érintem, akkor a jobbgombos menü jön fel, a beállítás menüben viszont akárhova bökök a tollal a menüben lépked. Fájlkezelőben kijelöli az ikont. De a felső soros menübe viszont már nem lépked. Ablak kezelésnél a bezár gombot csak kijelöli, de bökhetek többet, vagy tarthatom hosszan, nem történik semmi. A képernyőbillentyűzeten hasonló, csak kijelöli a gombot, de nem történik meg a beírás.

Kutattam már minden létező beállítást, konfigfájlt, de kifogytam. Ha másik DE-vel biztosan működik, akkor az is megteszi, igazából a cél az, hogy egy Chrome böngésző fusson, illetve azért belépni, kilépni lehessen. Van valami ötlet?

XScreenSaver démon auto indítása

Fórumok

Sziasztok!

 

Nem vagyok Leap 15.2 ben otthon, viszont van egy laptop amin automatikusan indítani kellene a képernyővédőt. Most minden újraindításkor amikor indítva van kézileg, ezt hozza elő:

Az XScreenSaver démon nem fut ezen a képernyőn: ":0.0".  Elindítsam most?

Hogyan tudnám beállítani, hogy automatikusan fusson?