[megoldva] abevjava + dwm = semmi

 ( BellMiner | 2010. június 27., vasárnap - 21:55 )

hello!

az abevjava 2.12.0 programot szerettem volna használni a napokban.
dwm 5.8.2, Xorg 1.8.1.902 alatt. amikor elindul a gui, semmilyen vezérlő elem nem jelenik meg, csak nagy szürkeség.
az alábbi paranccsal indítottam:
$ java -jar abevjava_install.jar

tiling és monocle módban is így viselkedik, átméretezni sem engedi az ablakot. a kis ablakok viszont, mint a "valóban létre akarja hozni a könyvtárat?" rendesen megjelennek.

ezután vakon kattintgatva a szürkeségben sikeresen telepítettem a programot, de maga a program is hasonlóan viselkedik, így használhatatlan.
másik, de ugyanolyan archlinuxot futtató ugyanolyan gépen, gdm és gnome alatt jól működik a gui.

van ötletetek, hogyan lehetne kiküszöbölni ezt a hibát?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

java -version kimenete is egyforma a kettő gépen?
--
http://opensolaris.org/os/project/indiana/
http://www.opera.com/browser/

bocs, ez lemaradt. igen:

$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Server VM (build 16.3-b01, mixed mode)

Vizsgáld meg, hogy milyen shell, terminál alól indítod itt és ott.
--
http://opensolaris.org/os/project/indiana/
http://www.opera.com/browser/

java feature, hogy nem egy wm alatt renitens a gui, és workaroundolni kell.. :(
google://dwm java

export AWT_TOOLKIT=MToolkit
export GDK_NATIVE_WINDOWS=true

Legalábbis awesome alatt ez a "workaround".

Ha az MToolkit nem jó, akkor még az XToolkit-et is próbálhatod.

ez sikerült, működik!

köszi! :D