Qt + Openembedded

 ( martonmiklos | 2010. február 13., szombat - 20:41 )

Próbálta már valaki a $SUBJECT-ben említett mutatványt előadni valamilyen !x86 vasra?

Eljutottam odaáig bő két nap hekkelés után, hogy lefordult minden flottul, a vason fent vannak a Qt libek.
Öröm.

Ezután jött a feketeleves. Eleve gyanúsnak találtam, hogy a Qt kétszer fordult le.
Egyszer az arm targetre, egyszer pedig x86_64 tagetre. Biztos ki lehetett volna váltani ASSUME_PROVIDED-el, de mindegy.

Előveszem a Qt Creatort betallózom az elkészült qmaket, fordítanék erre közli, hogy nem találja a default mkspect a
/opt/oeroot/tmp/staging/x86_64-linux/usr/mkspec
No itt kezdett büdös lenni a dolog.
Kiderült, hogy az általam használt qmake egy symlink az x86_64-es bin mappába, ami ugye a qt4-tools-native csomag birodalma.

Végül megadtam neki a kívánt mkspeceket defaultként egy symlinkkel a linux-gnueabi-oe-g++ mappára. Így a qmake lefut, azonban az elkészült Makefileval nem tudok mit kezdeni, mivel a sima make nem viszi őket a gondolom a hiányzó OE_QMAKE_CC és társai miatt. Ezeket honnan kellene vennie? Gondolom a qmake venné ki a megfelelő mkspecből.

A dolog új számomra, eddig avr32-re buildrootot használtam ami sokkal emberbarátibb, illetve a Qt flottul működik vele. Sajnos nem tudtam neki külső gites kernelfát megadni, így tértem át openembeddedre. Ha az utóbbi problémámra tud valaki gyógyírt szívesen venném.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

"Így a qmake lefut, azonban az elkészült Makefileval nem tudok mit kezdeni"

Mi a hibauzenet pontosabban ? Btw, ilyen qtopia-s dologgal probalkozol, Miklos ?

http://djszapi.homelinux.net