[Megoldva]Lenny ssh probléma

 ( szume | 2009. február 23., hétfő - 10:42 )

Frissítettem egy gépet lenny-re. Azóta nem mindenkinek fogadja el a jelszavát ssh-n. Az auth ldapból megy. Nem függ csoporttól. A rendszergazdák közül csak az egyiket engedi be, viszont a simple userek közül is beenged. Akit nem enged be, ott azt írja, hogy rossz password.
Van valakinek tippje, hogy merre induljak el?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Az auth.log -ban is az van irva, hogy bad password?

--
The Net is indeed vast and infinite...
http://gablog.eu

Ezt írja:
pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=....
Failed password for ...

a /etc/pam.d/ssh rendessen be va love ldaphoz?
az /etc/libnss.ldap ban nezz be,
ide vago resz pl:
pam_password md5

de mivel van akinel jo van akinel rossz ezert azt mondom
az ldap ban a password alapbol crypt nezd meg egy olyannal aki
belep es olyannal aki nem. (ott lehet h md5)
a lenyeg a passwd kodolas egyforma legyen.

Szijártó Zoltán
Aki tud az alkot, aki nem tud az csak szövegel.

- Azon usereknek hogy van az LDAP-ban a jelszava, milyen kodolassal? Esetleg plaintext?
- auth.log mit ir?
- Ha bekapcsolod a logolast a slapd.conf-ban nincsenek furcsa queryk ezekre az userekre?
- LDAP adatbázis teljesen oké? Logokba nem sír?

--

()=() Ki oda vagyik,
('Y') hol szall a galamb
C . C elszalasztja a
()_() kincset itt alant.

Mindenkinek MD5-ös jelszava van.

auth log:
2 10:46:31 szerver sshd[2459]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=remote.gep user=userneve
Mar 2 10:46:33 szerver sshd[2459]: Failed password for userneve from 172.16.4.8 port 59842 ssh2

Mar 2 10:53:14 szerver slapd[28605]: filter: (&(objectClass=shadowAccount)(uid=userneve))
Mar 2 10:53:14 szerver slapd[28605]: conn=139 op=1 SRCH base="o=Domain,c=Hu" scope=2 deref=0 filter="(&(objectClass=shadowAccount)(uid=userneve))"
Mar 2 10:53:14 szerver slapd[28605]: => access_allowed: search access to "uid=userneve,ou=People,o=Domain,c=hu" "objectClass" requested
Mar 2 10:53:14 szerver slapd[28605]: => acl_mask: access to entry "uid=userneve,ou=People,o=Domain,c=hu", attr "objectClass" requested
Mar 2 10:53:14 szerver slapd[28605]: => access_allowed: search access to "uid=userneve,ou=People,o=Domain,c=hu" "uid" requested
Mar 2 10:53:14 szerver slapd[28605]: => acl_mask: access to entry "uid=userneve,ou=People,o=Domain,c=hu", attr "uid" requested
Mar 2 10:53:14 szerver slapd[28605]: => access_allowed: read access to "uid=userneve,ou=People,o=Domain,c=hu" "entry" requested
Mar 2 10:53:14 szerver slapd[28605]: => acl_mask: access to entry "uid=userneve,ou=People,o=Domain,c=hu", attr "entry" requested
Mar 2 10:53:14 szerver slapd[28605]: => access_allowed: read access to "uid=userneve,ou=People,o=Domain,c=hu" "uid" requested
Mar 2 10:53:14 szerver slapd[28605]: => acl_mask: access to entry "uid=userneve,ou=People,o=Domain,c=hu", attr "uid" requested
Mar 2 10:53:14 szerver slapd[28605]: => access_allowed: read access to "uid=userneve,ou=People,o=Domain,c=hu" "userPassword" requested
Mar 2 10:53:14 szerver slapd[28605]: => acl_mask: access to entry "uid=userneve,ou=People,o=Domain,c=hu", attr "userPassword" requested
Mar 2 10:53:14 szerver slapd[28605]: conn=139 op=1 ENTRY dn="uid=userneve,ou=People,o=Domain,c=hu"

Senkinek nincs több ötlete?

De vót. :)
--
George

Köszönöm. Végülis az egyik pam.d/ file-ban volt a hiba.

pubkey_auth nem játszik?