RoundCube ékezet probléma - (MEGOLDVA)

Sziasztok!

Van egy kis problémám a levelezésem webes felületével (ubuntu 7.10-Postfix-Courier-mysql-Amavisd-SpamAssassin-ClamAV)

Ha a feladó nevébe ékezetes betű van és nyomok 1 reply-t a levélre akkor a címzettethez hibás karaktereket ír be, és az emailcímet is rosszul írja bele pl:

Kóbásztóni
Az üzenetbe pedig erre próbálja címre probálja küldeni: kolbasztoni@f?==?UTF-8?Q?xxx.xx

Küldés után, jön egy content-fileteres hibaüzenet:

Your message WAS SUCCESSFULLY RELAYED to:
<?=@hostom>

The message WAS NOT relayed to:

501 5.1.3 Failed, id=01424-04, from MTA([127.0.0.1]:10025): 501 5.1.3 Bad
recipient address syntax

This delivery report was generated by the program amavisd-new at host
hostom. Our internal reference code for your message is
01424-04/rfew4+DRTub5

Return-Path:
Message-ID: <00ec7a2bbe520002434422b8e3765a9a@localhost>
Subject: =?UTF-8?Q?Re:=20K=C3=B3b=C3=A1sz?=
Reporting-MTA: dns; hostom
Received-From-MTA: smtp; hostom ([127.0.0.1])
Arrival-Date: Sun, 9 Mar 2008 09:41:47 +0100 (CET)

Original-Recipient: rfc822;kolbasztoni@f?==?UTF-8?Q?xxx.xx
Final-Recipient: rfc822;kolbasztoni@f?==?UTF-8?Q?xxx.xx
Action: failed
Status: 5.1.3
Remote-MTA: dns; 127.0.0.1
Diagnostic-Code: smtp; 501 5.1.3 Bad recipient address syntax
Last-Attempt-Date: Sun, 9 Mar 2008 09:41:50 +0100 (CET)

Meg egy sima daemon:

This is the mail system at host hostom.

I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can delete your own text from the attached returned message.

The mail system

<?=@hostom>: unknown user: "?=@hostom"

Ha kitörlöm a hibásan megjelenő karaktereket a címzett mezőböl akkor szépen elmegy.
-> Kóbásztóni <-

Email kliens progival nem jelentkezik a probléma, csak a roundcube webes felületén.

Mit nézzek át szerintetek?

Thx&Üdv : Somi

Hozzászólások

az adatbázisban UTF-8-ban vannak az adatok tárolva? Az apache UTF-8 at használ?
Én arra gyanakszom, hogy az adatbázisból nem jön át rendesen át az adat. Próbáld ki egy saját php-vel ami egyszerűen kilistázza az adatbázist. Aztán próbáld meg a query("SET NAMES 'utf8'"); opcióval az encodingot változtatva. Ha jól jön át, akkor már csak a roundcube-ot kell rávenni, hogy a lekérdezések előtt szintén állítsa be a lekérdezés paramétereként a kódolást. (Ha nincs máris egy config paraméter ehhez.)

thx, átnézegetem a jelenlegi Szerver változók és beállítások a phpmyadmin szerint:

character set client utf8 (Globális változó) latin1
character set connection utf8 (Globális változó) latin1
character set database latin1
character set filesystem binary
character set results utf8 (Globális változó) latin1
character set server latin1
character set system utf8
character sets dir /usr/share/mysql/charsets/
collation connection utf8_unicode_ci (Globális változó) latin1_swedish_ci
collation database latin1_swedish_ci
collation server latin1_swedish_ci