INIT: version 2.86 booting... es nem megy tovabb

 ( SySERR | 2007. november 25., vasárnap - 16:36 )

Tegnap nekilattam beelesiteni a `http://hup.hu/node/44383` forumtemaban levo Ralink kartyamat.
Odaig mar eljutottam hogy gep latta, modulkent be volt toltve, stb... Aztan volt egy reboot, es a `INIT: version 2.86 booting` -nal tovabb nem akar menni. E felirat megjelenese utan a vinyo meg csinal valamit kb 1 masodpercig, utana csak all es ennyi (lefagyva nincs, gombokra reagal, hibat nem ir ki, en meg csak nezek hogy mi van)
Kiprobaltam az elozo 2.6.23as kernellel, de a helyzet ugyanez.
Most egy megregebbi 2.6.18al tokeletesen megy. (meg jo hogy sose torlom le az elozo kerneleket)

Amiket eddig megcsinaltam:
- Vinyo be masik gepbe, fsck-t lefuttattam
- kernel ujrafordit, ujrarak

Help pls!

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Alt+SysRQ+Shift és akkor megkapod a lehetséges mágiuks gombokat, azokkal tájékozódj, hogy melyik process akadt le


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

Ezzel mindossze annyit sikerult kideriteni hogy meg az S01glibc -ig se jutott el.

akkor wifi kártya ki és restart, ha ígysem akkor minden ki és egyesével minden vissza és közbe reboot vagy forgass másik 2.6.22-es kernel-t és próbáld azzal wifi nélkül


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

Minden kartyat kivettem, a jelenseg ugyanaz.
Uj kernelt meg mar eleve forditani kellett, hogy mukodjon az Alt+SysRQ :P

Ami eszrevetel meg volt a wifi kartyanal amikor meg mukodott az uj kernellel:
Amikor konfigoltam a kartyat akkor kidobott a gep par PCIBUS errort meg skge kartyara is hivatkozott (en meg neztem, hogy mit akar ez, nem is nyultam hozza a benne levo gigas kartyahoz)
A gigas kartya termeszetesen tokeletesen mukodik.

Az esetleg jelenthet gondot hogy a kernelt egy tavoli gepen forditom? (az egy Core2Quad es azon emberi sebesseggel lefordul a cucc)

akkor attól függ mire optimalizálsz, mert az lehet a gond, hogy olyan dolgot optimalizál ki, ami kellene ehhez a géphez, a másik dolog, hogy a pci eszközöknél mmconfig helyett próbáld meg direct access-re tolni az uz kernelnél és ugy lehet hogy müxik


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

a build gépen au verzióju debian volt? ha nem akkor ott a gond


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

Igen, ugyanaz. Raadasul ugyanakkor volt frissitve mind2 gepen a rendszer.

Szerintem használd azt a kernelt amelyikkel megy.

Debian-etch pont a 2.6.18asat "supportálja", ha azzal megy minden, akkora maradj annál. Ha minden megy vele megfelelően és semmilyen eszköz nem igényel újabb drivert maradj annál. jóaz. megkockáztatom talán a legjobban sikerült 2.6.1X széria. :)

-----

Nem a zsömle kicsi, a pofátok nagy...

Pont a Ralink wifi kartya igenyel uj kernelt. Es az uj kernel forditasa utan el is indult gyonyoruen a gep es latta is a kartyat. Az utana levo reboot utan jottek a gondok.

akkor a ralink driver a szar. milyen reboot volt?


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

Sima mezei ctrl+alt+del

én a 22-esre esküszöm, nekem az jött be és ez is fog maradni(wifi) , a legjobb pedig, az, hogy hosszúkarbantartású kernel lett.
+ a 22-es mellett: libata stabilizálódott, tickless kernel, slub és gyorsabbnak érzena a 18-asnál


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

én sutyiban megsasoltam itten ezt a 2.6.22.14et vagy melyiket, csak azzal a +1-2%al volt gyorsabb amit a PaX patch/SEGMEXEC hiánya okozott.

ugyanis 2.6.22.14ra asszem nincs kész grsecurity, és a lirc modul is elsőre elhasalt. utóbbit valszeg könnyű lenne kikozmetikazni előzőt már kevésbé.

cserébe kapnék egy rtc-cmos.ko drivert, de mivel rászoktam a hibernálásra megy a normál /proc/acpi/alarm-ba írkálás is.

tehát több a veszteség mint amit nyernék rajta...bár ez az én spec. esetem :)

(mondjuk tény, hogy a pacsált 2.6.18asom tartalmaz némi acpi/pci--msi-x/hypertransport supportot is. lehet ha ezek nem lennének lassabb lenne, tehát ha most kellene dönteni hogy 2.6.18at "piszkáljak", vagy 2.6.22.14et akkor lehet utóbbi mellett döntenék, de így hogy már van egy "kulcsrakész", ez elbillenti a mérleget.

----------------

Nem a zsömle kicsi, a pofátok nagy...

ja ahogy elnéztem a lenny is 2.6.18-as alapon fog majd kijönni, 22-es meg most van a sid-ben


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

.config
lspci


linux v2.6.22.14 + madwifi v0.9.3.3-mal itt
debian gnu/linux @ linux-2.6.22.14-pancs1-wifi3

lspci:
00:00.0 Host bridge: Intel Corporation 82810E DC-133 GMCH [Graphics Memory Controller Hub] (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
01:03.0 Ethernet controller: D-Link System Inc Gigabit Ethernet Adapter (rev 11)
01:04.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

http://bermuda.unrealgames.hu/.config