[Sarge] Postfix upgrade 2.1 -> 2.3

 ( Dolphy | 2007. január 23., kedd - 18:49 )

Sziasztok!

Kéne nekem 1-2 feature a Postfix 2.2-ből, de sarge csomagban ugye csak 2.1 van.
Nézegettem backports.org-ot, onnan le lehet szedni 2.3.6-os postfix deb-et.
A probléma csak az, hogy egy éles rendszert kéne upgrade-elni és nincs hol kipróbálni.

Van valakinek tapasztalata ezzel kapcsolatban vagy kipróbálta már esetleg pont ezt a backports csomagot?
A másik, hogy ha esetleg valami gebasz van, amit nem tudok max 10 perc alatt megoldani, akkor hogyan tudom visszaállítani az eredeti állapotot legegyszerűbben, hogyan tudom a régi csomaggal felülírni az újat?

thx,
Dolphy

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hat, a legegyszerubb, ha a packages.debian.org oldalrol _letoltod_ a csomagot, amit frissiteniii akarsz. Ha nem jo a frissites, akkor a letoltott csomagot pakolod fel.

És az milyen, ha vissza akarom rakni a régit, akkor sources.list-ből backports kiszed, aztán apt-get install postfix-tls --reinstall?

Mindenesetre az /etc/postfix konytarat mentsd le :))

Pontosan milyen feature-re gondolsz ? Mert en is 2.1.5-ot hasznalok.

Azok az opciók, amik smtpd rate controllal kapcsolatos új cuccok.
Levelek száma kapcsolatonként pl. meg ilyenek, mindjárt megnézem neked a doksiból konkrétan.

Na ilyenek:
smtpd_client_connection_rate_limit
smtpd_client_message_rate_limit
smtpd_client_recipient_rate_limit
...
stb.

IPtables ugyan csak 5 smtp kapcsolatot enged másodpercenként, de ha egyet már nyitott a freemail mondjuk, akkor azon betolhat nekem 3000 mail delivery status üzenetet pillanatok alatt és azok mire végigmennek a spamszűrő(kö)n meg a vírusírtón, háááát.

Még ezzel kapcsolatban láttam, hogy az új postfix csomag replace-szeli a postfix-tls-t.
Belefordították ezek szerint alapból a TLS supportot gondolom, ugye?

Valtozott a queue formatum, szoval mielott frissitenel, nem art kiuriteni a queue-t. Az esetleges downgrade elott pedig egyenesen kotelezo. Egyebkent erdemes a postfix forrasban levo HISTORY, RELEASE_NOTES atolvasasa, kiternek ezekre a dolgokra. A debian specifikus valtozasokat meg elvileg a preinst/postinst elintezi, de ez ertelemszeruen csak a 2.1->2.3 iranyba mukodik. Amugy jo otlet a 2.1.5-tol megszabadulas, kisse "erdekes" benne par dolog.