Quake 3 nem települ

 ( BaT | 2006. november 25., szombat - 20:43 )

Üdv!

Találkozott már valaki azzal a problémával, hogy 1.16n (vagy az előtti) verziójú Quake 3 telepítője nem indul? Ugyanis már FC4-en sem indult el a fent említett telepítő (jelenleg FC6-om van), de még a demo telepítője sem. Valami KDE-s problémára gyanakszom, vagy az installerben lehet bug. Valahogy úgy néz ki a dolog, h. kiírja, hogy kbuildsycoca running..., majd megjelenik egy fehér hátterú ablak egy pillanatra, miután bezáródik, kiírja, hogy KWrited - a kérések figyelése a(z) /dev/pts/4 eszközön, majd kilép.
Azért nem jó újabb verzió, mert van egy kedvenc szerverem ami a régi protokolt használja és az 1.16n az utolsó verzió, ami még ezt használja.

Esetleg érdekelne az is, ha valakinek megvan a bináris, illetve hogy ki lehet-e tömöríteni az ilyen installer fájljait.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

lasd "miert nem fejlesztenek linuxra"

Úgy csinálom, hogy a feltelepített verziót átmásolom. Így működik. (Én csak a demót használom.)

Honnan szerezzem meg a telepített verziót? Vagy te feltelepítetted anno egy régebbi disztribre/régebbi kde-re és onnan másolod?

Szivessen átküldöm ...

Semmi gond gtk s alkalmazás qt nem viszi :P
Kell neki 1.2 gtk ha jól emlékszem ...
Inditsd terminálról ... Gui nélkül karakteeres módban ... --help opcióval úgy emlékszem simán kitömöríteni is kitudod ...

Hmm, én úgy emlékeztem, hogy nem gtk-s...

Felraktam gtk+-t (1.2.10) de semmi nem változott. Viszont egy hirtelen ötlettől vezérelve lefuttattam rajta egy ellenőrzést, eredménye:

[root@localhost telepítők]# ./linuxq3apoint-1.16n.x86.run -check
tail: "+6" nem nyitható meg olvasásra: Nincs ilyen fájl vagy könyvtár
Error in check sums 2988782453 4183380385
[root@localhost telepítők]# ./linuxq3ademo-1.11-6.x86.gz.sh -check
tail: "+6" nem nyitható meg olvasásra: Nincs ilyen fájl vagy könyvtár
Error in check sums 110245027 1300192087

Szóval lehet, hogy ezért nem megy?

Egyébként a -keep opcióval kéne otthagynia a kitömörített fájlokat, de szerintem el sem jut a kitömörítésig. Olyan módot meg nem látok, amivel parancssorból lehetne telepíteni.

Ez nem a Q3 baja hanem a Loki installeré (ami különben GTK1.x-et használ valóban).
Text editorban nyisd meg a *.run-t, szedd ki az elejéről a scriptet, és tarral csomagold ki a "maradék" filet (nem emlékszem gzippelt-e vagy nem), így megkapod a setup könyvtárat amit egyébként a /tmp alá pakolna.
Innen el tudsz már indulni (./setup).

ha jol ertem, akkor itt az a problema, hogy valaki debaianon csomagolta, ahol a tail-nek van olyan kapcsoloja, hogy +6, amit ki kene cserelned a script-ben tail -n 6-ra, es sztem menne a dolog.
--
Peace, Love, Unity, Respect

Igen ez mindenképpen tisztább megoldás mint az enyém.
De gány/bruteforce rulz ;)

de a tied tuti, hogy működik, én csak próbáltam kiokoskodni, hogy kábé.
--
Peace, Love, Unity, Respect

Bocs, de ezt az ágat valamiért észre sem vettem, így nem olvastam...

Kicséeréltem hex editorral a 6db 'tail +'-t 'tail -n '-ra (aposztrófok nélkül). Most sem indul el, de legalább nem kapok errort. -check meg azt mondja, hogy Error in check sums 586958006 1300192087 de szerintem ez betudható a csereberének is.

Szerk: végül Csigaa megoldása segített, bár utána kellett nézni annak, hogy milyen karakterektől indul a gz. (1F 8B 0B). Majd jelentkezek, hogy működik-e... :)

Jeeeeeeeee! Működik. Igaz, a winre feltelepített q3 adatfájljait egyelőre nem linkeltem, hanem másoltam, de már megy. Kivéve a hangot. Hogy lehetne hangot varázsolni neki?

OSS kell neki, ha valami (pl. hangdaemon) fogja a hangkarit, szívás... Ha meg nem, akkor ő fogja fogni a hangkarit, megint szívás...
[kedvenchangdaemonod]dsp-t neki!

Szóval ha alsa-t használok, akkor át kell váltanom oss-re? Egyébként szerintem van oss, mert wine configban is oss van bejelölve és winevel indítottam már el winre telepített vlc-t és ment a hang...

Q: I get no sound in Quake III, and I'm using ALSA!
A: echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
A: Note that this also works for any other game that doesn't support ALSA and needs mmap'd audio,
just change the binary name (quake3.x86 with, for instance, et.x86, for Enemy Territory.)
A: Or switch to the open-source Quake III port here at icculus.org: http://www.icculus.org/quake3/

Ezzel mukodik jopar ID-s jatek (q2, RTCW, Q1)
Meg nem mondom, hol talatam a FAQ-ot, de volt ott par link atirt Quake enginekre, amivel a Q1 is alomszep lett :)

Megvan: http://icculus.org/lgfaq/

Működni működik, csak fagy. Mármint a játék. Hang nélkül szépen futott. Pl. felmennék kedvenc szerveremre, erre awaiting snapshot-nál egy hangfoszlány elkezd ismétlődni, és nem történik semmi. Billentyűkombinációkra sem felel. Single playernél meg 2 pályát próbáltam, q3dm12-nél megjelenik a map és abban a pillanatban fagy, az 1. pályán (q3dm1?) meg megy végig, csak az eredménynél fagy...

Mi ez, talán valami alsa/oss bug?

Milyen verzioszamu fagy? Milyen videokartyad, stb. van? Amugy ha q3, akkor www.icculus.org.

Nem hinném, hogy a játékban van a bug. Mert amíg nem írtam be a fent említett fájlba a szintén fent említett sort, addíg nem fagyott, de nem volt hang. Miután beírtam, azóta fagy. Mindíg olyankor, amikor egy hangnak kellene megszólalnia. És minden pálya esetén máshol. Szóval bizonyos esetben szól a hang, szóval nem a hang előállításával lehet a hiba...

Hasznalj 1.32c-t feher ember ugyis azzal jatszik neten.

Csak azzal nem tudok bemenni a kedvenc szerveremre. (Jóformán több szerverre nem is járok, az az egyetlen.)

Senkinek semmi 5let? Még a végén telepítek qemuba vmi olyan rendszert, amin biztosan fut az installer... Esetleg mondhatnátok ilyen rendszereket.

Ez számomra újat nem mond, amúgy is olvastam már. Azt viszont elfelejtettem írni, hogy az 1.32-es q3 telepítő FC4-en működött, de mint már említettem, 1.16n fölé nem mennék...

Továbbra is várom olyan disztribek ajánlását, melyen fut a q3 fent említett verziójának a telepítője. Ha a demo telepítője fut, az nekem már jó!

Jaja, ezzel kell kezdeni a telepitest, aztan semmi gond:

http://www.ioquake3.org/files/ioquake3-1.34-rc2.run

Aztan loheti otthon egyedul a botokat mi?:D