3G - Vodafone - Huawei

 ( Takoca | 2006. július 18., kedd - 11:26 )

Üdv!

először is szeretném leszögezni, hogy tök láma vagyok!

egy vodafone-os, huawei e618 3G kártya, ill egy pci-as PCMCI átalakító segítségével kéne egy win2k3 szerver elé egy egyszerű linux gateway-t varázsolnom. Csinálmt már valaki ilyet?

google volt már, más kártyákra találtam is leírást, de ezt nem bírom életre lehelni (még 1x: nagyon láma vagyok linuxhoz)

köszi

Tako

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

a vodás net árakat nézted már? :)
__________________________________________________________________

Intel(R) Pentium(R) 4HT

őőő ez itt nem kérdés! ez van ez kell bele, markomba nyomták, hogy ezzel hozzam össze :)

huh
__________________________________________________________________

Intel(R) Pentium(R) 4HT

Hol akadtál el?
pcmcia-howto -t olvastad már ?
"pci to pcmcia" cucc már belőve ?
Tudod listázni a 3G kártyádat, csak driveret nem tudsz tenni hozzá?
Ha listán, már szerepel ott mi a neve?

hát az elején! :)

azóta felraktam egy SUSE 10-t és elvileg látja a motyót de nem jutok tovább:

ha berakom a 3g kártyát ezt látom a /var/log/messages -ben:
Jul 20 14:31:35 linux kernel: PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
Jul 20 14:31:35 linux kernel: ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKA] -> GSI 7 (level, low) -> IRQ 7
Jul 20 14:31:35 linux kernel: PCI: Setting latency timer of device 0000:03:00.0 to 64
Jul 20 14:31:35 linux kernel: ohci_hcd 0000:03:00.0: OHCI Host Controller
Jul 20 14:31:35 linux kernel: ohci_hcd 0000:03:00.0: new USB bus registered, assigned bus number 1
Jul 20 14:31:35 linux kernel: ohci_hcd 0000:03:00.0: irq 7, io mem 0x24000000
Jul 20 14:31:35 linux kernel: hub 1-0:1.0: USB hub found
Jul 20 14:31:35 linux kernel: hub 1-0:1.0: 1 port detected
Jul 20 14:31:35 linux kernel: PCI: Enabling device 0000:03:00.1 (0000 -> 0002)
Jul 20 14:31:35 linux kernel: ACPI: PCI Interrupt 0000:03:00.1[B] -> Link [LNKA] -> GSI 7 (level, low) -> IRQ 7
Jul 20 14:31:35 linux kernel: PCI: Setting latency timer of device 0000:03:00.1 to 64
Jul 20 14:31:35 linux kernel: ohci_hcd 0000:03:00.1: OHCI Host Controller
Jul 20 14:31:35 linux kernel: ohci_hcd 0000:03:00.1: new USB bus registered, assigned bus number 2
Jul 20 14:31:35 linux kernel: ohci_hcd 0000:03:00.1: irq 7, io mem 0x24001000
Jul 20 14:31:35 linux kernel: hub 2-0:1.0: USB hub found
Jul 20 14:31:35 linux kernel: hub 2-0:1.0: 1 port detected
Jul 20 14:31:35 linux kernel: usb 1-1: new full speed USB device using ohci_hcd and address 2

ha megnézem a yast2 ben a hw infór akkor ott van egy olyan az usb alatt hogy huawei mobil

50: USB 00.0: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_12d1_1001_noserial_if0
Unique ID: ADDn.gxU4lDcTlH9
Parent ID: k4bc.phwK+OmszH8
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:04.0/0000:03:00.0/usb1/1-1/1-1:1.0
SysFS BusID: 1-1:1.0
Hardware Class: unknown
Model: "HUAWEI Mobile"
Hotplug: USB
Vendor: usb 0x12d1 "HUAWEI Technologies"
Device: usb 0x1001 "HUAWEI Mobile"
Speed: 12 Mbps
Module Alias: "usb:v12D1p1001d0000dc00dsc00dp00icFFiscFFipFF"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #49 (Hub)

eddig ok de hogyan tovább,

bocs a bénázásért!

Ezekkel
http://portal.wikinerds.org/howto-3g-pcmcia-gnu-linux
http://www.mybroadband.co.za/vb/showthread.php?t=21726&page=23
és az általuk hivatkozott dokumentumok alapján szerintem meg tudod oldani.

köszönöm! próbálkozom!

Gondoltam leírom, hogy mi lett a megoldás végül, hátha kell másnak is:

szóval gentoo alá sikerült beszenvedni a cumót de sajna a vinyó 1 hétig bírta...

valami "egyszerűbb" megoldást kerestem, coyote, smoothwall vagy ilyesmi.

A megoldás az IPCop lett illetve ennek egy UMTS-el kiegészített verziója. (igazából csak az usbserial lett bele rakva pluszba asszem)

az install kb 10 perc, és elég jó kis cucomónak tünik.

a 3g működéséhez csak annyit kellett pluszban csinálnom, hogy /etc/modules.conf ben be lett rakva ez a két sor:

options usbserial vendor=0x12d1 product=0x1001
post-install usbcore modprobe usbserial

Galbi köszi a segítséget még 1x

Takoca

Ha még nem találtátok meg a megoldást, itten van, nekem tökéletesen megy, méghozzá gyorsabban mint win alatt. Az átlag sebessége eléri a 200-250 kb/s-ot! A PIN kérést egy telefonba ki kell kapcsolni!

options usbserial vendor=0x12d1 product=0x1003
post-install usbcore modprobe usbserial

/etc/wvdial.conf-ba:

[Dialer Defaults]
Phone = *99#
Username=polyp
Password=polyp
Stupid Mode=1
Dial Command=ATDT
[Dialer huawei_e220]
Modem=/dev/ttyUSB0
Baud=460800
Init2=ATZ
Init3=ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN=0
Modem Type=Analog Modem

Elindítása terminálban:

Ahogy a /etc/wvdial.conf-ban a [Dialer xxxxx] szekcioban nevezted. Nalam ez huawei_e220, tehat

wvdial huawei_e220

Leállítása:
ctrl+c

Ja és még egy tapasztalat mindegykinek, aki a lenti feltételekkel netezik:
- Kubuntu 7.04
- Vodafone 3G (Huawei)
- Kmail, Kopete...
Újratelepítettem az eddig működő rendszeremet, és utána furcsán viselkedett! A Skype és a Firefox működött, az MSN nem, a mail küldés működött, a fogadás nem!!!

Eredmény:
A 3G modem dial-up kapcsolatot épít fel, viszont az óra mellett megjelenő KNetworkManager megakadályozza a normális működést! Jobb gombos kattintással ki kell kapcsolni az automatikus indulást, és tökéletesen fog futni az összes beállított protokoll! :-)

Vegul is meg nem telt el egy ev az utolso bejegyzeshez kepest, igy jokor szoltal. De koszonjuk. (Illetve gondolom koszonik ok.)

Köszönjük a tapasztalatod megosztását.
"nekem tökéletesen megy, méghozzá gyorsabban mint win alatt"
Win alatt is simán megy ennyivel, a speedtest.net alatt mértem.
__________
U-Bantu©

Nekem is 12d1:1003 -am van:
Bus 004 Device 002: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem
mégis az általad írt wvdial.conf a következőt adja:
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
ATQ0
OK
--> Re-Sending: ATZ
ATZ
OK
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
ATQ0
OK
--> Re-Sending: ATZ
ATZ
OK
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
ATQ0
OK
--> Re-Sending: ATZ
ATZ
OK

Miért?

ezt milyen disztrib alatt csinálja?

Egy olyan problémám lenne, amit sehogy sem értek és emiatt nem tudok mivel próbálkozni. A Huawei E220 USB-s modemet használom, Kubuntu alatt. Sokáig ment is a dolog, nagyon jó volt. Azonban a mai nap nem tudom használni az internetet. Vagyis a modem kapcsolódik a kppp-vel, viszont semmilyen internetet használó program (böngésző, skype, levelező stb) nem tud kapcsolódni. Olyan, mintha nem lenne ip cím, dns, és átjáró. A kppp-nél meg tudom nézni az ip címet, hasonlít is ahhoz, mint amit a winnél látok, a system settings-ben találok dns-t, az is jó, mégsem megy.
Mit tudok csinálni? Merre induljak?

Kezdeném egy laza ping-gel. Ha az nem megy akkor ping egy tutti válaszoló ip-cimre. Aztán ifconfig. Én is vodás netet használok, és néha találkoztam már azzal a problémával, hogy a dns-ük nem dolgozik mindig.

Köszönöm. Igazándiból átjöttem a kubuntuba és amikor be akartam írni az ifconfig-ot, a levelező elindult. Innen kezdve megy minden. Csak nem értem mi volt ez. A win alatt ment, a linux alatt nem. Ezt megcsináltam ma legalább 5x, most meg megy (megijedt...). De fátylat rá, ha megint előfordul, jelentkezem... Mégegyszer köszönöm.

Ha ilyen van, eloszor mindig a default gw-t kell megnezni, a ppp csak kulon keresre allitja be (altalaba a grafikus frontendek ezt kerik, de ki tudja). Aztan a DNS-t, pingelni kifele. A resolv.conf-ba kell valami ismertebb, kiprobalt DNS server is, nagy reszuk nem nezi honnan jon a keres.