mplayer és az xv kimenet

 ( ghostdog | 2006. február 19., vasárnap - 10:01 )

üdv!

problem a következő:
ubuntu 5.10 + nvidia6600Gt pci-e, nvidia driver a backportból felrakva (google magyar oldalak: ubuntu wiki)

mplayer ilyen-olyan módokon hajlandó felkúszni de xv- kimenetet sehogy se talált
gondolom: mert nincs.. mplayer -vo help .. xv az nincs deka se..

./configure --enable xv ..nem nagyon hatódik meg tőle..

dpkg-reconfigure mplayer -->xv kiválaszt, config-ba vo=xv .. lejátszás van, de tuti átáll a x11-re mert ha direktbe parancssorba beírom hogy mplayer -vo xv film.avi --behal

konzolba az xvinfo cannot open display üzenetet ad vissza
nagy kérdésem: hogyan lesz nekem xv kimenet, ha már kiköltekeztem videokarira, legalább legyen kicsit hw-esen is megdolgoztatva linux alatt is.. ugyebár..filmnézés..miegymás

minden helpet szivesen fogadok, köszi

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

érdekes hogy xterm-ben xvinfo dobja az adatokat
hm.. ötlet?

őszinte részvétem...

nézd meg ezt: http://lists.debian.org/debian-user/2005/08/msg00205.html

ha jól értelmezem, az nvidia 6600gt chip nem képes xvideo-ra? :-/
csak 6800 fölött van ismét benne?
ez csak debian alapokra igaz (ubuntu) vagy bármely disztro-ra?

(bocs az értetlenkedséért, nem szántam rá az időt hogy fordítgassak)

hát ezt mondja Mr. "Bruno", de persze nézz még utána a dolognak...
ha a kártya nem támogatja, akkor lehet bármilyen oprendszered, overlay nem lesz, az biztos.

nvidia AFAIK mindig is vacakolt ami az overlay-t illeti (még az elején is voltak olyan modellek, amikben nem volt).

köszi a választ
lassan már ott tartok hogy nincs jó vga megoldás linuxra..
ati nemjó mer sok a baj vele mindenhol ezt olvasom, nvidia meg 50% ezek szerint..
vááááá, miért jó ez a gyártóknak..

Hi!

Ha mindenképpen hw gyorsítást akarsz, akkor még talán szóbajöhetnek a -vo gl|gl2 videokimenetek....
Persze ez azt feltételezi, hogy az X szervereden van "háromdé" gyorsítás. Ami egy újabb keringő -- bár egyesek szerint könyebb Nvidia esetén, mint ATI esetén. YMMV.

A minap probaltam az istenitett nvidia videokartyan az MPlayert: xv megy, viszont se xvidix, gl, gl2, svga, dga, ugyhogy maradok az atinal ;-)

Configure elott probalj meg egy apt-get install xlibs-dev -et.

Töltsd le az nvidia drivert a www.nvidia.com-rol.
Az nv drivert könnyű felrakni van egy .run kiterjesztésű file azt lefuttatod és válaszolsz a kérdésekre. Utána az xserver(xfree86,xorg) confjában átirod a drivert nv->nvidia és kész is.
A xwindows system ujraindítása után megjelenik az nvidia logo és voala van is 3d meg opengl.
mplayerben meg alitsd be a videokimenetet gl-re

have fun!

nv driver már van backportból,glxgears lefut, igaz a legújabbat nem tudom feltenni amit leszedtem, sh N..run, mert nem látja a kernel forrást, holott fentvan, sőt még link is van rá hogy a default szerint is megtalálja.. ( /usr/src/linux a konfig file szerint)

a gl is használ hw-es gyorsítást?

végül is egy alap ubuntu visszarakása után a következőkkel sikerült xv kimenetet láthatóvá tenni az mplayernek

1. apt-get install build-essential
2. xlibs-dev
3.nividia-glx,stb
4. a ubunutu wiki oldalán található mplayer leírás ajánlott függőségei
5. /configure --enable-gui --enable-xv

mplayer-vo help: látszik az xv

viszont grafikus konzolból indítva: mplayer need x11, cannot open display..

filekezelőből elindul a gmplayer, (configba vo=xv)

mindössze annyi van most hogy "cannot find codecs for -vo stb.."
pedig fentvannak a megfelelő helyen, sőt még fordítás előtt beraktam a helyére..
a gui beállításaiban látszik a xv kimenet! miért nem tud vele dolgozni?

hogyan tovább? :-(

"hogyan tovább? :-("

Ha /etc/mplayer.conf-ba is beleirod?

csak a user és a root config-jába
meg a gui.conf-ba saját magától írja be..

hm, azt mivel tudom 100%-ra csekkolni hogy a hw-es gyorsítás tutik@élet műxik?oké hogy vmi kisablak mozog 3 fogaskerék (glxgear) de vmi keményebb meló kellene neki 3Dbe

mármint, képes e rá, gnome ablakozó van fent

glxgears parancs

"a gl is használ hw-es gyorsítást?"

Igen. O volna az opengl :)

"hm, azt mivel tudom 100%-ra csekkolni hogy a hw-es gyorsítás tutik@élet műxik?

# glxinfo | grep "direct rendering"

Minden kartyanak vannak egyeni beallitasai is, igy az nvidianak is. Ha felraktad az nvidia csomagjait, akkor a man oldalai is elerhetok lesznek:

man nvidia-xconfig
man nvidia-settings
man nvidia-installer

---------------------
Ригидус а бетегадьбол

a megoldás rendszer újra, alap fordítók, xlib-dev, nvidia, codecs-ek helyére előre és fordítás :-))
annyiféle kavarodás volt már az mplayer körül hogy backup elkerülhetetlen volt, de legalább már ez a kérdés lejátszott lett végleg..

már csak olyan bajom van hogy a sima mplayer no gui jól kezeli a ttf betűt amit megadtam a config-ba, viszont a gui-s nem.. .-(
még előző állapotba x11 korszakban a gui is látta jól a ttf-et..

vki ötlet?

Probáld a Preferences/Font-nál is megadni.

igen, ez történt, de csak a saját mplayer-es font kell neki, a TTF-et nem akarja bekajálni..