Geany Plugins

 ( dzsolt | 2019. május 20., hétfő - 10:04 )

Fordítanám rendszeren kívülről (de repóból ugyan ez a probléma) és hiányolok pár plugint, ami fontos lenne!
Debugger, DevHelp, Geanypy, MultiTerm.
A configure kimenete:

  • https://pastebin.com/euM494VL
  • Mit hiányolhat, hogy ezeket nem fordítja le? Valaki futott már bele?

    Hozzászólás megjelenítési lehetőségek

    A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

    teljes a siker, ja, nem! Ezek a hiányzók GTK2-n futnak és nem létezik portjuk GTK3-ra :(

    --
    „- Mindig azt akartam, hogy a számítógépem ugyanolyan könnyen használható legyen, mint a telefonom. A kívánságom valóra vált. Már nem tudom, hogyan kell használni a telefonomat.”

    dzsolt

    Fordíts akkor hozzájuk Gtk2-őt. Bár egy Gentoo-ra stílszerűbb lenne egy vim vagy egy Emacs.


    No keyboard detected... Press F1 to run the SETUP

    Fordítottam, bár a py így sem működik, lehet visszább kellene mennem pár verzióval. 1.26-7 környékén még működött, módosítok majd egy ebulidot, mert csak 30-ig van visszafelé. Elvileg egy python modullal van teljes értékű arduino környezet és azt akartam kipróbálni.
    OFF: Attól, hogy Gentoo-t használok, nem vagyok mazochista ;) Sosem állt kézre sem a vi/vim sem pedig az emacs. A kezdetek kezdetén kínlódtam a vi-vel, mert legtöbb esetben nem volt más, de szerencsére konzolon sem állt meg a fejlődés.
    --


    „- Mindig azt akartam, hogy a számítógépem ugyanolyan könnyen használható legyen, mint a telefonom. A kívánságom valóra vált. Már nem tudom, hogyan kell használni a telefonomat.”

    dzsolt

    "Attól, hogy Gentoo-t használok, nem vagyok mazochista ;)" :)

    Attól tényleg nem. De attól igen, hogy nem stabil cuccot akarsz rátenni. Csak a 30-as verzió stabil. Persze feltuszkolhatsz újabbat, aztán jönnek vele a nemstabil függőségek és azok nemstabil függőségei által generált problémák.

    Ha fontos hogy mindenből új legyen használj inkább fedorát. Én megtanultam, hogy gentoo a nyugalom szigete, ha minden összetevőjéből - amiből van stabil - stabilt használok. Ha meg nem, akkor elszabadul a pokol, amihez képest egy beta fedora vagy ach is egyenesen menyországnak tűnik.

    powered by ©gentoo

    ...hát amit rá akarok tenni, épp pont vagy 8-10 alverzióval korábbi, mint a legfrissebb, tehát épp nem érdekes, hogy mennyire friss vagy nem az, ha működik. Ilyenekre van egy chroot-om, kipróbálni abban fogom. Amúgy meg sem tudom, mondani pontosan, hogy mióta van gentoo a gépeimen (talán itt vissza lehet követni, de igazából nem érdekes, minden esetre kizárólagosan gentooval futnak a gépeim vagy 10+ éve) és sosincs semmiféle komoly bajom! Olvasgatom itt a mindenféle disztrók kérdezz/felelek topikjait és eszembe sem jutna felcserélni az én gondjaim az övéikkel ;) Kár, hogy nem értek a gtk-hoz egy cseppet sem, mert még megpróbálnám ezt az egyetlen modult 2-ről a 3-ra portolni és akkor „kidobhatnám” a teljes arduino-t (nem teljesen, mert azt hívja, de legalább lenne egy korrekt szerkesztőm)


    „- Mindig azt akartam, hogy a számítógépem ugyanolyan könnyen használható legyen, mint a telefonom. A kívánságom valóra vált. Már nem tudom, hogyan kell használni a telefonomat.”

    dzsolt

    "hát amit rá akarok tenni, épp pont vagy 8-10 alverzióval korábbi, mint a legfrissebb"

    A logod alapján Te az 1.35-ös verziót szeretnéd telepíteni. Ez a legújabb a geany.org szerint, viszont a gentoo csomagtárában ez még csak sárga jelzést kapott. Ha amd64 vagy x86 architectúrájú procid van akkor már jó az 1.34-es, ha valami extrémebb, akkor meg csak az 1.30, ami elméletileg probléma mentes.

    Én 13 év debianozás után világosodtam meg így csak két éve gentoozom, de azt megtanultam, hogy nem éri meg a nem stabil cuccokat reszelgetni. Mert akkor mindig beránt valami másik nemstabil összetevőt ami lehet egy darabig működik, de idővel valahol mindíg borul a bili. Jobb esetben csak nem fordul le valami, vagy egy harmadik program nem fog megfelelően működni. A debianos időkből hozzászoktam, hogy nem a legfrissebbek benne a cuccok, de legalább jól működnek.

    Ha mindenáron a frissességre törekednék fedoráznék, esetleg arch. Bár red hat irányba hajlok.

    powered by ©gentoo

    Olvass légyszives tovább is:

    https://hup.hu/node/164355#comment-2350708

    A lényeg, hogy valamikor dobtak pár gtk funkciót és a sajátot használják helyette. A plugin persze nem azt használja, de az, hogy .26 vagy .27 ami még viszi az kérdéses. Majd kiderítem!

    UI: a 26-os működik geanypy-al, már csak az extra plugin nem :(


    „- Mindig azt akartam, hogy a számítógépem ugyanolyan könnyen használható legyen, mint a telefonom. A kívánságom valóra vált. Már nem tudom, hogyan kell használni a telefonomat.”

    dzsolt