ISPConfig és Let's Encrypt

 ( gkaroly | 2017. október 14., szombat - 17:06 )

Sziasztok,

Felraktam ez alapján egy ISPConfig-ot.

A szóban forgó rész így szól:

Install Let's Encrypt
ISPConfig 3.1 has support for the free SSL Certificate authority Let's encrypt. The Let's Encrypt function allows you to create free SSL certificates for your website from within ISPConfig.
Now we will add support for Let's encrypt.
apt-get install certbot

There are no further steps required than installing LE. The website SSL certificates are created by ISPConfig when you add the web sites.

A szóban forgó csomagot fel is raktam, de ISPConfig -ban hiába pipálom be a Let's Encrypt -et, az SSL mappa üres marad.

A howto szerint minden szép és jó, mégsincs https:// .

Mit rontottam el? Mi hiányzik? Segítsetek! Köszi.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Szia!

Lehet valami gond miatt nem megy végig a folyamat, nézd meg esetleg a /var/log/letsencrypt/letsencrypt.log fájlban, hátha segít.

A letsencrypt logjába sem kerül semmi hiba? (/var/log/letsencrypt)

Új telepítésnél megy rendesen, a régieknél fel kell tenni a hiányzó csomagokat és frissíteni az ISPConfigot. De nekem is van vele bajom. Semmi mással nincs gond, itt is csak a sorrendet kellene eltalálni szerintem. Esetleg kitölteni a cert adatait, elkészíteni, utána pipa... Ha valaki már kikísérletezte engem is érdekel.

Új telepítésű az ISPConfig.

Eddig jutottam: https://pastebin.com/X2JjmZ3x

--
-- Üvegfiú - Csontkemény harc
Tégy Jót!®

SSL fülön kitöltötted az űrlapot (ország város, megye, fiú, lány) és rányomtál a lap alján a mentésre?

ISPConfig-nak nem magától kéne a certet, kulcsot legenerálni az ország, város, fiú, lány alapján?

Ugyanis őkegyelme nem engedi elmenteni, mert ezek a mezők üresek.

--
-- Üvegfiú - Csontkemény harc
Tégy Jót!®

Ezen tanúsítványok lényege a CommonName, amit egy legördülő menüből választhatsz ki (SSL domain).
1, volt már olyan, hogy aliasok, www előtag meg hasonlók miatt a legördülőben nem az volt a default, mint amit én szerettem volna. Igazából a cert elkészült, csak nem arra a címre amire vártam volna...
2, többször előfordult az is, hogy nem volt elég a Domain tabon a két checkbox bepipálása. Az SSL fülön szépen ki kellett tölteni az adatokat, az űrlap legalján SSL akciónál Create certificate, mentés és láss csodát pikk-pakk elkészült a tanúsítvány.

Úgy látom, fontos könyvtárak is hiányoznak:

root@ganyikaroly:~# ls -la /etc/letsencrypt/
total 16
drwxr-xr-x 4 root root 4096 Oct 14 17:25 .
drwxr-xr-x 106 root root 4096 Oct 14 17:30 ..
drwx------ 3 root root 4096 Oct 14 17:24 accounts
drwxr-xr-x 2 root root 4096 Oct 14 17:25 renewal

--
-- Üvegfiú - Csontkemény harc
Tégy Jót!®

azt a certbot megcsinalja maganak...

Na, egy darabig azt hittem, hogy user error, de csak félig:
- Site-ot létrehozom, elmentem.
- SSL-be beimportálom az ország-város-stb -t, create certificate-et kiválasztom, elmentem.
- Újra szerkesztem, Save certificate.

Oldalt megnyitom, SSL nélkül betölt jól, https-re váltva közli, hogy az Ön kapcsolata nem privát. Magyarán a létrehozott cert nem valid. Ahogy a drága Fluimucil Ábel kérdezné: de miért?

Valaki segítsen pls, mert már a hajamat tépem...
Köszi!

--
-- Üvegfiú - Csontkemény harc
Tégy Jót!®

Csináltál egy self-signed certet és ezért reklamál. :)

Egyébként a pastebin-edből úgy tűnik, hogy olyan domainnek próbálsz certet kérni ami nem is a szerverre mutat. :)

A DNS jol van beallitva a siteokra? CNAME sem arthat neki arra is replikazik neha. Konzolbol probaltal mar certet generalni? Ott mukodik?

Nincs valid DNS bejegyzés, /etc/hosts-ba írtam a domaint.
Ez lehet a gond?

--
-- Üvegfiú - Csontkemény harc
Tégy Jót!®

A domain ellenőrzés ez esetben, hogy lehetne sikeres? :)

Ez hát.
Olvasd el hogyan működik a letsencrypt.
--
Gábriel Ákos