unable to mount rootfs neha

 ( htmm | 2005. január 6., csütörtök - 19:33 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Azert a kabeleket rangasd meg, hatha csak..

Természetesen a DMA mód kikapcsolását csak a mentés idejére értettem. Anélkül nem lenne egészséges használni a vinyót... :)

Ajánlom figyelmedbe a már említett http://www.ultimatebootcd.com című weboldalt, egy nagyon hasznos kis tool ilyen esetekre.

Érdemes lenne lefuttatni szerintem egy fsck-t a fájlrendszereden, és megsasolni, hogy mi a helyzet a bad sectorokkal, mert esetleg azok is okozhatnak ilyen problémákat.

Toma_ javaslata is megfontolandó, illetve a vezérlőre is gyanakodhatsz akár.

Hali!
Van egy gep, ami erdekes dolgokat produkal es nem igazan tudok rajonni, hogy mitol van.
Debian Sarge a rendszer, 2.6.10 -es kernellel . Via chipset az alaplapon, AthlonXP proci.
IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
A kernelben benne van a VIA82CXXX chipset support.
A jelenseg: betoltodik a kernel, mikor odaig jut, hogy mountolna a / -t, akkor unable to mount rootfs. De nem mindig! Kb 10 inditasbol egyszer. Utana reset, minden megy rendben, fagyas nincs. Hardwarehibat nem tartok valoszinunek, mert akkor nem menne se a Debian, se az xp stabilan rajta.

Egy reszlet a dmesgbol:

[quote:7c7e63b1f2]
hda: max request size: 128KiB
hda: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(133)
hda: cache flushes supported
hda:hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
ide: failed opcode was: unknown
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
ide: failed opcode was: unknown
[/quote:7c7e63b1f2]

Van valakinek valami otlete?

Szia!

Először is futtasd le a merevlemezeden a gyártó diagnosztikai progiját (http://www.ultimatebootcd.com), és ha az hibát jelez, akkor kapcsold ki a DMA-t, és kezdj el archiválni (meg új vinyóra gyűjteni)... :o

[quote:6f7ed67125="htmm"]Hali!
Egy reszlet a dmesgbol:

hda: max request size: 128KiB
hda: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(133)
hda: cache flushes supported
hda:hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
ide: failed opcode was: unknown
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
ide: failed opcode was: unknown

Van valakinek valami otlete?[/quote:6f7ed67125]

1. Erre láttam utalást a valamelyik kernel helpben (A DMA és az
IDE opciók között valahol)

2. Ez nekem időzítési problémának tűnik elsőre (erre jól illeszkedik
a DMA teória)

3. Alaplapsetup turgányolás, időzítések, DMA módok.

+1 Szerintem borotvaélen táncol a vinyód.

[quote:6bb14052c5="htmm"]
A jelenseg: betoltodik a kernel, mikor odaig jut, hogy mountolna a / -t, akkor unable to mount rootfs. De nem mindig! Kb 10 inditasbol egyszer. Utana reset, minden megy rendben, fagyas nincs. [/quote:6bb14052c5]

Helló htmm!

Először is a legfontosabb:
Azonnal csinálj mentést a pótolhatatlan dolgaidról!

Csak azért regisztráltam most magam, hogy neked válaszoljak. ;-)

Hasonló jelenséggel küszködtem egy ideig, de Gentoo alatt. Kb. 10-15 indításból egyszer produkálta a "nem mountolós" hibát.
A gépem több mint 5 éves (Intel Celeron + BX chipset) és egy 80GB-os WD800JB típusú merevlemez volt benne a legújabb alkatrész, amit 2003 januárban vettem. 2004 márciusig Sarge volt fenn és nem volt semmi gondom. Utána keztem Gentoot használni, de arra nem emlékszem, hogy mikor történt először ez a "nem mountolós" hiba.
Novemberig működött így a rendszer, de a hibára semmilyen logikus magyarázatot nem találtam. Ezen kívül semmilyen más látható problémával nem találkoztam, amiből esetleg kiderülhetett volna a hiba oka.
Novemberben történt aztán, hogy linux alatt másolgattam volna két FAT32-es partíció között adatokat, de másolás közben megállt és csak várt. A logokból nem derült ki semmi, és XP alatt a másolást gond nélkül megcsinálta.
A biztonság kedvéért lefuttatam a wddiagot, volt SMART + felületellenőrzés és az eredmény: SEMMI HIBA, se badblock se semmi! Késő volt, gondoltam másnap kiderítem mivel van a gáz.

[color=red:6bb14052c5]!!! Ha másnap mentéssel kezdtem volna, akkor b*sztam volna rá, hogy új vinyót kell vennem, mikor besz*rt, DE nem azzal keztem, így lefelé görbült a szám széle!!![/color:6bb14052c5]

Szóval másnap megint ezzel a linux alóli FAT32-es másolgatással kezdtem, a másolás megint megállt, shutdown, aztán induláskor veszett kerepelés.

Mentettem már sok halódó vinyóról adatot, de persze az ember mindig a sajátjával szívja meg. Nem találta a 0. szektor, anélkül pedig bajos bármit is leolvasni. Bele kellett törődnöm, hogy házi módszerekkel hiába próbálkozom, a Kürtben persze jó pénzért biztos lementenék...

Ez a tanmese arról szólt, hogy az emberi hülyeségre nincs orvosság és az ember jó esetben a saját hibáiból tanul. És persze arról, hogy ha diagnosztika nem is jelzi a hibát, attól még ott lehet az a hiba.

Röviden összefoglalva a tanácsom:
[color=red:6bb14052c5]Használd nyugodtan tovább ezt a vinyót, de legyen mindig mentésed![/color:6bb14052c5]

Szabi

Koszonom szepen mindenkinek az eddigi valaszokat!
Kozben a winyot mar leteszteltem a PowerDiaggal, az nem talalt semmi hibat.
(A winch egyebkent mint a fentibol is latszik egy 80as maxtor)
Akkor nagyon gyorsan mentes masik winchre, meg meg mellette megprobalom a dma letiltasat, bar az nem velemi remek otlet, mert ugy a sebesseg is veszik.