32 bit -> 64 bit; ReiserFS -> Ext4

 ( trey | 2015. február 15., vasárnap - 16:46 )

Ennek a napnak is el kellett jönnie. Előretekintve, viszlát 32 bit, helló 64 bit. Viszlát ReiserFS, helló Ext4.

trey@alderaan:~$ uname -i
x86_64

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Mik az okok?
A régi rendszert rakod át, vagy újratelepítés? (Utóbbira tippelek)

Már végeztem. Az utóbbi.

Az ok? Van már olyan projekt, ami dobta a 32 bites vonalat, csak idő kérdése, hogy az Ubuntu mikor lépi meg ezt. A fájlrendszernél a ReiserFS nem támogatott pl. TRIM-et. Mondjuk ettől függetlenül szépen ment SSD-vel évekig.

Hogy miért most? Most volt hozzá kedvem. Többször nekiálltam volna, de valahogy sosem volt hozzá türelmem.

A 32 bites rendszer azért egy diszken el van téve, mert tervezek csinálni egy-két összehasonlítást. Pl. mennyi a memóriahasználat ugyanolyan alkalmazások ugyanazon adatok mellett 32 biten és 64 biten. Csak kicserélem az SSD-t egy HDD-re és visszakaptam a 32 bites rendszert :)

--
trey @ gépház

Folytatod az update sorozatot. Vagy ezzel annak is vége szakad?

Persze, hogy folytatom. Nincs nekem annyi időm, hogy állandóan full telepítést csináljak :)

--
trey @ gépház

hát nem sietted el

--
Live free, or I f'ing kill you.

nem ide

Végülis 2038-ig nincs elkésve... :)

-------------
I made an NTP joke once. The timing was perfect.
DevMeme, fejlesztői pillanatok...

ket kerdes merult fel:
- az ubuntuk mar multiarchossak, azzal nem lehet megoldani a 32bit->64bit valtas?
- ha a fenti mukodne, akkor egy ext4 format, rsync, fstab edit, grub install-lal nem usztad volna meg az fs valtast? (es akkor elmondhatod hogy X ev ota ugyanaz a rendszer csak frissitve van es tulel mindent :D)

--
A vegtelen ciklus is vegeter egyszer, csak kelloen eros hardver kell hozza!

Nem akartam egy nagy kuplerájt csinálni. A 32 bit -> 64 bit váltás elég nagy lépés (történelmi! :), gondoltam megadom neki a megfelelő tiszteletet azzal, hogy friss alapokkal indítok. :)

--
trey @ gépház

Te tudod, de semmivel sem bonyolultabb, mint egy verzióugrás...

sub

Én egy hónapja álltam vissza. Próbaképp felraktam a 32 bites 15.04-et és egy pár napos tesztelgetés után átköltöztem teljesen. A 14.04 64bit elég gyakran swap-olt 4Gb rammal. Így sztem sokkal használhatóbb lett a rendszer. Ugyanazok a programok: Ubuntu + apache, postgre, QtCreator, Chrome. Persze a régi rendszer is megvan, de eddig nem kellet vissza bootolni.

Lassan 3 hete álltam át én is 64 bitre. De eddig csak a hátrányát éreztem.
Még adok neki egy kis időt, de ha továbbra is egy rakat cuccnak kell a 32bites lib nem éri meg.
Szopás volt a wine, vboxba rakott android meg még egy progi, de nem ugrik be.
Mindegyiket meg tudtam oldani, de használni szerettem volna a rendszert mint eddig, hogy nem tákolom mindig.

pch
--
http://www.buster.hu "A" számlázó
--

You holding it wrong. Worksforme. #troll

A viccet felreteve: nekem a wine-nal sose volt bajom, pedig mar idestova 3 eve 64 bites OS-sel tolom, Androidot meg leginkabb a sajat emulatoraban hasznaltam, egesz turheto volt. Ami a VBoxot illeti, sose volt vele bajom.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Gondolom nem sok proprietary, 32-bit only cuccot használsz. Na, azokkal szórakoztató a 64 bit. Van, hogy csak chroot-tal lehet életre kelteni.

Rosszul tudom hogy egy ideje (régóta) 32 bites csomagok is feltehetők 64 bites rendszeren, meg fordítva? Vagy ez csak a Fedora / RHEL vonalon van így? Mintha multiarch-á vált volna Debiannal együtt Ubuntu is, nem?

Persze. Kivéve, amikor nem, mert ütköznek :-)

Mármint mi ütközik? Tudtommal ilyen nem fordulhat elő, ha hivatalos tárolóból teszel fel valamit.

Tudtoddal.
Pl. libdwarf-dev 64 és 32 bites verziója simán. Meg jópár ilyen.

Akkor úgy látszik ez Debian vonalon probléma csak:

http://paste.ubuntu.com/10255063/

Ez egy példa volt. Kipróbáltad az összes létező programot?

Biztos hogy nem fogom kipróbálni. Azért kérdeztem hogy nálatok mi volt a gond. Ha nem tudsz mondani, akkor te nyilván nem futottál bele és részedről minden rendben van. De akkor hogy akarod cáfolni amit én állítottam? Vagyis hogy tudtommal a hivatalos tárolókban lévő csomagoknak fel kell tudniuk települni konfliktus nélkül.

Vagy azt mondod hogy szerinted nem így kellene lennie? Vagy azt mondod hogy így kellene lennie de tudsz ilyen csomagról?

Ubuntu alatt nem tudom. Csak kérdezem, hogy ott nem így kellene lennie?

Illetve nem hivatalos tárolóban lévő cuccok nem érdekelnek részemről, mert ott úgy rakják össze ahogy a fejlesztők akarják - azzal bármilyen gond lehet. Arra lettem volna kíváncsi hogy a hivatalos tárolóval kapcsolatban volt-e sűrű észrevétel ilyen hibák terén.

Nálam - Debian alapok - konkrétan a hivatalos libdwarf-dev-vel volt baj. De volt még pár másikkal is, már nem emlékszem, melyikekkel.
Nyilván a csomagok többségével megy, csak pont pár kritikussal nem. Az, hogy neked pont ez működik Fedorán, számomra nem jelent semmit.

Ez akkor nem segitseg, ha a prorpietary cucc regebbi/ujabb libekre hivatkozik, mint ami elerheto csomagbol, es az ujabbal/regebbivel meg persze nem megy. Vannak azert szep szopasok ezen a teren.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Ne is mondd, az otthoni scannerem pont ilyen. Szerencsere azonban nagy ritkasag, hogy barmi proprietary binarisba beleszaladok.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Windows?

Szerintem Linux.

Linux

pch
--
http://www.buster.hu "A" számlázó
--

"használni szerettem volna a rendszert mint eddig, hogy nem tákolom mindig"

Erre volt a válaszom, hogy: Windows.

:)

OS X.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Nem tudom, azt egyre jobban szidják. A Windows 10 ellenben most ingyen kipróbálható.

De en meg varnek vele a kovetkezo nyilvanos probaverzioig. Meg elegge... hat... kiforratlan itt-ott.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Hat, igy 2015 korul hogy alunk az IPv6-al?

A stack meg van és inkább az ISP-ket kellene kérdezni, nem? :)

Kb. ott tartunk, ahol 2000-ben.

--
trey @ gépház

A csunya, hogy 2025-ben is ott fogunk tartani.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()