Xorg gondok

Fórumok

Helló!

Gondoltam upgradelek sargeről SID-re. (úgy néz ki roszzul tettem) Xorg lett az Xszerverem (vagymi) de az nem indul el, s miután nem indul kitesz egy ablakot, hogy "Failed to start the X server..." de ott mintha megfagyna. Legalábbis nem veszi a billentyűzet üzeneteket. Csak SSH-val lehet lelőni utána lesz csak jó. Csatolom a logot meg a confot:
http://vizi.uw.hu/Xorg.0.log
http://vizi.uw.hu/xorg.conf

Nagyon köszönöm a segítséget.

Hozzászólások

(EE) xf86OpenSerial: Cannot open device /dev/input/mice
No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device "Configured Mouse"

eloszor talan olvasd el a logot, es ezt csinald meg.
nalam pl /dev/psaux-kent megy az eger, igaz ez usb-s.

Ket dolog: Debian a ps/2 es usb-s egereket is /dev/psaux-ra rakja.

A masik meg hogy amig a sarge-ban "rendes" /ddev van, addig sid-ben udev. Namost udev alatt en sem latom az eszkozeim felet. Valahogy tuti be lehet oket loni de nem voltkedvem ezzel sz@rakodni ugyhogy egesz egyszeruen:

dpkg --purge udev

majd:

apt-get install hotplug

Az udev felvaltja a hotplugot is, es kezel elmeletileg az usb-s eszkozoket meg egy csomo mindent, olvasd el a manjat ha erdekel. Lenyeg az hogy kell neked hotplug vagy udev. :)

a meg valami.. ha usb-s egered van akkor a HID ugye bele van forgatva a kernelbe, es ha benne van mert beleraktad vagy mert a debian altal szallitott eloregyertott kernelt hasznalod es modulbkent van benne akkor ugye be van toltve a modul?

ellenorizni igy tudod:

lsmod

Ennek a kimenteben ilyesmit kell keresni:

usbcore 128132 4 ehci_hcd,uhci_hcd,usblp

(ez az usb tamogatas) Meg kell lennie valaminek amiben aneveben benne van hogy hid (nekem nincs ilyen modulom foleg mert nincs hid-es eszkozom) Ha nincsenek benne akkor a /lib/modules/ konyvtarakban keresgelj olyan fajlt amine a neveben benne van a hid, majd:

modprobe

es maris van usb-s eger meg bill...

De elmeletileg az udev torlese es a hotplug felrakasa megszabadit minden gondoddtol...

Nekem udev-em van, de semmi gáz nincs vele. Csomagból tettem fel és futik vele az usb-s dolgoktól az ieee-sekig minden, meg még a kékfogas eszközök is.
Nekem a hotpluggal az volt a bajom, hogy bootoláskor jöttek a már betöltött modulokról az üzenetek, legalább négyszer-ötszrör. És valahogy gyorsabbnak is tűnik udev-vel a boot.