[MEGOLDÓDOTT] KDE 5.18.5 összeomlás...

Fórumok

A tegnapi nagy KDE frissítés után ma bekapcsoltam a gépemet és a bejelentkezés után egy fekete képernyőt kaptam az egérkurzorral a közepén. A bal felső sarokban áttűnő kék folt, amire ha rákattintok, az Anydesk indul el (?).

Az ALT-F2 működik, tehát mindent szoftvert el tudok indítani, és használni is tudom őket, de az asztalt nem látom.

Újraindítás után néha megjelenik az asztal, de utána változatos dolgok történnek:

  • 10 másodpercenként eltűnik, megjelenik, majd fekete marad a képernyő
  • Folyamatosan látom az asztalt (a tálcán ott van a Plasma előző összeomlását jelző ikon), használni is tudom, de ha arrébb húzok egy asztali ikont, azonnal crash-el.

Egészen biztos vagyok benne, hogy a frissítések közül valamelyik okozhatja a problémát, de nem tudom melyik lehet az. Járt így más is? Vagy van valakinek ötlete, hogy mit kellene megnéznem?

KDE Neont használok, alatta a 18.04-es Ubuntuval.

[MEGOLDÓDOTT]

A május 22-i KDE frissítés óta eltűnt a probléma (kb. 60 KDE csomag frissült).

Hozzászólások

Szerkesztve: 2020. 05. 12., k - 08:04

Biztos, hogy nincs valami egyedi kwin scripted?

Esetleg próbáld meg, hogy kompozitor renderelő modult váltasz, vagy teljesen ki is kapcsolod.

Egyébként, meg valami log jó lenne, amiből pontosan látni, hogy mi baja.

Nincsen egyéni kwin scriptem.

A renderelő modulok közül az OpenGL 2.0 volt alapértelmezetten beállítva. Ezen kívül választható még kettő, az OpenGL 3.1 és az XRender. Kipróbáltam mindhármat, a hibajelenség megmaradt.

Ezután kikapcsoltam a Kompozitor bekapcsolása indításkor opciót, de a hiba így is megmaradt, ám most 10 mp múlva legalább újraindul a plasma shell és nem kell a gépet újraindítani.

Szívesen küldök logot, ha megírod, hogy melyikre lenne szükség.

Lehet, hogy tévedek, de egyelőre azt figyeltem meg, hogy a KDE saját szoftverei ikonjainak áthelyezésekor nem jelentkezik a hiba, csak ha külső gyártó szoftverének az ikonjával próbálkozom.

Közben visszakerestem a syslogban azt a – frissítés utáni – első gépindítást, ami után előjött a hiba, egészen a fekete képernyős újraindításig:

Valamint a Plasma összeomlás jelentő appjából kimásoltam a crash infókat:

Hátha találnak bennük valamit az értő szemek...

Szerkesztve: 2020. 05. 12., k - 08:18

Az MS újabb "fejlesztési hozzájárulása" a Linux elfogadottá tételéhez. (Az "Asztal" eltüntetése a W10 frissítésének egyik ismert featurája, szinte az első 10-es verziótól kezdve időnként fekete képernyő a közvetlen eredménye.) - "A minden mindennel összefügg" elméletének egy gyakorlati példája.  :)

systemd szapulás mellett, megpróbálnám a videokártya meghajtóját újratelepíteni.

3D-s alkalmazások futnak? pl: glxgears

Milyen videokártyád van?

Volt nekem is olyan, hogy telepítés közben valamely csomag letiltotta a vga drivert. 

cat /etc/modprobe.d/* | grep "vga_driver"

Meg olyan is volt, hogy leszedtem (purge)  azt a KDE csomagot ami elszállt és jó lett.

 

ps.: Ezek egyike sem a KDE hibája, csak itt jelentkezik. A csomagoló "hibája".

Nekem tegnap a settings->compositor alatt írt intel driver hibát. Valamit állítgattam és elindult az opengl. (azt vettem észre, hogy nem működtek az ctrl + f7 ... f10 billentyűk).

Nem írtad, hogy testing vagy user ágat használod, ha testing akkor:

https://github.com/tiguchi/kde-neon-downgrade

ha user akkor csak át kell írni testingre a reposytorit és lefrissíted. Így kitudod küszöbölni, hogy neon frissítés volt-e?

Arch-on ugyanez a frissítés pár napja nálam zökkenőmentes volt. Igaz nekem nem intel a GPU.