10GBE X540T2 X540T1 és samba

 ( cspguy | 2019. március 3., vasárnap - 13:28 )

Sziasztok,

X540T2/T1 kártyák freenas 11.2 és win 10 közötti SAMBA sebességével van bajom, amivel kapcsolatban esetleg némi info nem lenne haszontalan és erősen megköszönném.

N54L-ben benne a T1 freenassal és Desktop PC-ben a T2, Win 10.

Legfrissebb intel driver a Windowson, freenas is legújabbre frissítve.

A 2 kártya direktben összekötve egymással, ip címet ugyanabból a tartományban kézzel adtam nekik (10.0.0.X)

freenasban mtu 9000 opciónak megadva a kártyán.

Win oldalon Intel driver által jumbo 9014-re beállítva, Interrupt moderation rate Adaptive, Receive, transmit bufer 512.

Ha a buffer feljebbveszem, leesik a sebesség.

150-160MB/sec jön ki sima sata diszkből, ez ok.

Betettem melle egy ssd-t kölün volume-nak, az sem megy gyorsabban (RAID 0-ssd-ről, NVME-ről rámásolva sem.)

SSD-ből illene kijönnie az 500 olvasásnak és 400 írásnak kb.

ZFS system tunable-st felállítgattam a 10GBE kártyákhoz.

Mi lehet a gond, mihez lenne érdemes hozzányúlni?

Köszönöm szépen a válaszokat!

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hirtelen ezek jutnak eszembe:

1.) Első lépésként, viszonyítási alapként, mérd le iperf-fel a két gép közötti kapcsolat sebességét. Összetettebb protokollokat használva annál csak rosszabb értékeket fogsz mérni.
2.) Győződj meg arról, hogy a lehető legújabb Samba/CIFS protokoll verziót használod.
3.) A Samba adatátvitel során figyeld a CPU használatot, főként az N54L gépen. Akkora packet/sec értékek már kérhetnek enni rendesen.
4.) A Samba protokoll használata során sok oda-vissza kommunikáció történik, ahol a késleltetés erősen korlátozó tényező lehet. Próbáld több szálon végezni a másolást.

+1 Szerintem a 3.) es a 4.) lesz a problema.

Sziasztok,

köszönöm szépen a válaszokat!

Az N54L 30%-on pörög mindkét maggal.

Kipróbálom, amit leírtatok.