Win10 vs. Samba -> 0x80070035

 ( lajos22 | 2018. szeptember 18., kedd - 12:57 )

Eddig teljesen jól működő samba megosztás egyik pillanatról a másikra, random gépeken meghalt.
Változó, hogy egyik nap ezen, másik nap egy másik gépen találkozom a hibaüzenettel, mely szerint a megjelenő gépre kattintva az nem található. Interesting, de kajakra.
Kis guglizás, MS support tanácsa, töröljem a hálókártya illesztőjét, tegyem vissza. Hát ez oké, de a problémát ez nem oldja meg.
Találtam valami házirendeknél lévő beállításra utaló dolgot, a gépen viszont nem volt erre lehetőség.
Következő nekifutás sem jött be, de találtam egy gyenge elsunyult hivatkozást valami "AllowInsecureGuestAuth" beállításra. De az nem volt már ott, hogy ezt hol keressem. (Még mindig MS support oldala.)
Ráguglizva kijött a megoldás, regedit matatás. Továbbra is MS support oldal, az ott leírt helyen ilyen beállítási lehetőség nem volt.
Ám de, a regeditben van search lehetőség, éltem is vele. Hosszas keresgélés után (i7, NVMe SSD, majd 3 perc volt) megtalálta a kérdéses beállítást, ahol a 0-t 1-re átírva meglepetésemre már bekéri a gép a jelszavát.

Fasza...

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Melyik volt az a kérdéses beállítás? Hátha másnak is kellene.

Regeditben rákeresve a "AllowInsecureGuestAuth" paraméterre, ki is adja. A support szerint ez a ms/widows/lanmanworkstation-ben van, de ez a lanman nincs a windwos-ban, hanem valamerre máshol (nem néztem meg konkrétan.)

--
openSUSE 42.2 x86_64

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters alatt egy DWORD, ha jól látom ;)

Na megnéztem, a szóbanforgó gépen "controlpanel/***(sorszám, gépenként más más)/lanman... helyen van.

--
openSUSE 42.2 x86_64

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\default\LanmanWorkstation\EnableInsecureGuestLogons

https://kepkuldes.com/images/4e5c742ce9436ae4bddc0286cb8dfff5.jpg

A fentiekre gondolt mindenki elvileg?

Nope. A Névnek kell lennie az "Enable...." szövegnek. Az értéke 0 vagy 1.

--
openSUSE 42.2 x86_64

Berakhatnád a teljes registry útvonalat, ahol Te megtaláltad a registry-ben.

Véletlenül nem a Windows 10 1803 update-je után jelentkezettek az esetek?

Nem tudom már, majd meglesem.

--
openSUSE 42.2 x86_64

Na, meglestem, 1803 a verzió, de hogy azóta van-e baja, azt nem tudom megállapítani, mert csak most jelezték, de az enyém szerint ez 5. hóban települt fel, amikor az összes többi is. Csak én azt a gépet csak néha használom, ha már unom, hogy a core2-n akad a youtube.

--
openSUSE 42.2 x86_64

Na ezt holnap meglesem én is. Múlt héten még én is elértem a helyi kis fájlszerveremet. Ezen a héten már nem. Mindenkinek megy, csak nekem nem, csak én használok Windows 10-et.

Hajrá, nálam majd holnap derül ki, hogy ténylegesen megoldódott-e a probléma, vagy csak véletlen egybeesés, hogy az enyém jó lett ettől.

--
openSUSE 42.2 x86_64

Ebbe én is belefutottam pár hete, majd kipróbálom. Viszont az ideális megoldás inkább az lenne, ha a sambát lehetne úgy konfigurálni, hogy ez a beállítás ne okozzon problémát.

Talán van valami lehetőség, csak a sambát nem akarom munkaidőben piszkálni, amikor a (z amúgy tökéletesen működő) win7-es kliensekkel rajta lógnak.

--
openSUSE 42.2 x86_64

Ha mar veszed a faradtsagot, hogy blogolj errol, akkor igazan leirhattad volna osszeszedett modon, hogy pontosan mit irtal at mire a registryben. Ne kelljen mar 20-30 hozzaszolasbol kitalalni, amit +1 perc munkaval leirhattal volna az elejen.

Írtam, hogy gépenként változó az útvonal és érdemesebb rögtön a keresést használni.

--
openSUSE 42.2 x86_64

Akkor használj joker karaktert vagy írj rá egy reguláris kifejezést :D

Hát, hogy ez segített, vagy sem:
gpedit.msc -> Számítógép konfigurációja -> Felügyeleti sablonok -> Hálózat -> Lanman-munkaállomás -> Vendégek nem biztonságos bejelentkezéseinek engedélyezése -> Engedélyezve
Pár próbálkozás után, egyszer csak elértem a megosztást (FreeNAS 11.1-U6 Samba megosztás) hibaüzenet nélkül.