Trunk beallitas Hoston, switchen, NAS-on

 ( Vamp | 2017. május 2., kedd - 18:18 )

Sziasztok!

Adott egy Host(ESXi), ami ra van dugva egy switch-re(HP procurve) ket porton.

A hoston a ket port teaming-elve van.

Adott egy NAS(Thecus) ket gigabites portal, ez szinten teaming-ben van (load balancing)

A HP switchen letrehozva ket trunk (lacp) az egyik a host (trk2), a masik a nas(trk3).

a trk3 untaggelve a server VLAN-ba, a trk2 taggelve a szukseges VLAN-okba (server, client) a Hoston a VLAN settings kesz. (trunk nelkul megy szepen)

A gond:

Ezen beallitasok utan, van olyan VM a server VLAN-ban, ami elerheto, van olyan ami nem... ket AP sem akart mukodni.

trunk-ok lebontasa utan minden megy szepen...

Hol lehet a hiba a configban?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

En megprobalnam azonos tipusu trunkkel, pl., mindenhol lacp

-----------------------------------
Hell is empty and all the devils are here.
-- Wm. Shakespeare, "The Tempest"

Csakhogy a Cisco terminológiában ez pl. port-channel, máshol link-aggregation és a bónusz, hogy Cisco-éknál a trunk a több VLAN egy portra állítását jelenti. :) Pár éve jól megkaptam itt a magamét, hogy mit képzelek a trunkről...

ciscon az lacp member igy nez ki, a 'mode active' a lenyeg ez jelenti az lacp-t:

interface GigabitEthernet1/0/1
switchport mode trunk
switchport nonegotiate
channel-group 5 mode active

anelkul etherchannel lesz ami nem baratkozik a hp lacp-jevel!

A switchport mode trunk továbbra is azt jelenti, hogy tagged vlanokkal is használod. A sima access mode-os LACP így néz ki:

interface GigabitEthernet0/17
switchport access vlan N
switchport mode access
channel-group 1 mode active
end

interface GigabitEthernet0/18
switchport access vlan N
switchport mode access
channel-group 1 mode active
end

interface Port-channel1
switchport access vlan N
switchport mode access
end

Hogy a membereknél mennyire számít az access vagy trunk mód, azt nem próbáltam. Van viszont ugyanezen a switch trunk portos multivlan-os portchannelünk is és ott a port mode az trunk. :)

Az LACP két oldalán lehet passzív és aktív tag, szóval ez LACP-n belüli beállítás. Az ajánlás szerint két különböző eszközt mindkét oldalon aktív módba kell konfigolni.

+1

kb minden gyartonak megvan a sajat "teaming" modszere amik egymassal nem kompatibilisek. es altalaban azt eroltetik. az lacp a szabvany megoldas, amit kb minden tamogat, hasznald azt.

Reggel van, Trump beállításnak olvastam :D

A konfigban sok minden, de nem látom. Azt viszont tippelem, hogy a trk2 lacp és esxi lacp nem teljesen azonos. Az esxi oldalon összeállt? A trkába helyeztékor minden konfigot levettél az interfészekről? A trk-n próbáld meg az összes vlant átengedni és a vswitch-nél megadni, hogy melyik vlant használja.

Az lacp-nek az a lenyege ha jol tudom, hogy azonos barmilyen gyarto, tipus, stb.
A gond itt hogy a nason mas fele bond van, atkell rakni laco-re.
---------------------------------------------------
Hell is empty and all the devils are here.
-- Wm. Shakespeare, "The Tempest"

LACP és LACP elvileg gyártófüggetlenül kommunikál egymással. Nekem inkább a NAS oldalról a "load balancing" a gyanús! Ha ez RR load balancing, az nem fog normálisan kommunikálni a switch oldali LACP-vel!

----------------------------------^v--------------------------------------
"Probléma esetén nyomják meg a piros gombot és nyugodjanak békében!"

Az LACP a switchel kommunikál csak, mással nem, de a megérzésed jó, mert mac, ip vagy egyéb alapján végez load balance tevékenységet, így egyébkét ha működni is fog a kollégának a két eszköz közt max 1Gb-re számíthat, vagy többre.

Milyen teaming van a hoston kiválasztva? Etherchannelhez IP hash kell. Továbbiak: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004048

Ez most storage traffic (gondolom, azért említetted a NAS-t) vagy nem? Ha igen, akkor NFS vagy iSCSi?
--

"After successfully ignoring Google, FAQ's, the board search and leaving a undecipherable post in the wrong sub-forum don't expect an intelligent reply."

NFS

Akkor nason legyen ez: 802.3ad ,
vmware-t nem ismerem de lehet az se jo,
hp-n meg aligha jo az lacp disabled beallitas.

Igen, azt neztem en is most... aktiv vagy passziv mod van.

Milyen verziós ESX van? Host felé menő LACPhez 5.1 kell minimum és szerintem dvSwitch is. Ha host felé etherchannel van akkor, teamingnél a loadbalance legyen ip hash.

ESXi 6.0.0

A VMware beállítás jónak tűnik, a NAS beállítása rossz, ahogy azt már említették is (802.3ad kell). A HP beállítása is jónak tűnik a tapasztalataim alapján, de azért nem ártana, ha a "Mode" környékén ott is szétnéznél, biztos ami biztos.

lacp status: disabled ????

mar enabled :)

Na, most mar jo a NAS, meg az ESXi a kerdes... Azt is LACP-re tennem, viszont ott a beallitasok (Switch+ESXi) meg nem teljesen tiszta...

Ha nincs dvSwitched(ehhez ugye Enterprise Plus és vCenter), akkor csak etherchannel fog menni(ip hash loadbalance beállítás).

Ertem... ez a Host egy "sziget", van vCenter-unk is, de az egy masik telephely.

Akkor marad a loadballance. Az akkor a fontebb linkelt vmware video tutorial szerint mehet?

vmware 2 interface eseten failoverezni szokott, nem lacp. en legalabbis nem lattam meg lacp beallitasi lehetoseget, vszinu az tenyleg csak vswitch-el van.

Szuper, mukodik minden :)

Vegul a NAS lacp lett, az ESXi pedig "sima" trunk.

Koszi mindenkinek a segitseget!