KDE 3.3 frissítés után billentyű gond

 ( zz7 | 2005. január 8., szombat - 0:53 )

KDE 3.3 frissítés után billentyű gond

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Na szóval a hiba okát én sem találtam meg, csak egy ideiglenes kerülő megoldást, ami biztos kicsit amatőr, de nekem működik.
/etc/init.d/kdm -et kicseréltem egy olyanra, aminek tartalma csak ennyi:

#!/bin/sh
kdm

És működik a billentyűzet elsőre is. Legalábbis nálam ez bevált.
A hiba okát majd megpróbálom felderíteni, csak végig kellene rágnom magam a script-eken, hogyan is indítják a KDM-et.
Csak szabadidő kérdése, mert még nem vagyok egy script bajnok.

Üdv

ZZ

[quote:df8245c90b="zz7"]Most frissítettem KDE 3.3-ra a Debian Sarge-t.
A gondom az, hogy KDM-ben nem tudok bejelentkezni, mert nincs billentyűzet. Egér van. ALT+F1 -re sem reagál a billentyű.[/quote:df8245c90b]

Ilyesmi nekem akkor szokott lenni, amikor a gdm/kdm/xdm egy olyan virtuális konzolra ül rá, melyen már fut egy szöveges bejelentkezés (getty).

pontosan. tehat *dm configjaban olyan vt-t adj meg, amin nem fut /etc/inittabban megadott *getty :wink:

Nekem ugyanez a problémám, de így vizsgaidőszakban, még csak 2x találkoztam vele, többször nem volt boot:)
Szóval nem is tudom a getty-s dolgot megnézni, bár nem tudom egyből, ezt hogy lehetne megoldani. Le tudod írni?

Kösz!

szerk: lassú vagyok:)

szerk2: megnéztem kdm dirt, sehol semmi tty-os cucc, csak a /etc/kde/kdm/Xservers fileben egy ilyen:
:0 local@tty1 /usr/X11R6/bin/X -nolisten tcp

A régebbi kdm csomagban még a végén van egy [b:38c3427181]vt7[/b:38c3427181], gondomom ezt beírod, azt jó is lesz!

Igen!

Ez kel álljon a /etc/kde3/kdm/Xservers -ben:
:0 local@tty1 /usr/X11R6/bin/X -nolisten tcp vt7

Így már müxik

Sziasztok!

Most frissítettem KDE 3.3-ra a Debian Sarge-t.
A gondom az, hogy KDM-ben nem tudok bejelentkezni, mert nincs billentyűzet. Egér van. ALT+F1 -re sem reagál a billentyű.
Ha egérrel kattintgatva kijelentkezek a KDM-ből és konzolon találom magam, akkor van billentyűzet.
Itt belépek root-ként, beírom hogy kdm, el is indul és most már van billentyűm.
Innentől minden ok.
Ez minden indításkor így megy csak. Elsőre nincs billentyű, konzol, root, kdm és megy.
Nem tudom merre induljak.
Légyszi segítsetek.

Üdv

ZZ

Hali!

Nekem is ugyanez történt.
Gyanús a syslogban valami kdm panaszkodás. Amúgy nem volt sok időm foglalkozni vele és én is a konzolos belépés módszerrel loggoltam be.
Tegnap frssültek a X csomagok is. Nem mondom, hogy van összefüggés, de ma már nem csinált ilyet a kdm, talán neked is segít majd a frissítés.

üdv

khm... visszavonom az előző hozzászólást... most megint kikapcsolja a billentyűt a szutyok :(
nem tetszik, hogy néha megy, de általában nem...

üdv