openLDAP és debian

 ( szaty | 2004. november 30., kedd - 19:46 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Azért kell mert a leg újabb és én most csak a szolgáltatásait akarom kipróbálni nem élesben használni. A debian csomaggal az a baj hogy nem hajlandó se bdb se ldbm adatbázissal elindulni.

A gcc nem hiányzik az fel van rakva.
gpp meg nem kell neki nem is kéri.(ha jól értetem amit kiirt)

a debian csomagból föltett ldapnaka ez a pontos reakciója:

Unrecognized database type (ldbm)

Sziasztok,

Egy openLDAP-ot szeretnék leforditani de a configure mindig kiakad.

Copyright 1998-2004 The OpenLDAP Foundation. All rights reserved.
Restrictions apply, see COPYRIGHT and LICENSE files.
Configuring OpenLDAP 2.2.17-Release ...
checking host system type... i686-pc-linux-gnulibc1
checking target system type... i686-pc-linux-gnulibc1
checking build system type... i686-pc-linux-gnulibc1
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for mawk... mawk
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking for gnutar... no
checking for gtar... no
checking for tar... tar
checking configure arguments... done
checking for a BSD compatible install... /usr/bin/install -c
checking for cc... cc
checking for ar... ar
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for EMX OS/2 environment... no
checking how to run the C preprocessor... /lib/cpp
checking for gcc... (cached) cc
checking whether the C compiler (cc ) works... no
configure: error: installation or configuration problem: C compiler cannot creat
e executables.

Milyen csomagot kell föltenni hogy ilyen ne történyen?

Az is megoldás ha valaki tud küldeni egy slapd csomag 2.2-es vagy annál nagyobb verziójú változatát.

Előre is kösz mindenkinek.

Ui: sid-et használok

ftp://ftp.bayour.com/pub/debian/dists/woody-ol2.2/binary-i386/OpenLDAP22

Próbáld meg ezt, hátha... Amúgy meg nézelődj gcc táján, azzal van a fordításnak baja.

a csomagok woodyhoz vannak és nem is mennek sid-del az istenek sem.
Szerintem nem a gcc val van baj hanem v mi mással erre a következő sorból gondolok:

checking for working makeinfo... missing

De azt hogymilyen csomagot kell förakni lövésem sincs.
make
automake
fönn vannak.

[quote:69e96614bd="szaty"]a csomagok woodyhoz vannak és nem is mennek sid-del az istenek sem.
Szerintem nem a gcc val van baj hanem v mi mással erre a következő sorból gondolok:

checking for working makeinfo... missing

De azt hogymilyen csomagot kell förakni lövésem sincs.
make
automake
fönn vannak.[/quote:69e96614bd]
nezd meg a configure filet. megtalalod benn azt a reszt ami ezt a hibauzenetet irja ki. ha oda ranezel ra fogsz jonni mi hianyzik.
Ha nem akkor a brute force megoldas:
tasksel
es tedd fel a C fejleszto csomagot.
na abban minden szukseges dolog benne van.
A makeinfo egyebkent a texinfo csomag resze, es az info oldalakat generalja vele.

Szerintem egy apt-get install gcc megoldja a problémát :) Szimplán hiányolja a C fordítót, legyen az bármely típus. Szóval ez egy C hiányolós...
Szerintem... ;)

Sőt, leszeded az apt-src nevű csomagot, majd apt-src install csomagnév, és apt-src build csomagnév. Ha a gcc fel van rakva, akkor ő már a többi szükséges dolgot leszedi magának.

[quote:6d7301558d="szaty"]
checking whether the C compiler (cc ) works... no
configure: error: installation or configuration problem: C compiler cannot creat
e executables.

Milyen csomagot kell föltenni hogy ilyen ne történyen?

[/quote:6d7301558d]
Hello!
Szerintem apt-get install gcc g++

u.i.: minek neked 2.2-es slapd? 2.1.30 van sarge-ban, de nekem eddit teljesen eleg volt mindenhez.

Udv.