MPlayer + Celeron = csuszik a hang?

 ( testerlnx | 2004. november 11., csütörtök - 21:19 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Sziasztok!

Kb 3 honapja hasznalok MPlayer-t AthlonXP-n PIV-en es Celeron illetve Mobile Celeron-on, raktam fel mindegyikre forrasbol es package-bol is (mind SuSE). Sajnos mind a laptopomon (Mobil Cerka) mind a Celeron-os gepen, egy ido utan (5-10 perc) megugrik a kep es elcsuszik a hang, majd kb 5-10 mp utan vissza all... Nem tudjatok mi lehet a gond, es hogy lehet kikuszobolni a problemat?

[quote:a7adfe61cb="testerlnx"]Sziasztok!

Kb 3 honapja hasznalok MPlayer-t AthlonXP-n PIV-en es Celeron illetve Mobile Celeron-on, raktam fel mindegyikre forrasbol es package-bol is (mind SuSE). Sajnos mind a laptopomon (Mobil Cerka) mind a Celeron-os gepen, egy ido utan (5-10 perc) megugrik a kep es elcsuszik a hang, majd kb 5-10 mp utan vissza all... Nem tudjatok mi lehet a gond, es hogy lehet kikuszobolni a problemat?[/quote:a7adfe61cb]
Ha a proci lassú neki akkor kapcsold be a framedroppingot a d-vel lejátszás közben, vagy a -framedrop paraméterrel.

Sajnos attol meg csunyabban viselkedik :( Probaltam mind 2 framedroppal is...

Amugy 2.4GHz (128k cache) a proci, a mobile meg 1.5GHz-es...

Most probaltam ugy hogy "--disable-rtc" -vel forditottam, igy nemi javulast tapasztaltam, de igy is neha egy kicsit el kezd sietni a kep es kb 4-5 mp mulva szinkronizal a hanggal (joval kevesebb ideig csuszik, de csuszik :()...

Melyik audiomeghajtót használod? ALSA, ARTS, OSS...?

Nekem 1.7Celeron alatt UHU-Linux gyári MPlayer csomag ugyanezt csinálja 10 filmből 1 esetén, framedrop állandóan be van kapcsolva. OSS hangot használok, asszem Xv a video, ATi Radeon 9000 chipsetes kártya az ATi fglrx driverrel.

De nem minden filmnél! Talán formátumfüggő, sosem figyeltem. A NumPad +- szabályozza a hang késleltetését menet közben a MPlayeren.

LG

Asszem ALSA van (SuSE amit beallit alapbol azt hasznalom), amugy a filmek mind mencoder-el capture-oltek (-ovc lavc -lavcopts vcodec=mpeg4:vbitrate=2000).

-ao sdl kimenettel tesztelgess egy darabig, az arts-ot szvsz tiltsd le, es probald a rossz filmeket xtermbol inditott mplayerrel nezni.
(Igazabol a legjobb lenne kilott X mellett konzolbol tesztelni.)

Toma_

en ugy szoktam hasznalni, hogy ne csusszon a hang, hogy lelovom a hangkezelo demont (arts helyett nalam esd van de egykutya) es hagyom hogy maga keresse ki a legjobbat. emmelle -framdrop -autosync 30 kapcsolokkal inditom es ha tudod xv vagy xvidix drivert hasznalj video outputnak. nekem bevallt.

bar sajnos nemelyik filmmel barmit csinalok alapbol el van a hang romolva, mindegy milyen lejatszoval nezem...

[quote:8137e9cfc1="gdavid"]en ugy szoktam hasznalni, hogy ne csusszon a hang, hogy lelovom a hangkezelo demont (arts helyett nalam esd van de egykutya) es hagyom hogy maga keresse ki a legjobbat. emmelle -framdrop -autosync 30 kapcsolokkal inditom es ha tudod xv vagy xvidix drivert hasznalj video outputnak. nekem bevallt.

bar sajnos nemelyik filmmel barmit csinalok alapbol el van a hang romolva, mindegy milyen lejatszoval nezem...[/quote:8137e9cfc1]

Szerintem probalj egy -nobps kapcsolot, altalaban meg szokta oldani a hang szinkronizalasi problemat. Legalabbis 500AMD-n nalam mukodott...

Köszönöm! Végig próbálom amiket mondtatok.