Segítség, nem lehet démont indítani!

 ( AMD | 2004. augusztus 25., szerda - 18:58 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hi!

A topic címe magáért beszél. Nem mindegyik démon indul el a Debianos gépemen. Egyedül az apache és a proftpd megy, de pl. az sshd, samba és eggdrop nem. Az sshd kimenete:
daemon() failed:Success

A konfigokkal nincs baj, debug/no-daemon módban mennek a progik...

Egyik ismerősöm javasolta hogy próbáljam meg purge-olni az apache-t, lehet hogy az okozza, megtettem, de nem oldotta meg a problémát...

Valaki segítsen, mert nekem már semmi 5letem :(

[quote:a569845904="AMD"]Nem mindegyik démon indul el a Debianos gépemen. Egyedül az apache és a proftpd megy, de pl. az sshd, samba és eggdrop nem. Az sshd kimenete:
daemon() failed:Success
[/quote:a569845904]
Ez nagyon gaz. Ugyanis a daemon() az egy fuggvenyhivas, a libc resze ha jol tevedek. Az ter vissza hibaval, de amikor leolvassak a hibat, akkor az jon, hogy minden rendben van. Ez attol lehet, hogy azota mas fuggvenyt is meghivott valahogy, es az torolte a hibakodot. Frissitettel libc6 csomagot? Melyik Debian valtozat (stable/testing)?

[quote:a569845904="AMD"]A konfigokkal nincs baj, debug/no-daemon módban mennek a progik...
[/quote:a569845904]
Pontosan. De ha csak siman beirod, hogy sshd rootkent, akkor szinten nem indul el az sshd ugye? Ugyanis amikor debug modban futtatod, kihagyjak a daemon() fuggvenyhivast.

[quote:a569845904="AMD"]
Egyik ismerősöm javasolta hogy próbáljam meg purge-olni az apache-t, lehet hogy az okozza, megtettem, de nem oldotta meg a problémát...[/quote:a569845904]
Ez biztosan nem igaz.

Egyvalamit neznek meg, de csak tapogatozas; letezik /dev/null es
[code:1:a569845904]crw-rw-rw- 1 root root 1, 3[/code:1:a569845904] ilyen jogokkal major/minor szamokkal? Fontos, hogy legyen, c-vel kezdodjon...
/GCS

Stable verzió, a ftp.hu.debian.org-ról származó 3.0r2 ISO-jából telepítettem.

Délután még próbálkoztam, akkor láttam a következőt:
A /dev/null-ra olyasmit ír ki, hogy Could not create /dev/null: read-only file system. (most nem tudom még1x megnézni mert nincs ott a monitor "^^)
Az a fura hogy a root partíció mount opciói rw,default voltak, de próbáltam csak rw-vel, de így is ugyanazt írta ki.
Minél előbb megpróbálom visszapakolni a moncsit, és akkor pontosan leírom mi ír a /dev/null-ra.
(most a házikedvenc 486osomra pakolom a win31-et vele, mert mono VGA-van nem akar fölmenni :) )

Megvan.
A pontos üzenet:
[code:1:1105941d36]
(...)
INIT version 2.48 booting
/etc/init.d/rcS: /dev/null: Read-only file system
/etc/init.d/rcS: /dev/null: Read-only file system
Activating swap
/etc/init.d/rcS: /dev/null: Read-only file system
(...)
[/code:1:1105941d36]

A root filesystem mount opciói pontosan:
[code:1:1105941d36]/dev/hda1 / ext2 rw 0 1[/code:1:1105941d36]

A /dev/null jogai:
[code:1:1105941d36] -rw-r--r-- [/code:1:1105941d36]
Tehát nincs C. És nem is tudok rá ilyet adni, mert amint látom ez az eszközfájloknak (pl. dsp, fb0, ...) van............