SSH

 ( linuxguru | 2004. augusztus 9., hétfő - 13:10 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

[quote:d22e2c369a="szucs_t"]Ha valaki birtokában van a privát SSL kulcsom, akkor mit tud vele kezdeni? Minden lehetséges rosszat írjatok le, kérlek![/quote:d22e2c369a]

Ugyerted rsa_id/dsa_id ?

[quote:b8f62e97f5="WoOh"][quote:b8f62e97f5="szucs_t"]Ha valaki birtokában van a privát SSL kulcsom, akkor mit tud vele kezdeni? Minden lehetséges rosszat írjatok le, kérlek![/quote:b8f62e97f5]

Ugyerted rsa_id/dsa_id ?[/quote:b8f62e97f5]

Kompletten az egész, azok is.

Kozeppontban az SSH!

ezt most mi a halálnak łrtad? :?

HI!

Kerdes: ssh servernel hogyan tudom beallitani, hogy csak 1 bizonyos felhasznalo tudjun csatlakozni? Root -kent se tudjak belepni esetleg utanna
[b:fa0c17b5fc]su - root [/b:fa0c17b5fc]-kent?

Udv! :roll:

sshd_config ba ird bele h AllowUsers user1 user2
aztan sshd restart es ezutan sshn csak az itt felsorolt userek tudnk belepni.

udv, sne

Koszke!

Muxik.

Udv

sne: elfelejtetted a jelszavad? :wink:
(mi ez az új nick)

[quote:707f19941f="linuxguru"]
Root -kent se tudjak belepni
...
Udv! :roll: [/b][/quote:707f19941f]

sshd_config-ban a root külön is szabályozható, a PermitRootLogin yes/no-val.

D.

Ez a linuxguru nick csak vicc, ugye? :wink:

valaki a nickjében fogalmazza meg az álmait :lol:

Gondoltam ha nem foglalt miert ne :D

De meg lehetek Linuxguru!!!!! :lol:

[quote:801024cb5b="linuxguru"]Gondoltam ha nem foglalt miert ne :D

De meg lehetek Linuxguru!!!!! :lol:[/quote:801024cb5b]

Csak mert furcsa, amikor egy linuxguru ilyeneket kérdez... Remélem, most nem vagyunk túlságosan biciklizős szinten :D Lásd
[url]http://hup.hu/modules.php?name=News&file=article&sid=6634&mode=&order=0&thold=0[/url]

Ehe-ehe! :D
Ertem es igyekszem :!:

Szóval ha még nem sikerült beállítanod, íme a varázs szavak.
Az /etc/ssh/sshd_config fileban állítsd be a következéket:
PermitRootLogin no
DenyUsers ?
AllowUsers user

A "user" helyett a kívánt usert add meg.

Have a nice day!

Kedves Linuxos Fórumozók!

Mi lehet annak az oka, hogy ha nem root-ként lépek be, a su-val nem tudok másik felhasználóra belépni? Mindig azt írja ki, hogy "incorrect password". Valószínűleg ugyanezen okból nem érhető el https-sel a honlap sem, csak sima http-vel. Shadow jelszavakat használok. Milyen jogosultsági probléma lehet?

Meg van egy par fincsiseg:
AllowGroup
DenyGroup

Asszem igy s nelkul irjak...

[quote:7c246c03a5="vmiklos"][quote:7c246c03a5="linuxguru"]Ehe-ehe! :D
Ertem es igyekszem :!:[/quote:7c246c03a5]
a szomszédunk kocsijának rendszáma: FEJES-1
az is valami hasonló eset :wink:[/quote:7c246c03a5]

azért egy fekete 3-as BMW tulajától azért lehet azt hinni, hogy fejes... vagy nem?

[quote:9931545cb9="szucs_t"]Kedves Linuxos Fórumozók!

Mi lehet annak az oka, hogy ha nem root-ként lépek be, a su-val nem tudok másik felhasználóra belépni? Mindig azt írja ki, hogy "incorrect password". Valószínűleg ugyanezen okból nem érhető el https-sel a honlap sem, csak sima http-vel. Shadow jelszavakat használok. Milyen jogosultsági probléma lehet?[/quote:9931545cb9]

Rosszul megy át valamelyik karakter.

[quote:6c7208ed37="linuxguru"]Ehe-ehe! :D
Ertem es igyekszem :!:[/quote:6c7208ed37]
a szomszédunk kocsijának rendszáma: FEJES-1
az is valami hasonló eset :wink:

A su-val meglett a megoldás, nem tudom miért, de a setuid bit kellett neki.

Jolvan, ugyes, okos :lol:
Debian GNU/Linux support? :lol:
:idea:

nemide :wink:

[quote:4972dbf481="vmiklos"]nemide :wink:[/quote:4972dbf481]

Hát, a https-es probléma nem oldódott meg. Nem lehet, hogy valamit annak idejét setuideztem, és azért működött? Én nem szeretem azt a setuidet, minek fusson gyökérként valami?

openssllel generáltad a cert-et, vagy mivel? az biztos, h rendben van? :wink:

Hejj,

netstat -l

van egyatalan valami a 443-on? tuzfalon beengeded? lynx-el megy?

vagy en ertem felre es apache anyazik neked, hogy 404?

Igen, jól generáltam le, legalábbis ugyanúgy, ahogyan korábban.

Semmilyen böngészővel sem megy. Lehet, hogy mafla vagyok, és nem SSL-lel indítottam az apache-ot. Azonban ha így van, és a httpd.conf-ban beállítottam az SSL dolgokat, nem kellene valamilyen hibaüzenetet kiírnia?

[quote:74678467a0="szucs_t"]Semmilyen böngészővel sem megy. Lehet, hogy mafla vagyok, és nem SSL-lel indítottam az apache-ot. Azonban ha így van, és a httpd.conf-ban beállítottam az SSL dolgokat, nem kellene valamilyen hibaüzenetet kiírnia?[/quote:74678467a0]
Nem.

[quote:02a07a0000="GCS"][quote:02a07a0000="szucs_t"]Semmilyen böngészővel sem megy. Lehet, hogy mafla vagyok, és nem SSL-lel indítottam az apache-ot. Azonban ha így van, és a httpd.conf-ban beállítottam az SSL dolgokat, nem kellene valamilyen hibaüzenetet kiírnia?[/quote:02a07a0000]
Nem.[/quote:02a07a0000]

Akkor tutira ez a probléma. Biztosan a helyreállításkor (mert valami "kötsög" Romániából feltörte a szervert) valamilyen korábbi indító szkriptet másoltam vissza. A setuid bites dolgokat mind átírtam. Ez nem lehet probléma? Lehet, hogy valamit nagyon szigorúra tettem. Ha a wwwrun felhasználó alatt fut az apache, és a felhasználónak még shellje sincs, akkor ő helyesen tud futtatni SSL-es webkiszolgálót?

Ha valaki birtokában van a privát SSL kulcsom, akkor mit tud vele kezdeni? Minden lehetséges rosszat írjatok le, kérlek!