2.4.26 - grsec + phpnuke nem megy, létezik ez ????????

 ( Anonymous | 2004. május 24., hétfő - 21:13 )

2.4.26 - grsec + phpnuke nem megy, létezik ez ????????

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hali!

Feltettem a 2.4.26 - grsec kernel-t, debian woody-ra, és azóta nem megy egyik php-nuk verzió sem, ebben az a durva, hogy eddig ugyanezen a gépen 2.4.25 grsec-nélkül ment, létezik, hogy emiatt nem megy a nuke rendszer ???

php4.x.x, mysql-server, apache1.3.x, minden ugyanúgy konfigolva mint amikor még ment egy különbséggel, hogy a 2.4.25 szimpla kernel helyett 2.4.26-grsec és nem megy........létezik ez ????

mi az, hogy nem megy? :wink:

ez annyit jelent, hogy ha böngészövel szeretném megyitni az oldalt, akkor egy üres site jön le, de ha beteszek egy egyzerű php-kódot tartalmazó php fájlt a documentroot-ba akkor az szépen működik, de a nuke meg se moccan, megnéztem az sql logokat semmi hibára utaló jel, az apache logjaiban szintén semmi geb@sz, tehát php megy, apache jól viselkedik, mysql client/server szintén jó, de az a kib@sz*tt php-nuke b************** működni, már elnézést, és minden a nagykönyv szerint van beállítva, na ilyenkor tudok agyvérzés közeli helyzetbe kerülni.........na látjátok ha az a ********************** windows csinálja ezt velem, meg a sz@r IIS6 akkor legalább tudok anyázni a mikroszoft magyarországi képviseletének, hogy adják visza a pénzem és az idegsejtjeim nagyrészét.............na lehigadtam sorry, kicsit felment az agyvizem...........azért még reménykedek hátha tudtok erre valamit mondani nekem.......az a baj hogy nem tudok logokat küldeni mert tök üresek.......

na huuuuhhh.....:)))

[quote:fa8b1948f0="Anonymous"]ez annyit jelent, hogy ha böngészövel szeretném megyitni az oldalt, akkor egy üres site jön le, de ha beteszek egy egyzerű php-kódot tartalmazó php fájlt a documentroot-ba akkor az szépen működik, de a nuke meg se moccan, megnéztem az sql logokat semmi hibára utaló jel, az apache logjaiban szintén semmi geb@sz, tehát php megy, apache jól viselkedik, mysql client/server szintén jó, de az a kib@sz*tt php-nuke b************** működni, már elnézést, és minden a nagykönyv szerint van beállítva, na ilyenkor tudok agyvérzés közeli helyzetbe kerülni.........na látjátok ha az a ********************** windows csinálja ezt velem, meg a sz@r IIS6 akkor legalább tudok anyázni a mikroszoft magyarországi képviseletének, hogy adják visza a pénzem és az idegsejtjeim nagyrészét.............na lehigadtam sorry, kicsit felment az agyvizem...........azért még reménykedek hátha tudtok erre valamit mondani nekem.......az a baj hogy nem tudok logokat küldeni mert tök üresek.......

na huuuuhhh.....:)))[/quote:fa8b1948f0]

Ha a grsec ügyködik, akkor ő beleírja a kernelnaplóba hogy mit csinált.
pl. signal11-t küldött xyz alkalmazásnak, unthrusted exec, stb...célszerű minden grsec kernelnaplózási opciót bekapcsolni.

grsec acl-t bekapcsoltad? - az bekavarhat, de a kernelnaplóban benne vagyon.
PaX-ot? - ez már sz'tem kevésbé.

Ill. az is lehet, hogy 2.4.26 grsec nélkül sem megy...?

Van valami HW-es oka, hogy a 2.4.26hoz ragaszkodsz, amiért nem jó a javított
2.4.18-as woody kernel? - 1.9.9h-s grsec -et FULL hozzá lehet idomítani közepes munkával.
A benne levő 1.9.4-eset acl nélkül - sz'tem nincs hozzá működő gradm, az 1.9.4-es valamiért nem működik. paxot hozzá lehet, de nem biztos, hogy lehet chpax-al vezérelni.

[b:1cf41f4c01]Anonymous írta:[/b:1cf41f4c01]

[quote:1cf41f4c01] az a baj hogy nem tudok logokat küldeni mert tök üresek....... [/quote:1cf41f4c01]

Feltehetőleg :

2.0-ást használsz és olyanok a beállításaid hogy a syslog és a klog sem képes elindulni...

( pl. high security, default módban a /dev/log sem elérhető, sőt az iptables sem indul )

Javaslat :
Állj vissza a régi kerneledre, vegyél elő papírt ceruzát, olvasd át a gracldoc-ot, módszeresen tervezd meg a biztonsági rendszert, írd meg a saját acl fájlodat, csak ezután bootolj grsec-es kernelt....

A legjobb az ha két kerneled van és felváltva bootolsz... :twisted: