[MEGOLDVA] hálokártya nem indul

 ( jupiter2005ster | 2011. december 14., szerda - 1:05 )

hello

a szituáció az hogy a második hálókártya nem indul el automatikusan, azaz az udev nem csatlakoztatja.
ha ifup-om akkor minden szép és jó.

a dmesg-ben ez látszik (az udev debug-ra állítása után):
[ 1.732056] e1000: eth1: e1000_probe: Intel(R) PRO/1000 Network Connection
[ 1.732139] alloc irq_desc for 22 on node -1
[ 1.732139] alloc kstat_irqs on node -1

a /proc/net/dev alat szépen látszódik az eth0 és az eth1, de csak az eth0 van forgalom (mivel ugye az eth1 még nem megy).
cat /proc/net/dev
Inter-| Receive | Transmit
face |bytes packets errs drop fifo frame compressed multicast|bytes packets errs drop fifo colls carrier compressed
lo: 560 8 0 0 0 0 0 0 560 8 0 0 0 0 0 0
eth0: 35515 438 0 0 0 0 0 0 48147 311 0 0 0 0 0 0
eth1: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

van valakinek ötlete hogy merre keresgéljek?

előre is köszönök minden segítséget.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hogy néz ki az interfaces file?

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
#NetworkManager

iface eth1 inet dhcp

iface eth0 inet static
address 192.168.1.62
netmask 255.255.255.0
gateway 192.168.1.254

--
http://hu.opensuse.org
http://phoenix-art.hanzo.hu/

En a helyedben ebben a sorrendben neznem meg a dolgokat:
- ethtools <- van-e link? (s a kabel "masik vegen logo" eszkozt is megneznem, hogy mit lat sebesseg gyanant
- ifconfig <- van-e IP
- netstat -rn <- van-e routing
- iptables <- van-e olyan rule ami tiltja a kimeno forgalmat (ne nevess, lattunk mar ilyet...)

A ping es a traceroute is jo segitseg tud lenni.
ping loopback <- csak ellenorzesnek
ping iface address <- ha ez sem megy, akkor driver problema szokott lenni
ping default gw a network-on

ez a baj, de nem tudom miért.

root@debian-cluster-2:/etc/apt# ethtool eth1
Settings for eth1:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: umbg
Wake-on: d
Current message level: 0x00000007 (7)

Link detected: no

root@debian-cluster-2:/etc/apt# ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: umbg
Wake-on: d
Current message level: 0x00000007 (7)

Link detected: yes

IP nem lesz mert nem indul el a kártya magától.
root@debian-cluster-2:~# ifconfig
eth0 Link encap:Ethernet HWaddr 08:00:27:b7:21:c9
inet addr:192.168.1.62 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:feb7:21c9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:283 errors:0 dropped:0 overruns:0 frame:0
TX packets:220 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:26012 (25.4 KiB) TX bytes:29122 (28.4 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:560 (560.0 B) TX bytes:560 (560.0 B)
/


root@debian-cluster-2:~# netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 192.168.1.254 0.0.0.0 UG 0 0 0 eth0

nincs, mert friss rendszer.

root@debian-cluster-2:~# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Egyébként, ez egy VirtualBox 4.1.4-ben létező VM, bár nem kéne hogy számítson.
--
http://hu.opensuse.org
http://phoenix-art.hanzo.hu/

LOL, láma voltam nagyon. Az interfaces fájlból hiányzott az "allow-hotplug eth1" rész. Ezután már jól megy :)

köszönöm a segítséget és az ötleteket.

--
http://hu.opensuse.org
http://phoenix-art.hanzo.hu/