Debian Woody PS/2 egér gondok

 ( Ochronus | 2002. december 24., kedd - 21:15 )

Debian Woody PS/2 egér gondok

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Sziasztok!



A problémám a következő: felteszem szépen a woody-t, de mintha nem látná a PS/2-es egeremet. Az eszközből is hiába olvasok közvetlenül, és ezután konzekvensen sem a gpm sem az X nem látja az egerem. Ez ez teljesen standard PS/2-es, 2 gombos rágcsáló. Van valami tippetek, hogy mit tegyek?



Köszi

Quote:


On 2002-12-23 22:23, Ochronus wrote:

Sziasztok!



A problémám a következő: felteszem szépen a woody-t, de mintha nem látná a PS/2-es egeremet. Az eszközből is hiába olvasok közvetlenül, és ezután konzekvensen sem a gpm sem az X nem látja az egerem. Ez ez teljesen standard PS/2-es, 2 gombos rágcsáló. Van valami tippetek, hogy mit tegyek?



Köszi






/etc/X11/XF86Config(-4) kellene hozza. Idezd be az egerre vonatkozo reszt. Valahogy igy kell kineznie:



[...]

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/psaux"

Option "Emulate3Buttons" "true"

Option "ZAxisMapping" "4 5"

EndSection

[...]



Ez egy gorgos eger, ha nem az van neked, hanem csak sima PS/2 akkor az



Option "Protocol" "PS/2"



igy nez ki, es nem kell a



Option "ZAxisMapping" "4 5"



opcio.



Ezt ellenorizd el. Kernelbe legyen PS/2 eger tamogatas.

1: kernel beallitasok jok? CONFIG_MOUSE=y ; CONFIG_PSMOUSE=y

2: /dev/psaux



3: GPM: /etc/gpm.conf

device=/dev/psaux

repeat_type=ms3

type=autops2

sample_rate=100



4: XFree86: /etc/X11/XF86Config-4

Section "InputDevice"

......

Driver "mouse"

Option"Device""/dev/psaux"

Option"Protocol" "PS/2"

....

Köszi a tippeket, nem az X configgal, vagy GPM configgal vannak gondok, azokhoz úgy-ahogy értek. Azóta buheráltam kicsit a BIOSban, most látja az egeret, (eddig a /proc/interrupts -ban sem volt benne), használja is szépen minden, de ha X-ből párszor visszaváltok konzolra (nem frame bufferes, nem ez a hiba), akkor "lefagy" az egér, de olyan szinten, hogy egy soft reset sem segít rajta (win alatt is döglött a rágcsáló utána), csak ha kikapcsolom a gépet teljesen, majd újra be. A winem sosem csinál ilyet, valamint Mandrake-kel is ment az egér gondok nélkül, nem harware-hibáról van szó.