Több wwebkamera mplayer alatt

Hali.

Van 4 db webkamerám.

egy db Micrós csoda. legyen A = 1600x1400
egy db Labtec nem annyira csoda legyen B = 640x480
két db A4tech szintén nem nagy durranás. legyen C és D 640 x 480

A kamerák képei elég különös variációk szerint érhetőek el egy időben.

A: mplayer tv:// -tv driver=v4l2:width=1600:height=1400:device=/dev/video0 -nosound
B: mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video1 -nosound
c:mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video2 -nosound
d:mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video2 -nosound

Ha A megy akkor max B elérhető.

A B megy C -vel.

A B megy D -vel.

C és a D nem megy együtt.
valamint

se A és C nem megy
se A és D nem megy.

külön külön minden ok.
Amikor azt mondom hogy nem megy az egy zöld képet jelent.

A gyökérok, hogy fogalmam sincs a tv kimenetről, se... :-) Valaki látott már hasonlót?

Lehet hogy USB oldalon van gond? Kellene plusz vezérlő? Vagy csak a tv:// kimenet lett tele, vagy nem fér hozzá. Mit lehet tenni?

Beiktattam már egy aktív usb hubot is, hátha táp, de nem segített...

$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:c52e Logitech, Inc.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 027: ID 0ac8:3450 Z-Star Microelectronics Corp.
Bus 001 Device 026: ID 045e:0772 Microsoft Corp.
Bus 001 Device 025: ID 0ac8:3450 Z-Star Microelectronics Corp.
Bus 001 Device 021: ID 046d:08a2 Logitech, Inc. Labtec Webcam Pro
Bus 001 Device 017: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Hozzászólások

c:mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video2 -nosound
d:mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video2 -nosound

C és a D nem megy együtt.

ez nem meglepő, ha mindkettőt a /dev/video2-n próbálod elérni egyszerre...