NVIDIA: "Support timeframes for Unix legacy GPU releases"

Címkék

Az NVIDIA bejelentette, hogy hogyan és meddig fogja támogatni a "legacy", vagyis régebbi GPU-it UNIX(-szerű) rendszerek alatt. Régebbi NVIDIA kártyákkal, alaplapi chipekkel rendelkezőknek mindenképpen érdemes elolvasni a bejelentést:

The Linux 390.* legacy driver series is the last to support GF1xx ("Fermi") GPUs.  Support for new Linux kernels and X servers, as well as fixes for critical bugs, will be included in 390.* legacy releases through the end of 2022.

The Linux 340.* legacy driver series is the last to support the G8x, G9x, and GT2xx GPUs, and motherboard chipsets based on them. Support for X.Org xserver version 1.20 was added to the 340.* legacy driver series with version 340.107, and support for Linux kernels up to Linux 5.4 was added with version 340.108. No further releases from the 340.* series are planned.

The Linux 304.* legacy driver series is the last to support the NV4x and G7x GPUs and motherboard chipsets based on them. Support for X.Org xserver version 1.19 was added to the 304.* legacy driver series with version 304.134, and support for Linux kernels up to Linux 4.13 was added with version 304.137. No further releases from the 304.* series are planned.

Support for X.Org xserver version 1.15 was added to the 173.14.* legacy driver series with version 173.14.39. No further releases from the 173.14.* series are planned.

Support for X.Org xserver version 1.12 was added to the 96.43.* legacy driver series with version 96.43.23. No further releases from the 96.43.* series are planned.

No further releases from the 71.86.* legacy driver series are planned.

For more information about the GPUs supported by each Legacy GPU driver series, please see: http://www.nvidia.com/object/IO_32667.html

NOTE: this list is specific to Unix drivers. For Windows information, click here: EOL Windows driver support for legacy products

Hozzászólások

Mennyire sérülhetne a piaci helyzetük, ha legalább ezek esetében megnyitnák a kódot a Nouveau számára?

Azt a nouveau -t sajnos a franc ette meg ott ahol van, legalábbis nálam sosem volt jó se egy GNOME desktop futtatására, se egy játékra. Pedig több GPU-val is teszteltem. :) Elindulni el bírt, de vagy hiányos volt az opengl támogatása, vagy simán k lassú volt, vagy időnként szétfagyott. Technológiai érdekességek múzeumában a helye.

(és ahogy a kollega irja, a driverben vélhetően 3rd party kódok is vannak, nem kizárólag házi fejlesztések).

The Linux 390.* legacy driver series is the last to support GF1xx ("Fermi") GPUs.  Support for new Linux kernels and X servers, as well as fixes for critical bugs, will be included in 390.* legacy releases through the end of 2022.

 

Eleg korrekt. Ha jol latom ezek ~10 eves GPU-k es meg lesz rajuk tamogatas par evig. (Es azutan sem allnak meg, csak uj driver nem jon mar ki.)

Érdekes gondolatmenetük van nekik.. A 304 drivert már alig támogatják a disztrók mindegyik azt mondja használj nouveaut vagy 340-es drivert. Namost a 340-esben meg nincs benne az a videokártya támogatás ami a 304-ben van. Nouveau meg egy kalap sz.r. Sz*rházi banda....

A Geforce 7 sorozat ~14 éves. Szerintem messze van az nvidia a szarháziságtól, hogy eddig supportálta. Legalábbis ebben a listában kerestem valamit amit nagyjából ismerek / használtam annak idején: https://www.nvidia.com/Download/driverResults.aspx/123709/en-us

szerk.: "and support for Linux kernels up to Linux 4.13"

Szóval ősi gpuhoz adott régi driverhez régi Linux jár, ilyen ez a világ.