A Mozilla elkezdte blokkolni a Flash-t a Firefox-ban

 ( trey | 2015. július 14., kedd - 14:17 )

A hétvégén a Facebook biztonsági igazgatója, Alex Stamos kifakadt és arról tweetelt, hogy itt az ideje annak, hogy az Adobe bejelentse a Flash életciklusának végét és arra kérje a böngészőgyártókat, hogy azok állítsák be a killbiteket az adott napra.

A Firefox support team vezetője komolyan vette a kérést. Olyannyira, hogy meg sem várta az Adobe-ot, már tegnap bejelentette, hogy a Flash összes verziója alapértelmezetten blokkolt a Firefox-ban tegnaptól.

9 órával ezelőtt tisztázta a helyzetet és közölte, hogy addig blokkolják a Flash-t, amíg az Adobe ki nem ad egy olyan verziót, amiben nincs olyan publikusan ismert sebezhetőség, amelyet aktívan kihasználnak.

Idézet:
To be clear, Flash is only blocked until Adobe releases a version which isn't being actively exploited by publicly known vulnerabilities.

Valaki morózusan megjegyezte, hogy "Szóval akkor örökre blokkolva marad".

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

jöhet a js is

:D Megallna az Internet!

Ha mar JS, en azt nem ertem, hogy ennyi ev alatt hogy nem jutottunk el odaig, hogy nincs a bongeszokben egy "akkor is uj tab lesz ezen a mereten, ha a js azt mondta hogy uj ablak mas merettel" feature. Nem popup blokkolokra gondolok itt, hanem arra, hogy JS abszolut ne tudjon uj browser window-t nyitni, atmeretezni meg plane ne tudjon, akkor se ha meg van hivva (es a usernek ez a "single window feature" be van kapcsolva).

Ez még issue? Nem is emlékszem, mikor nyílt meg felugró ablak előttem...

Valamikor par regi szar (akar intranetes) site-hoz muszaj popupokat engedelyezni (tudom, lehet oldalankent, de akkor is). Nincs is ezzel baj, csak nyilnanak meg uj tabon helyette, mar anno egy 12 evvel ezelotti IE6-ra epulo Maxthon buildben is meg lehetett ezt oldani, modern bongeszokben meg nem.

(Ja meg lehet be van kapcsolva az adblockod, mig en csak hosts file-ozok ;) )

FF-ban a 'browser.link.open_external' -t 3-ra állítva nem jó? Nekem ez pl. a Cib Java-s webbankját megoldotta.

Nekem seamonkeyban erre még guis beállítás is van, firefoxban about:configban egész biztosan állítható.

Ezeket eleg reg hasznaltam, Safariban es Chrome-ban menu szinten tuti nem allithato, about:configot nem neztem

Még képet is találtam, íme: http://postimg.org/image/u19ecrn23/

When scripts want to open a new window:
- Always divert windows into tabs

browser.link.open_newwindow.restriction = 0

about:config beállítás: browser.link.open_newwindow.restriction = 0

Nem értem ezt a nagy JS ellenességet. Kíváncsi lennék, hogy akik szidják, azok közül hányan vették a fáradtságot, hogy megismerjék a nyelvet. Ilyen szempontból minden nyelv szar. Mindamellett a JS-t is lehet ésszel használni.

Az JS erdekes, de szerintem nem annyira rossz, azota irtam (szamitogep) emulatort is benne pl. Mondjuk ezt a nagy "szar az JS" divathullamot altalaban onnan latom jonni, aki nincs kibekulve azzal, hogy OOP kornyeken olyan is van, hogy prototype alapu nyelv. Amugy meg az JS egy leanyalom a PHP-hez kepest, na annal ganyabb nyelv nincs. Komolyan olyan, mintha random dobaltak volna ossze meg az alapelveit is. Ezt reszben az eredeti alkotoja is beismeri - ha jol emlekszem -, tehat annyira nem meglepo :)

Ilyen kijelentést is általában olyan ember tesz, aki még egy deka kódot sem írt PHP-ben. Javaslom, hogy egyszer nézz meg egy komolyabb PHP framework-köt (ne adj Úristen dolgozz is benne, tanuld meg) és utána ítélkezz.

Minden nyelven lehet spagettikódot írni.

-------
It is our choices that define us.

Valóban minden nyelven lehet spagetti/sz@r kódot írni, de ami by design olyan, hogy erre ösztönöz...

Eleg sok kodot irtam PHP-ben, ezert is mondom :) Ui mindig meglep, hogy mik vannak ... Azt ne mondja nekem senki, hogy normalis, hogy ez utan:

var_dump("12"=="0xc");

azt mondja, hogy true :) Ertem en, hogy a 0xC (hex) szamkent ertelmezve 12. De konyorgom, stringek vannak megadva, azonos tipus, minek konvertalni barmire? Ok, akkor johet a === operator, ez igaz. Viszont hany PHP developer tudja ezt pl? Ez akar security hole is lehet, ha jobban belegondolunk.

Szoval a PHP az brain dead by design, es mint irtam, maga az alkotoja is vmi olyat irt, hogy a PHP olyanoknak keszult, aki nem feltetlen ert annyira a programozashoz, ezert probalkozik meg a PHP "magatol" ilyen remes trukkokkel, hogy megnezni az osszehasonlitast pl numberikuskent ertelmezve is, akkor is, ha amugy ket string van osszehasonlitva (gondolom ennek celja az, hogy az "egyszeru programozo" nem akar ilyenekkel foglalkozni, es pl POST/GET stb dolgok stringben vannak lerakva).

Aztan pl itt van az orulet, hogy a fuggveny mint entitas az log a levegoben valahol. Probald meg pl ezt:

var_dump(array_map(strtoupper, array("ez","az")));

esetleg ["ez", "az"] ujabb PHP-kben mar. Az eredmeny bar normalisnak tunik elsore (de nem az), amde a PHP azonnal csokoltat is:

PHP Notice: Use of undefined constant strtoupper - assumed 'strtoupper' in Command line code

Mert ugye azt kellett volna irni, hogy "strtoupper". Marmint idezojelekkel. Szoval siman (nem string-kent), nem lehet fuggvenyre valojaban hivatkozni univerzalisan, max annak meghivasakor pl (azt hiszem erre mondjak hogy a nyelvben a fuggveny nem "first class" elem vagy vmi hasonlo). Ez kulonosen akkor lesz vicces, ha mondjuk egy vmi OOP stuff bejon pl:

class Akarmi {
function my_error_handler($errno , $errstr, $errfile, $errline, $errcontext) {
... valami ...
}
function __construct() {
set_error_handler(IDE MIT IRJUNK?);
}
}

Namost, itt elsore sem vilagos, hogy akkor mi a fenet kell az "IDE MIT IRJUNK?" helyere irni, hogy az Akarmi class adott peldanyaban levo my_error_handler-t hivja. Amugy pl ezt lehet irni:

set_error_handler([$this, "my_error_handler"]);

Namost ez normalis? :) Szoval egy tombkent kell neki atadni (ahol a metodus neve tovabbra is string ...), mashol meg sima fuggveny az string, de tomb nem kell persze, stb ... Jezusom.

Megy ez viccesebb iranyba is, amikor bejonnek az exception-ok, es ott milyen magiak vannak, kepernyooldanyi kodok, ami normalisabb nyelvekben egy sor.

Nem vitatom, PHP-ben is lehet normalis dolgot alkotni, de az embernek az az erzese, hogy a nyelv szandekosan megneheziti ezt (gondolom ez azert van, mert az egyeszeri alig programozni tudokat meg segiteni akarja, ahogy a PHP alkotoja is nyilatkozott). Arrol nem is beszelve, ha php.net -en nez az ember barmi kicsit "modernebb" feature-t, kb oldalakon at megy a "igy lehet", de egy verzio utan mar igy, ja aztan meg igy is fog menni, de vigyazat mert ... Kozben az is zavaros, hogy mi az ami errort ad visza visszateresi ertekkent, es melyik ertek jelenti azt, mi az ami vmi php warning/notice whatever-t general, mi az ami exception-t, es miert olyan zavaros az egesz (en megprobalom inkabb error handler-ekkel egysegesiteni hogy minden exception legyen, akkor pl backtrace eloallitasaval sem kell feltetlen annyit "szenvedni").

En nem vitatom, lehet, hogy nem ertek a PHP-hez annyira, mint masok itt a hup-on, de szerintem azert az sem igaz, hogy teljesen hulye vagyok hozza. Ellenben a "szar az JS" azt olyan divatnak erzem inkabb. Nyilvan, lathatom rosszul is, nem is allitottam, hogy feltetlen csak nekem lehet igazam.

Azt viszont nem ismerem el, hogy "keress egy framework-ot" a megoldas. Pont arrol van szo, hogy a nyelv alapjai szarok, az meg framework nelkul latszik igazan. A framework meg felesleges kod sokszor, mert emberek lustak, az egyszeru dolgokra is framework a megoldas, sokszor a framework akar nagysagrend(ek)kel nagyobb mint maga a megoldando feladat. Mivel az eredeti hozzaszolas JS volt, legyen itt JS-es pelda: ott is gaz, hogy egyesek mindenre JQuery-t hasznalnak. Akkor is "behuzzak" ha egy szem helyen hasznaljak arra, amit "nativ" JS-ben is egy sor lenne, es neznek ertetlenul, ha valaki nem JQuery-s peldat ad, hogy neki az igy nem megy. Ez kisse szanalmas szerintem. Persze, nyilvan van az a szint, ahol mar erdemes framework-re epiteni, sot rosszul is jar az ember, ha nem igy teszi esetleg.

Az viszont PHP-nel erdekes (tobb embertol is hallom), hogy a vedekezes az "keress normalis framework-ot". Nem ez volt a kerdes, hanem hogy a PHP nyelv alapjaival van a gond, kit erdekel akkor a framework? Legalabbis szerintem ...

Szép hosszú hozzászólás lett, szóval előre is sry, de ennyire nem akarok belemenni, viszont reagálok pár dologra. Nem tartom magam programozó gurunak, (még :P) de azért én is konyítok pár nyelvhez kicsit. Igazából sok nyelvvel foglalkoztam már életemben, és általában minddel csak annyira, amennyire feltétlenül szükséges a munkám elvégzéséhez. PHP-vel és Js-sel foglalkoztam eddig a legtöbbet. Ezen kívül dolgoztam már nagyon sokat C# és Java rendszerekben.

Természetesen mindezek során, ahogy tanulom egy nyelv használatát, igyekszem minden olyan nyelvi hiba okát is megérteni, amibe belebotlok. Ennek ellenére pl. amit a legelején említettél, azzal még sosem találkoztam, mármint --> var_dump("12"=="0xc"); ==> true Erre csak azt tudom mondani, hogy aki nem ismeri a nyelvi operátorokat, (== és === közötti különbség) az nem (PHP) developer. És tökéletesen egyetértek abban, hogy ez (többek között) egy security hole. A PHP olyan "faszán" van toldozva-foltozva, hogy már sikerült ~6000 oldalnyi ismert bugot összegyűjteni a nyelvvel kapcsolatban. Ezek csak az ismertek és aki mindet ismeri az előtt emelem a nem létező kalapom. Viszont azt is érdemes megnézni ilyenkor, hogy ezekkel a bugokkal hányszor találkozol a gyakorlatban.

Azért említettem a framework-köket, mert ha PHP-vel komolyan akarsz foglalkozni, akkor érdemesebb ezekben a rendszerekben dolgozni, mert rövid idő alatt nagyon király alkalmazásokat lehet bennük összehozni, gyorsan lehet tesztelni és nagyon jól áttekinthetőek. Ezen kívül a jól megírt framework-kökben lekezelik ezeket a nyelvi hibákat és ösztönöznek az elkerülésére. Valószínűleg ez ugyanígy van minden nyelvben. Ja... hogy elölről akarsz PHP-ben írni valami nagyobb rendszert és mondjuk fontos a biztonság is? Sok sikert... :)

A PHP script nyelv, ahogy a JS is, eredetileg nem arra lett tervezve, hogy több ezer (millió?) soros rendszereket írjanak benne. A scriptekről egyszer valahol olvastam egy nagyszerű idézetet, ami valahogy így szólt: "A könnyű dolgokat legyen könnyű megcsinálni, viszont a nehéz dolgokat is meg lehessen csinálni." Pontosan ezen az elven használom ezeket a nyelveket és arra amire kell/lehet. Ágyúval nyilván nem lövünk verébre, ha akarok csinálni egy sima weblapot, amin van egy üzenetküldő form, akkor nem fogok Java-val töketlenkedni, hanem megírom PHP-ben. Amennyiben banki rendszert tervez az ember, akkor már nagyon nem biztos, hogy a PHP lesz a jó választás. Úgy gondolom, hogy egy igazán jó programozó el tudja dönteni, hogy a különböző nyelveknek mik a határai, még ha nem is tud mindben kódolni.

Bugokat pedig az összes nyelven lehetne sorolni a végtelenségig, verziószámra visszamenőleg... milyenmá' hogy a pythonban minden major verzió után kb. tanulhatod újra a nyelvet... ;)

És ha már scriptnyelvek, akkor egy kis fun.

-------
It is our choices that define us.

Nem mondom, hogy nincs igazad. En pl JS-ben server oldali cuccokat (lasd node.js) miegymas valahogy nem irnek :) Ott egesz fura dolgokat sikerult osszehozni (bar oszinten, ahhoz nem igazan ertek pl). Szoval a mindenre a megfelelo eszkoz temaval egyet ertek. En pont azon szoktam szornyulkodni, hogy mivel a PHP "egyszeru" (szoval az elso hello world pl) ezert sok olyan ember dolgozik PHP-ben akinek fogalma sincs a dolgokrol, es pl ereg()-el keres (most az mas dolog hogy azota deprecated is ez mar ...) substring-et stringben. Esetleg egy szem karaktert is. Aztan meglepodik, ha "." keresese fura dolgokat okoz :) Nyilvan, az nem feltetlen a nyelv hibaja, hogy kik hasznaljak, ez is igaz valahol. De az is, hogy a PHP meg PHP/FI-bol orokolt alapjai az "egyszeri, kezdo programozo" szamara keszult, es ezt probaljak csurni/csavarni, ami igen fura helyzetet kepes okozni.

Azt viszont tovabbra is fenntartom, hogy a PHP alapjaiban hibasan van tervezve (ezert irtam, hogy "gany"). Vagy legalabbis, annak fejlodesekor szakitani kellett volna az alapokkal es tiszta lappal kezdeni, mert a jelenlegi allapota az elegge minosithetetlen (OK ertem en, hogy kompatibilitast total sutba vagni az kb uj nyelv, de minnel tovabb varnak, annal jobban fog fajni!). Tiszta "veletlenszeru" otletek osszevagva, hasonlo dolgok total mas szintaxissal es viselkedessel, mas nyelvekbol "tetszo" otletek atvetele teljesen lehetetlen modon, es komoly mellekhatasokkal, ha azokat keverni akarnad (mivel PHP-ban van, elvarhato lenne hogy ezek egyuttmukodjenek). Jelenleg PHP OOP-style, keverve namespace-ekkel, exception-okkel, miegymas az mar komoly elmebajrol tesz tanubizonysagot, raadasul - mint irtam - doksik is tele vannak neha 5-6 megoldassal is, egesz kozeli PHP verziokat emlegetve, hogy ebben igy, abban ugy, amabban meg amugy. Ha mar igy valtoztatgatnak, nem lenne egyszerubb alapjaiban megreformalni az egeszet?

Az talan kitunt, hogy nem ugy biralom a PHP-t, hogy semmit nem ertek hozza azert, framework-oket is "lattam mar". Profinak azert nem vallom magam PHP es hasonlo temakban, de kezdonek sem. Es igen, neha en is hasznalom, ahogy irod is, csak nem feltetlen mindenre. Ettol meg van rola a velemenyem persze. Na mind1, ami fura, hogy tulajdonkeppen a fenti valaszodban semmi 'vitatni valot' nem talaltam igazan.

Ha mar Python (amit szinten hasznalgatok azert), ott a fobb elteresek azert tenyleg major verzioszamnal vannak. PHP-nal szinte mindig. Illetve, mint irtam, szerintem komolyan raferne PHP-re, ha az egeszet kb ujra kene tanulni, de vegre kicsit gatyaba raznak :)

Tény, hogy ráférne egy alapos gatyába rázás a nyelvre és az is igaz, hogy valszeg akkor már új nyelvről is lenne szó. Amit most csinálnak a PHP-vel és a Js-sel is, az a szénné bonyolítás... csinálnak benne új dolgokat, de az ezeréves cuccokat nem takarítják ki, hanem csak rányomják a deprecated "pecsétet". Ezért lehet mindent 131072 féleképpen megoldani (és azzal a lendülettel elcseszni) bennük.

Az "egyszeri programozóknak" meg egytől egyig azt tenném kötelezővé, (mint egy jogsit) hogy mindenek előtt programozzanak már C++ || Java || C#-ban és ismerjék a modern módszertanokat legalább, mielőtt nekiállnak scriptelni.

-------
It is our choices that define us.

Ok-ok, akkor kb egyet is ertunk mar mindenben :)

A PHP nem lett tervezve....

"designed for web development" :P

Minden nyelvnek vannak hibái, viszont nem mindegy, hogy ennek ellenére mennyire tud az intuitív maradni. Ha folyamatosan azon kell agyalni, hogy az adott utasítást hogyan kell úgy leírni az adott nyelvben, hogy az ne okozzon valamilyen problémát a futtatókörnyezet miatt, az nagyon hamar lefárasztja az embert. Csak hogy egy vicces példát említsek: http://phpsadness.com/sad/52

A framework számomra egy olyan library halmaz, ami egy adott nagy részproblémára nyújt egységes és magas szintű megoldást (mint pl. entity framework, spring framework). Php-ban (és js-ben) viszont a frameworkök sokszor semmi mást nem csinálnak, mint elrejtik a nyelv hibáit, hiányosságait, miközben semmilyen "üzleti" problémát nem akarnak megoldani. Én csak azt nem értem, hogy miért jó választani egy rossz nyelvet, majd egy frameworkkel elrejteni annak hibáit, hiányosságait, mint választani egy jobb nyelvet az adott feladatra.

Engem ez az ami megremisztett:

"Once you start having separate operators for each type you start making the language much more complex. ie. you can’t use ‘==’ for stings, you now would use ‘eq’. I don’t see the point, especially for something like PHP where most of the scripts will be rather simple and in most cases written by non-programmers who want a language with a basic logical syntax that doesn’t have too high a learning curve."

PHP 2 doksibol. Szoval a PHP "nem-programozoknak" irodott, olyanoknak akik nem kepesek megerteni komplexebb dolgokat, ami a legtobb mas programozasi nyelvvel egyutt jar. Ez azert sok mindent megmagyaraz, hogy miert ilyen amilyen. Azota persze sokat fejlodott, csak ami engem zavar az az, hogy a dolgok meg mindig arra az elkepzelesre epulnek PHP-ben aminek a fenti kijelentes masodik resze az alapja. Es szerintem ez tartja a nyelvet is vissza, ezzel kene szakitani, megreformalni, es normalis programozasi nyelvkent ujrairni. Legalabb kihullana a sok "nem programozo", az minek akar PHP-ben kodolni :)

JS-ben szerintem kisse mas a szitu, en ott nem latok "ennyire" durva hibakat, ott a legtobb framework szerintem (de ez eleg szubjektiv) inkabb a kenyelemre megy ra. Mar amennyire egyszeru egy JS es egy PHP framework celjat egyaltalan osszehasonlitani (es ismet JS alatt en a browser-ben futo JS-t ertem, a node.js bohockodasok nem erdekelnek ... ahelyett van normalisabb eszkoz is szerintem, ami nem JS).

Rég nem állok le hitről vitázni, helyette inkább ezt a régi írást linkelem. Aki szerint ezek normális dolgok, annak lelke rajta, használja azt a magával is inkonzisztens platformot.

-
Konténerezett Hadoop és Cassandra cluster konfigurálása - harmadik rész

+1

Ez nem hit kérdése. Szerintem aki komoly PHP fejlesztő már találkozott ezzel a leírással, és nem álltatja magát azzal, hogy a nyelv amit használ tökéletes. DE cserébe ez azt sem jelenti, hogy aki PHP-re fejleszt, az hülye, és ami PHP-ben készül az eredendően szar. Csak mert divat fikázni, és mert a nyelv nem teszi nehézzé hogy szar kód készüljön benne még nem kellene egy egész community-t elásni a nyelvvel együtt, és hitkérdést csinálni az egészből.

Tény hogy a php inkonzisztens, és ráférne egy ráncfelvarrás. De ezt ugye elmondhatjuk más nyelvekre is... Ott a python, ami folyton változik, ott a JS, amiről szerintem sokkal átfogóbb leírásokat találni mint a fractal of bad designs. Ott a java, amit vagy isteníteni, vagy a pokolra kívánni lehet az egész jvm-mel, stb...

"a nyelv amit használ tökéletes" az egy dolog, hogy nem tökéletes, mert a többi sem az, az meg egy másik dolog, hogy alapjaiban elcseszett, ne keverd össze a kettőt plz. Fából vaskarika, ami az utóbbi 10 évben a php körül történik, és sok újjítás csak fokozza káoszt.

"azt sem jelenti, hogy aki PHP-re fejleszt, az hülye" azt nem jelenti, de mégis a sok hülye php-ra fejleszt. Kérdeztél már meg random php fejlesztőt hogyan működik pontosan a GC? Vagy hogyan alakítja át a típusokat, és hogyan tárolja a memóriában?

"Csak mert divat fikázni" nem divatból teszem, hanem sok éves fejlesztői és üzemeltetői tapasztalatból.

"nem kellene egy egész community-t elásni a nyelvvel együtt" nem ástam én el senkit sem, megvan a php-nak helye, csak sajnos az estek többségében nem arra használják, amire való, és megy a gányolás. Érdemes csak megnézni a divatos Laravel keretrendszer ORM rétegét. Hát egy vicc.

"Tény hogy a php inkonzisztens" Az a helyzet, hogy bizonyos fejlesztési méret fölött, és karbantartási idő után minden dinamikusan és gyengén típusos nyelvet alkalmatlannak tartok munkára, és a php meg csak rátesz egy pár lapáttal (a linkelt oldalon található problémákkal).

-
Konténerezett Hadoop és Cassandra cluster konfigurálása - harmadik rész

a facebook valahogy nem érte el ezt a szintet

+1 gyakorlatilag, amit lehetett már kicseréltek sajátra, meg van fejlesztőkörnyezetük, meg ilyenek, ráadásul számtalan backend funkcionalitás nem is phpban van írva as i know. Tény, hogy van az a cég/projekt méret, ahol van pénz ilyen eszközöket fejleszteni, de ez megintcsak nem az átlag. A Google is használ mysql-t (szintén "utálatom" tárgya, nem követi az sql szabványt, ignorálja a default not null mezőket, nehéz jól horizontálisan skálázni, nem képes értelmesen particionálni táblákat, stb), de annak sem sok köze van ahhoz, amit mi le tudunk töltikézni a mysqldotcomról.

-
Konténerezett Hadoop és Cassandra cluster konfigurálása - harmadik rész

Gyorsan átfutva nem látom, amire gondolsz.
(a békesség kedvéért: arra reagáltam hogy a gyengén és dinamikusan tipusos nyelvek nem megfelelők egy bizonyos komplexitás felett. És hogy a PHP minden nyelvi nyűgje [eev.ee] erre rátesz egy lapáttal. Ahol programméret != általa kezelt adatbázis mérete vagy az alátolt gépek száma, és alkalmatlanság == lassú fejlesztési idő != lassú futás)

"a facebook valahogy nem érte el ezt a szintet" a FB egy másik szint, szóval nem nem érte el, hanem túlment rajta. De ha olyan nagyon jónak tartanák a php-t biztos nem öltek volna több ezer mérnökórát a különböző cuccaik lefejlesztésére. Írtak egy saját [url=https://en.wikipedia.org/wiki/Hack_(programming_language)]programozási nyelvet[/url]! Ami mondjuk amellett, hogy "A majority of the valid PHP scripts is also valid in Hack;" még "Hack allows programmers to use both dynamic typing and static typing.". Ezen felül használnak C++, Java, Python, Erlang, D, Xhp nyelveket. 1 szó mint száz engem ez nem győzött meg arról, hogy a stock php nekem érdemes használni. De mint írtam megvan a helye, és ha nem egy monolitikus alkalmazásba gondolkozunk elképzelhető olyan feladat/service amire tökéletes, pl a html renderelés, amire kitalálták (amennyiben a html generálást nem a kliens böngésző végzi). De üzletileg kritikus részeket biztos nem abba implementálnám.

-
Konténerezett Hadoop és Cassandra cluster konfigurálása - harmadik rész

+1

-------
It is our choices that define us.

Meggyozodesem, hogy a legkarbantarthatatlanabb es legolvashatatlanabb regexp mentes kodokat JS-ben szoktak irni. (Azert irtam regexp-mentest, hogy a megolvashatatlanabb Perl ne legyen versenyzo ;) ). A PHP rosszabbul tervezett nyelv, de eggyel hasznalhatobb kodokat szoktak benne irni meg a Pistikek is, azzal legalabb lehet mit kezdeni, nem ugy, amikor iosszevissza vannak a listenerek meg az async fuggvenyek, es azt se tudod mit hol kezdj el debuggolni, meg mi mit hivhat meg (es akkor eval meg szoba se kerult).

Foleg mikor a grunt/gulp elotti idokbol midnenki raszokott a "minel kevesebb forrasfajl" dologra, ergo minden ment egybe hogy "minel kevesebb request legyen". Elvi lehetoseg akkor is volt mar okosan megoldani, de a gyakorlat egeszen mast mutatott nekem.

+1

Kedves tőlük!
A kollégák meg ész-veszetten hívnak, hogy nem tudják feltölteni az ilyen olyan adatszolgáltatást.
De az sem komplett aki ilyen web-oldalakon Flasht vagy Javat használ! Az utóbbival minden frissítés után van valami gond. Túl új, megváltoztak a jogosultságok, stb.
--
Tertilla; Tisztelem a botladozó embert és nem rokonszenvezem a tökéletessel! Hagyd már abba!; DropBox

pl ügyfélkapu... :)

Én egy lépéssel előttük jártam:
Firefoxra nem is telepítek flash plugint.

+1
Én már egy évvel megelőztem a Mozillát :-)

Ezzel egyidőben az Adobe újabb Flash verziót adott ki, ennek telepítése nálam feloldotta/feloldhatóvá tette a blokkolást. http://news.softpedia.com/news/adobe-updates-flash-to-18-0-0-209-after-mozilla-blocks-all-versions-in-firefox-486813.shtml

IMHO én is baromira örülnék már ha kompletten elfelejthetnénk az egész Flash - Silverlight - JRE sz...háromságot a francba... (java-developerek most ne figyeljenek ide)

Egyébként ha már itt tartunk nem létezik valami noninvazív eljárás korábbi flash pluginok eltávolítására? Innen üdvözlöm az Adobe-fejlesztők édes anyukáját, legközelebb mondja meg a pici fiának, hogy ha már frissíti a pluginjét, törölje már le magának a korábbi verziót...
PS.: Igen pl. ezt ismerem, de ez nálam már invazív eljárás...

Hát a java appleteket már a 20. század végén el kellett volna felejteni.

Java fejlesztőként abszolute egyetértek, nincs semmi szükség ezekre....

Az Iceweasel is blokkolja.

Ész nélkül lehet csak igazán nagy hülyeséget csinálni... Ez most olyan, ha tetszik, ha nem...

+1, ott is nagy lehet a fejetlenseg...

--
"Nem akkor van baj amikor nincs baj, hanem amikor van!"
Népi bölcsesség

Emlékeim szerint a vmware webes szutyka is igényli a flash-t (is)...

A baj akkor van, mikor szorgalommal párpsul ;)

-
Konténerezett Hadoop és Cassandra cluster konfigurálása - harmadik rész

5 éve is megtehették volna

--
arch,debian,openelec,android

A Facebook pedig a saját életciklusa végét jelenti be?

:)

Bárcsak

Nem kötelező használni :-P

Vannak itt, akik használják?

Sz*patják az embereket. A nagy részük magasról tojik az egészre, és csak annyit szűrnek le az egészből, hogy a Firefox ismét rosszabb lett. 5% minusz megint.
--
honlapom http://dyra.eu/

Nem tudom. Nekem edesanyam emlitette, hogy milyen jo, hogy ujabban nem villog minden vacak minden weboldalon es engedni kell, ha meg akar nezni valamit. Kozben a gep ventije is sokkal halkabb :) Azaz: kevesebb energiafogyasztas, halkabb gep, szemkimelobb oldalak, ha meg kell, bekapcsolhato. Jol van ez igy. Amig JS-ben nem kezik el majd ugyanezt persze, pl canvas alapokon. Szoval sokaig nem tart az orom :)

Az Adblock+ csodákra képes :-P

Hmmm... Élvezet mikor az Adblock/Adblock Plus miatt a Firefox memóriaigénye dupla annyi, mint anélkül. Én már hosszú ideje nem is használom emiatt.

Vagy hosts-ból tiltok mindent vagy ha mindenáron teljeskörű megoldás kell, akkor uBlock.

De ha az sem jön be, akkor az uBlock tuti megoldás lehet. :D

-------
It is our choices that define us.

Öööö... nem értem, én nem ezt írtam?

Szerk.: Ja jó, értem. Figyelmetlen voltam :-)

Nekem személyes tapasztalatom van, mivel nap mint nap Firefoxot használok. A reklámokat blokkolom semmiféle villogást nem látok sehol. Viszont (szinte) minden egyes oldalánál megjelenik az értesítő sáv és ahol engedélyezem és meg is jegyeztettem egy újabb oldal látogatásnál 3x - 4x is összeomlanak egymás után a megosztott Flash tartalmak. Míg ezt nem hozta a Firefox addig problémám hasonló nem volt, így össze kötöm a két eseményt. Lehet valamelyik bővítmény okozza (adblock, ghostery) de én azokról le nem mondok inkább böngészőt váltok.

--
honlapom http://dyra.eu/

Szemelyes tapasztalatom van nekem is, de probaltam "atlagabb" user velemenyet leirni, ezert irtam le azt, amit edesanyam mondott. Szerintem o jol kepviseli ugyanis "a hozza tulsagosan nem erto, csak netezgetek neha" kategoriat.

Az, ugye, megvan, hogy az embed videokhoz desktop bongeszovel FB-on flash kell?

Desktopon nincs html5 videolejatszas. Egyaltalan. Legalabbis 1 honapja meg tuti nem volt, probaltam atverni FB-t, hogy ez nem FF hanem egy tablet, de 1 ora szivas utan - mivel hasznalhatatlan volt a tabletre optimalizalt felulet - feladtam.

szerk:
kép

Most, hogy ugyan abban a hacking team csomagban találtak a két flash mellett egy java zero dayt is, ugye blokkolni fogják a javat is?

+1

-------
It is our choices that define us.

a freshplayerplugin-ra nem gondoltak, az működik :)

Es a flashplayerplugin?

--
"Nem akkor van baj amikor nincs baj, hanem amikor van!"
Népi bölcsesség

Az működik. :-)

TLDR
szoval en csak annyit kerdeznek, h. mi aktivalta 2015.07.14-en ezt a fajta visrlkedest, mert en ugyan tegnap nem tettem fel uj ffox release-t, sem uj flash player plugint. Van a ffox-nak vmi online plugin csekkolo modulja, ami naponta megnezi az altalam telepitett pluginek kozul melyik lett az ejszaka folyaman veszelyeztetett, es automatice letiltja azokat? Azt ismerem amikor en nezem meg kezzel a listat a pluginkezeloben, de ilyen automatizmust eddig nem vettem eszre.
--
WP8.x kritika: http://goo.gl/udShvC

Tipp:

ls -la blocklist.xml
-rw------- 1 trey trey 169903 júl 15 08:15 blocklist.xml

less blocklist.xml
<?xml version="1.0"?>
<blocklist xmlns="http://www.mozilla.org/2006/addons-blocklist" lastupdate="1436891602000">
[...]

Idézet:
Update model

  • Download a blocklist file on a timer (86400 default)
  • If items are newly blocklisted or unblocklisted, adjust the datasource appropriately and prompt to restart.
  • The blocklist file will be placed in the profile-dir.
  • Blocklist is _replaced_ on each update, not merged or otherwise combined.

https://wiki.mozilla.org/Extension_Blocklisting:Code_Design

--
trey @ gépház

Hát kössz :)
--
WP8.x kritika: http://goo.gl/udShvC

Arra gondolok, - és sajnos, soha nem ez a megközelítés.., - ha valamilyen tartalom van egyáltalán fenn a neten, akkor azt, ha éppen arra van szükségem, - persze mindenképpen "öngyilkosság nélkül", azaz biztonságosan, - de ELÉRHETŐ(!) legyen. Az sem érdekel, ha a megoldás csak esszenciális, de legyen megoldás rá. A letiltás, nem megoldás!

A böngésző pedig arra lenne való, hogy adott esetben ne égessem meg a kezem, akkor sem, ha a "vas forró" ami után éppen "nyúkálok". (Valaki egyszer hivatkozott egy "munkavédelmi kesztyű" hasonlattal..)

Ha általában tartalmat kell blokkolni, - nem pedig megjeleníteni, - akkor az számomra annak beismerése, hogy nem elég jó az az eszköz, amivel megjeleníteni próbálunk. - (Tudom, ez így felhasználói szempontú leegyszerűsítés.., de ha egy flash, mondjuk rosszindulatú kóddal fertőzött, akkor konkrétan arról kéne informálni a felhasználót, ha éppen "exploit" jön rajta keresztül a gépre, akkor arról, persze ilyenkor az értesítés után blokkolhatná, - na nem a videó lejátszását, de a "fertőző" kódot feltétlenül... :-)

Van aki lassan, biztonságosan, és óvatosan autózik és van aki szeret "veszélyesen élni". Ez utóbbiak miatt építenek légzsákokat az autókba, de ez egyik "féle" felhasználót sem korlátozza az autózás "élményét" illetően. Motor esetén meg a bukósisak jelentősen korlátoz, de a forgalomban így résztvevők számára, még elfogadható kompromisszum.

A böngésző akkor legyen víruskereső is, vagy ezt most hogy?

Jelenleg is használ a adathalász-WEB-lapokról, IP-kről adatbázisokat... Sztem, az exploit-ok ellen is fel kellene szerelni hasonlóval. (Tehát ami a biztonságos tartalom-megjelenítéshez szükséges módszer, használnia kéne, - úgy gondolom... - Lehetséges böngésző-fejlesztési irány. - Plug-in-ek szintjén, már így is jelen van ez a fajta biztosítás. Kezdetnek integrálni kéne a már meglévőket. Ráadásul, így a fejlesztőknek pénzt hozó, "fehérlistás" reklám-megjelenítéseket is kézben lehetne tartani.

Annál is inkább mert a külső víruskeresők, - amennyiben a böngészés ellenőrzését is bekapcsolva tartjuk, - nagymértékben rontják az un. "felhasználói élményt", ezért azután ez a menüpont, a gyorsítás érdekében legtöbbször kikapcsolva is marad. ("Majd, ha kijön a böngésző alól" akkor megfogja "című".., nem túl "bizti" és szakszerű gondolkodásmód.)

Ha a böngésző-cache "sandbox"-ban fut, van is ennek létjogosultsága.

Ez szép és jó,de Windows-on firefox alatt mit lehet használni helyette?
Linux alatt ott freshplayerplugin csomag,ami szépen működik.

Nem értem. Windowson is lehet engedélyezni a saját felelősségedre. Linux alatt is tök mindegy, hogy a freshplayerplugin-nel használod, az csak egy PPAPI-host NPAPI-plugin adapter, ha sebezhető a legfrissebb Flash verzió is, azzal is az lesz.

--
trey @ gépház

Nem vagyok Windows-on otthon a témában :)
Linux alatt simán sikerült is, amit írtál.

Igazából idegesít a sok felugró sáv, hogy akarom-e használni annak ellenére,hogy nem biztonságos. Így Linux alatt megoldva a probléma. A Winest, majd tesztelem.

A Firefox eddig is tiltotta a Flasht, még frissítés után is.
A megoldás ez a link. Tán a hupon olvastam? ;) Csak fel kell rakni a Windows->Plugin based browsers csomagot és megy. Érdekes, hogy ez mindig frissebb, mint a legújabb frissítés. :)

A támogatott oldalakon pl. youtube a Flash megléte elegendő, ha helyette a greasemonkey+ViewTube+VLC játszik.
Ha meg it tartunk, akkor a java évek óta nincs fenn.

Olyan negatívak vagytok! Az Adobe hosszú évek alatt, folyamatosan az árral szemben úszva is megoldotta, hogy egyszerűen és kényelmesen lehessen távolról vezérelni a célgépeket. Mit nekünk TeamViewer, ha van Flash?
Ez a support leányálom:
Ügyf: - Nem megy az xy alkalmazás.
Supp: - Kérjük látogassa meg a ... oldalt, a többit megoldjuk mi!

:)

Nem oldotta meg, hogy egyszerűen, kényelmesen és biztonságosan lehessen távolról gépeket irányítani.

Szerintem nem értetted meg, amit mondott.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Ez mind szép és jó, a chrome mikor kirakta a Java-t akkor remekül lehetett áttérni IE-re speciális esetekben. Pl IBM Tivoli* tools, HP ILO, stb.

Most hogy a flash kikerült "by-default" a firefoxból, lassan lehet tényleg át kellene térni egy IE használatra :)

Igaz, igaz, konzerváljuk a nem szabványos, biztonsági kockázatot jelentő technológiákat. HTML5 esetleg?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Feel free: tessen szólni a HP-nak meg az Oracle-nek, meg a Dell-nek, IBM-nek... meg úgy minden gyártónak, hogy adjanak ki Flash és Java-mentes firmware-eket a cuccaikhoz :-P

Valahol el kell kezdeni. A Mozilla elkezdte. Webfejlesztők körében is jó volna, ha terjedne a flashtelenség.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Öntökönbökéssel is el lehet kezdeni, ez igaz, de nem biztos, hogy jó ötlet :-P

Ez csak a default. Lehet engedélyezni, ha valakinek nagyon kell.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Még lehet engedélyezni - a default tiltás önmagában öntökönbökés, hiszen akinek nem fog menni valami, az nem azt keresi meg, hogy miért nem megy, és hogyan fog menni, hanem "sz@rafirefox" felkiáltással veszi a következő keze ügyébe kerülő böngészőt.

Végül is minek is elolvasni, hogy engedélyezés most, meg efféle hülyeségek. A betűk csak öncélúan, dekorációnak vannak a képernyőn, nem azért, hogy bárki is elolvassa, értelmezze őket. Vagy mégsem így van?

Amúgy, ha senki sem gyakorol nyomást a webfejlesztők felhígult társadalmára, úgy még akkor is lesz flash plugin, amikor én már felnőtt pelenkát fogok hordani.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

A felhasználó nem fogja elolvasni (a./ verzió) vagy bekattintja, hogy mindent mindenhol (b./ verzió). Ha meg soknak tartja a FF részéről a bacogatást, akkor jön az ultimate verzióként a "sz@rafirefox" és más böngészőre vált.

Amennyiben tényleg ez a realitás, társadalmunk valóban pusztulni érett. :(


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Aki látott már közelről "júzert", az ezt nagyon jól tudja...

btw itt nem csak az "átlag" felhasználóról van szó. Hanem akár rendszeradminokról is. Akik bizony dolgoznak olyan dolgokkal amik java applettel mennek, vagy épp flash* -ot használnak. Ők tudják engedélyezni ezt nyilván (amíg lehetőség van erre, a chromeba mikor is szűnik meg az npapi támogatás fullra?) , nem is erről szól a történet.

Csak hogy ne kelljen már fenntartani 3 browsert azért, mert bizonyos emberkék kitalálták hogy "hát ez secholebugged* ,stb" tilccccsük le (két csvel ...) .

És mondjuk ez nem csak java / flash esetében jöhet elő. Esetleg aki dolgozott már Konica Minolta nyomtatókkal. ;) Ott előszeretettel csak és kizárólag firefoxal jön be egyáltalán az admin menü.

Tény, ez nem a browsert minősíti, de ennek ellenére ezzel perpill nem lehet mit tenni.

Az ezer éves storage/remote console/stb sw-ket a gyártók sem fogják frissíteni.

Hasonló példa hogy a céges SAP rendszer csak IE alatt működött, de az is csak a régi alatt...

Apró, de kevéssé ismert info: IE-ben be lehet állítani, hogy egy adott bővítmény mely site-okon működhessen.
Így a feltétlen szükséges, de megbízhatónak gondolt (pl. belső) oldalak whitelist-jével jelentősen csökkenthetők az esetleges Java, Flash kockázatok.

Üdv,
Marci

+1

Safariban is :)

Kit érdekel itt az IE?

krix emlegette, épp e szálban. De igazad van, manapság az Edge érdekesebb :)

Üdv,
Marci

+1, kár, hogy XP-re nem lesz :-P

Mint ahogy Win95-re és Win 3.1-re sem.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Jo, de ki hasznal Win 95-t meg 3.1-et?

XP-t sem kellene.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Az mindegy hogy kellene-e, hasznaljak az IE6-javal vagy max IE8-aval egyutt. Meg erosen merheto szazalek hasznalja, mig a Win 98-at hasznalok szama mar statisztikai hibahatar alatt van.

Miért lenne mindegy? Nem kár. Miután az XP-nek nincs támogatása, azóta van Win7, 8.0, 8.1, 10 - vagy majdnem -, így nem igazán értem, miért is kellene portolni a legújabb bömgészőt XP-re. Értelme annyi, mintha Win95-re portolnák. Az szerintem nem érv, hogy még használják. Nem támogatott. Akkor, ha én boot-olok egy MS-DOS 5.0-t, kapok rá friss böngészőt az MS-től? Nyilván nem, és nem is elvárható. Ugyanígy az XP esetéban is.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Hint: Ceruzaország (vagy más néven Irónia)

Vasaloorszag ;)

Aki működő böngészőt akar :-)

A flash ha lassan is , de biztosan megfog halni. Nekem még telepítve sincs , mert nem érzem szükségét , emellett linuxhoz csak régi verzió érhető el , így inkább telepítettem a chromeot külön , ha filmeket vagy sorozatokat nézni támadna kedvem.

Tisztára ideg vagyok, hogy a bestgore.com-on nem tudom megnézni a legújabb kivégzéseket!

Nem vagyok webfejlesztő. Mi az oka, hogy a legtöbb videó az oldalakon flash alapú? Rohadt idegesítő.

tippre egyszerűbb konvertálni (nem 3-4 formátumszor x 3 verzió, csak 1x) + nem kell a régi szarhoz hozzányúlni

-
Konténerezett Hadoop és Cassandra cluster konfigurálása - harmadik rész

A böngészők <video> támogatása még csak mostanában terjed el (sokan elavult/enterprise browserrel nyomják), a flash pedig 99%-nál működik. DRM-et csak a flash tud. Meg ugye a tradíció, sok player lett lefejlesztve flash-ben, nehezen engedik el.

99%-ios,android

Nem ritka az a kombó, hogy desktopra flash, mobilra html5 playert ad a site.

Érdekes, YouTube-nak sikerült.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Ők is visszamennek flash-re régi böngészőnél. Aki csak mainstream akar playert fejleszteni az egész eddig flash-elt, opcionálisan mobilra kitett egy buta html5 playert, mert eddig ez volt a legolcsóbb per-kopf. De lassan átbillen ez is a html5 térfelére.

> DRM-et csak a flash tud

No meg a Silverlight. ;)

Arra emlékszem, azt az MS fogja kinyiffantani.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Itt azt irja a Rendszer, hogy 2021-ig biztosan tamogatjuk majd. Addig meg csak sikerul kitalalni valami jobbat, mint a Flash, Silverlight, vagy a HTML5-os video tag.

Lehet, erre emlékeztem:

In 2015, Microsoft announced that since support for ActiveX will be discontinued with Microsoft Edge, Silverlight will not be supported in that browser.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Lehet. :)

A HTML5-ös video tag-gel mi a gond? Nem épp ez jönne a Flash, Silverlight helyett?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

DRM van benne?

Mondjuk nekem ne is legyen. Úgy érted, asszisztálnom kellene a szabadságom feladásához? Amúgy fogalmam sincs, hogy van-e benne, vagy sem, de remélem a screen capture, valamint a hangszerver monitorozása nem ütközik akadályokba.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Egy csomo szolgaltatas kb csak azert tud letezni, mert eleg jo hatekonysagu DRM megoldast tudtak talalni: Netflix, HBO GO, stb.

Ha nem lenne DRM, akkor valoszinuleg eleve nem hasznalhatnad ezeket, tehat az nehezen allja meg a helyet, hogy ez teged barmiben is korlatozna.

Miért ne létezhetnének ezek a szolgáltatások ha nem lenne DRM? Nem attól működik, hogy van, attól csak a tartalomszolgáltatóknak van az a hamis illúziójuk, hogy megvédték lelopás ellen a kontentet. Védték egy francokat... én olyanról még nem hallottam, hogy valami film/sorozat ne került volna ki a netre... Nem is tudom elképzelni, hogy komoly releaserek netflix-szel fognak szórakozni, amikor elérhető valami más forrásból. Cserébe az user szivatva van aki rootolt telefonnal jár, vagy linuxot használna...

Nem hiszem, hogy illúziójuk lenne. Inkább ők akarnak illúziót kelteni azzal, hogy elhitetik, illúziójuk van.

:)

Minek?