safe_mode_include_dir probléma

 ( djtacee | 2010. október 21., csütörtök - 12:58 )

Sziasztok!

Debian 4.0 rendszeren használok Plesk hosting menedzsment felületet.
Szerettem volna megoldani hogy a PEAR minden usernek elérhető legyen.

apt-get install php-pear és a szükséges csomagok a helyükön, a fájlok itt: /usr/share/php

php.ini:

safe_mode = On
safe_mode_include_dir = "/usr/share/php"
include_path = ".:/usr/share/php"

Apache restart után is ezt kapom:

"Fatal error: require() [function.require]: Failed opening required 'MDB2.php' (include_path='.:/usr/share/php') in /var/www/vhosts//httpdocs/system/extensions/database/_database.php on line 2"

Eddigi ismereteim szerint ennek mennie kellene, mi lehet a gondja?
Nagyon köszönöm előre is a segítséget!

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Még annyi, hogy van open_basedir beállítva, de elvileg ennek a globális beállításnak a php.ini-ben ezt felül kell bírálnia, hiszen pont ez lenne a lényege