gcc-3.3 csomag hiba?

 ( pinterg | 2004. augusztus 28., szombat - 10:20 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

a fenti bug report logban látszik hogy: gcc-3.3_3.3.4-6sarge1.2_i386.deb be kerül be a javítás.
tegnapi nap viszont 3.3.4-6sarge1.1 került csak fel a mirrorokra, tehát ebben még nincs benne.
javasolnám hogy tegyétek fel az apt-listbugs -ot, de pont a gcc-nél annyi feleslegesen sokszorosan és nehány false beküldött bug report van hogy mire kibogarászod ki kivel van megőszülsz...igaz annyi előnye még így is van hogy látod hogy bugos a legújabb vagy nem és max nem telepíted...

//jah mostmár frissültek a bugreportok is, szóval csak fele annyi van mint tegnap éjszaka :)

[quote:b36c13e536="zitbug"]Nalam meg mindig beteg:-(((((([/quote:b36c13e536]
Én tegnap este 11 után update-eltem az ftp.de.debian.org-ról és most megint a sarge-porposed-updates-ból installáta a csomagokat.
Most a ******-3.3_1%3a3.3.4-6sarge1.2_i386.deb verziójúakata rakta fel és hiba nélkül felmentek.

Gus

[quote:fc50666e12="pinterg"][quote:fc50666e12="zitbug"]Nalam meg mindig beteg:-(((((([/quote:fc50666e12]
Én tegnap este 11 után update-eltem az ftp.de.debian.org-ról és most megint a sarge-porposed-updates-ból installáta a csomagokat.[/quote:fc50666e12]

mert benn van a sources.list-edben ugyebár a sarge-porposed-updates, ami maj' ma fog a testing/sarge-ba kerülni

[quote:0d8eabbe9e="tso"]mert benn van a sources.list-edben ugyebár a sarge-porposed-updates, ami maj' ma fog a testing/sarge-ba kerülni[/quote:0d8eabbe9e]
Igen tudom, hogy benne van a sources.list-emben, direkt hívtam fel rá zitbug figyelmét, hogy nekem azért ment fel hibátlanul.

Gus

[quote:e8b77cad2d="pinterg"]Igen tudom, hogy benne van a sources.list-emben, direkt hívtam fel rá zitbug figyelmét, hogy nekem azért ment fel hibátlanul.[/quote:e8b77cad2d]

miután megírtam a hozzászólást már rájöttem, csak miután elküldtem az elsőt úgy tűnt mintha arra válaszoltál volna a quote pont lelógott a képernyőről :)

Megvarom a ma este 11 et;-)))
Ezert most nem irom at a sorces.list..

Azert thx

Na végre... Hogy ezen mi tartott ennyi ideig? (Jó, tudom, http://bugs.debian.org/cgi-bin/bugreport.cgi?archive=no&bug=264835 vagy 268807 - de azért ez akkor is gáz...)

Az mitől lehet, hogy a debian.inf.elte előbb frissül, mint az ftp.fsn.hu ? 23.14-kor apt-get upgrade -kor csak az elte-ről jött az új csomag.

Sziasztok!

Tegnap este upgradeltem a sargeom és ilyen hiba üzenetet kaptam:

(Reading database ... 69352 files and directories currently installed.)
Preparing to replace gcc-3.3 1:3.3.4-6sarge1 (using .../gcc-3.3_1%3a3.3.4-6sarge1.1_i386.deb) ...
Unpacking replacement gcc-3.3 ...
dpkg: error processing /var/cache/apt/archives/gcc-3.3_1%3a3.3.4-6sarge1.1_i386.deb (--unpack):
trying to overwrite `/usr/share/doc/gcc-3.3-base/changelog.Debian.gz', which is also in package gcc-3.3-base
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libstdc++5-3.3-dev 1:3.3.4-6sarge1 (using .../libstdc++5-3.3-dev_1%3a3.3.4-6sarge1.1_i386.deb) ...
Unpacking replacement libstdc++5-3.3-dev ...
dpkg: error processing /var/cache/apt/archives/libstdc++5-3.3-dev_1%3a3.3.4-6sarge1.1_i386.deb (--unpack):
trying to overwrite `/usr/share/doc/libstdc++5/changelog.Debian.gz', which is also in package libstdc++5
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace g++-3.3 1:3.3.4-6sarge1 (using .../g++-3.3_1%3a3.3.4-6sarge1.1_i386.deb) ...
Unpacking replacement g++-3.3 ...
dpkg: error processing /var/cache/apt/archives/g++-3.3_1%3a3.3.4-6sarge1.1_i386.deb (--unpack):
trying to overwrite `/usr/share/doc/gcc-3.3-base/changelog.Debian.gz', which is also in package gcc-3.3-base
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace gcj-3.3 1:3.3.4-6sarge1 (using .../gcj-3.3_1%3a3.3.4-6sarge1.1_i386.deb) ...
Unpacking replacement gcj-3.3 ...
dpkg: error processing /var/cache/apt/archives/gcj-3.3_1%3a3.3.4-6sarge1.1_i386.deb (--unpack):
trying to overwrite `/usr/share/doc/gcc-3.3-base/changelog.Debian.gz', which is also in package gcc-3.3-base
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/gcc-3.3_1%3a3.3.4-6sarge1.1_i386.deb
/var/cache/apt/archives/libstdc++5-3.3-dev_1%3a3.3.4-6sarge1.1_i386.deb
/var/cache/apt/archives/g++-3.3_1%3a3.3.4-6sarge1.1_i386.deb
/var/cache/apt/archives/gcj-3.3_1%3a3.3.4-6sarge1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ma reggel is megpróbáltam, kiürítettem az apt cache-ét, ujra letöltöttem a csomagokat de ugyanazt a hibaüzenetet dobta mint amit tegnap este.
Tegnap este ezek a csomagok még a sarge-proposed-updates között szerepeltek ma reggel viszont már a sarge csamagjai közt. Viszont az az érdekes, hogy a gcc-3.3-base csomag ugyanez a verziója hibátlanul felment.
Ha jól értem, a hiba az, hogy a changelog-ot akarja frissíteni, de nem sikerül neki.

Ezt a hibát hogyan lehet kiküszöbőlni?

Gus

csomagolasi hiba, nyugodtan hasznald a --force-overwrite kacsplot a vonatkozo csomagok installjanal (vagy atmenetileg beteheted ezt az opciot a dpkg.cfg-be is)

[code:1:76a75dc622]dpkg -i --force-overwrite vonatkozo-csomag1 vonatkozo-csomag2 vonatkozo-csomag3 ...[/code:1:76a75dc622][/code]

[quote:203b5c56b3="pinterg"]Ma reggel is megpróbáltam, kiürítettem az apt cache-ét, ujra letöltöttem a csomagokat de ugyanazt a hibaüzenetet dobta mint amit tegnap este.
[/quote:203b5c56b3]
A csomagok huszonnegy orankent egyszer frissulnek, akarmennyi verziot tolt fel a DD egy nap.

[quote:203b5c56b3="pinterg"]Ha jól értem, a hiba az, hogy a changelog-ot akarja frissíteni, de nem sikerül neki.
[/quote:203b5c56b3]
Majdnem, a baj az, hogy mas csomag changelog-jat akarja frissiteni.

[quote:203b5c56b3="pinterg"]Ezt a hibát hogyan lehet kiküszöbőlni?[/quote:203b5c56b3]
A hibat kijavitottak: [url]http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=268338&msg=10[/url]
Ma este tizenegy utan frissitve jo lesz.

[quote:e384a267d1="snq-"]csomagolasi hiba, nyugodtan hasznald a --force-overwrite kacsplot a vonatkozo csomagok installjanal (vagy atmenetileg beteheted ezt az opciot a dpkg.cfg-be is)

[code:1:e384a267d1]dpkg -i --force-overwrite vonatkozo-csomag1 vonatkozo-csomag2 vonatkozo-csomag3 ...[/code:1:e384a267d1][/quote:e384a267d1]
Szerintem ne, varja ki az este tizenegyet, mert mar fixaltak. Jobb mint ilyeneket a dpkg.cfg-be tenni.

ja, csak ha vmit pocsolni akar a gccvel addig is...
vicces, mert pont akkor olvastam ezt a thread-nyitot, amikor kikopte a hibauzenetet nalam; igy jar, aki koran kel.

btw ha jol latom, ma kerul be 5 honap utan a gimp (az igazi, nem az a gagyi gtk-1.2-es)

[quote:e6f45f219f="GCS"]A hibat kijavitottak: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=268338&msg=10[/quote:e6f45f219f]
Eddig ez az oldal elkerülte a figyelmem. :(
De most már használni fogom!

[quote:e6f45f219f="snq-"]ja, csak ha vmit pocsolni akar a gccvel addig is... [/quote:e6f45f219f]
Szerencsére nem kötelező ma használnom a gcc-t, szóval asszem marad a várakozás estig.

Köszi a gyors segítséget!

Gus

[quote:c2d72425d7="snq-"]ja, csak ha vmit pocsolni akar a gccvel addig is...
[/quote:c2d72425d7]? Az eredeti (ertsd: regi verzioju gcc) meg mindig ott van a rendszerben, mert a dpkg nem irta felul. Mivel mukodik a regi, miert kellene eroszakoskodni az ujjal? Majd a megujabbal mar ki van javitva.

[quote:c2d72425d7="snq-"]btw ha jol latom, ma kerul be 5 honap utan a gimp (az igazi, nem az a gagyi gtk-1.2-es)[/quote:c2d72425d7]
Igen, en is igy latom: [url]http://bjorn.haxx.se/debian/testing.pl?package=gimp[/url]

[quote:e13c86bb6e="pinterg"][quote:e13c86bb6e="GCS"]A hibat kijavitottak: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=268338&msg=10[/quote:e13c86bb6e]
Eddig ez az oldal elkerülte a figyelmem. :(
De most már használni fogom!
[/quote:e13c86bb6e]
Az egyik legfonotsabb Debian-os oldal. De sokfele van, csak altalaban nem mindenki ismeri oket.

Nalam meg mindig beteg:-((((((