Nem megy a nyomtató!

 ( Athes | 2004. július 22., csütörtök - 9:44 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

[quote:389c9e365e="SAGAL"]Tehát nem kell itt duhh-ogni, mondom újra köszönöm, vettem a lapot és az egyszer tényleg jó hogy írtad, mert mielőtt nem küldted a linket nem hallottam róla, hanem a nyomorult linuxprintingen azt írták már 1 éve is , hogy full támogatott.... csak ez valahogy kimaradt, mármint a firmware része.....

+1* köszönöm![/quote:389c9e365e]
Szívesen, de akkor is duhh! :twisted: :lol:
Én tavaly egy LJ1010-est izgattam be Woody alá sikerrel, lépésről-lépésre a "nyomorult" :-) linuxprinting.org-on leírtak alapján, ezért linkeltem be neked az oldalt. Azzal nem volt ilyen firmware probléma, csak a Woodyban lévő gs szopatott kicsit (megcserélte az alsó és felső margót), de a nyomtató teljesen jól működött.
Azért írd meg, ha végül sikerrel jártál!

Szabi

[b:d8c16b087d]lsmod[/b:d8c16b087d] listázza a [i:d8c16b087d]printer[/i:d8c16b087d] és [i:d8c16b087d]usbcore[/i:d8c16b087d] modulokat?
[b:d8c16b087d]lsusb[/b:d8c16b087d]vel látszik a nyomtatód?
Hányas kernel verziót használsz?
[b:d8c16b087d]hotplug[/b:d8c16b087d] vagy [b:d8c16b087d]usbmgr[/b:d8c16b087d] valamelyike fennvan a gépeden?

[quote:5686e32671="begin"][b:5686e32671]lsmod[/b:5686e32671] listázza a [i:5686e32671]printer[/i:5686e32671] és [i:5686e32671]usbcore[/i:5686e32671] modulokat?
[b:5686e32671]lsusb[/b:5686e32671]vel látszik a nyomtatód?
Hányas kernel verziót használsz?
[b:5686e32671]hotplug[/b:5686e32671] vagy [b:5686e32671]usbmgr[/b:5686e32671] valamelyike fennvan a gépeden?[/quote:5686e32671]

meri-home root # lsmod | grep usbcore
usbcore 101988 7 uhci_hcd,usblp,usb_storage,ehci_hcd,ohci_hcd
meri-home root # lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 003: ID 03f0:b002 Hewlett-Packard
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
meri-home root # emerge -s hotplug
Searching...
[ Results for search key : hotplug ]
[ Applications found : 2 ]

* sys-apps/hotplug
Latest version available: 20040923
Latest version installed: 20040923
Size of downloaded files: 43 kB
Homepage: http://linux-hotplug.sourceforge.net
Description: USB and PCI hotplug scripts
License: GPL-2

* sys-apps/hotplug-base
Latest version available: 20040401
Latest version installed: 20040401
Size of downloaded files: 40 kB
Homepage: http://linux-hotplug.sourceforge.net
Description: Base Hotplug framework
License: GPL-2

meri-home root # uname -a
Linux meri-home 2.6.9-gentoo-r13 #2 Sat Jan 8 20:47:24 Local time zone must be set--see zic manua i686 AMD Athlon(tm) XP 2500+ AuthenticAMD GNU/Linux
meri-home root #

egyedül a printer modult nincs betöltve, de nem is találok olyat

Igazad van. A printer helyett [b:100553077a]usblp[/b:100553077a] modul kell és az be is van töltve neked!
Így ránézésre minden adott hogy működjön a dolog. rootként sem megy a nyomtatás?

[quote:3f26f7bd9a="begin"]Igazad van. A printer helyett [b:3f26f7bd9a]usblp[/b:3f26f7bd9a] modul kell és az be is van töltve neked!
Így ránézésre minden adott hogy működjön a dolog. rootként sem megy a nyomtatás?[/quote:3f26f7bd9a]

hmm...ebben kis segítség kellene...hogyan lehet mondjuk konzolrol root-kent nyomtatni ? :)
sosem csináltam még ilyet azért kérdezem

A cups printer lapján a [b:2f82f89b55]Device URI[/b:2f82f89b55] után mi szerepel?

[quote:a83d6ced21="begin"]A cups printer lapján a [b:a83d6ced21]Device URI[/b:a83d6ced21] után mi szerepel?[/quote:a83d6ced21]

hát ezt csak este tudom megmondani, mert a gépem otthon figyel és innen csak ssh-zn keresztul érem el

[b:58f32ad1df]lynx[/b:58f32ad1df]-szel, vagy [b:58f32ad1df]links[/b:58f32ad1df]-szel is megnézheted a cups-t.

[quote:51a5c77483="meridian"]hmm...ebben kis segítség kellene...hogyan lehet mondjuk konzolrol root-kent nyomtatni ? :)
sosem csináltam még ilyet azért kérdezem[/quote:51a5c77483]
Azt hittem, hogy grafikus felületről akarsz nyomtatni. Eddig nem volt szükségem konzolról való nyomtatásra, de gondolom simán átirányítod a kimenetet a printerre. (pl. cat file.txt > /dev/usblp0)

[quote:76d35e7ee6="meridian"][quote:76d35e7ee6="begin"]A cups printer lapján a [b:76d35e7ee6]Device URI[/b:76d35e7ee6] után mi szerepel?[/quote:76d35e7ee6]

hát ezt csak este tudom megmondani, mert a gépem otthon figyel és innen csak ssh-zn keresztul érem el[/quote:76d35e7ee6]
Hp-Photosmart-7260 HP PhotoSmart 7260 Foomatic/hpijs (recommended)
Description:
Location:
Printer State: idle, accepting jobs.
Device URI: usb:/dev/usb/lp0

Létezik a /dev/usb/lp0 eszköz? Elvileg kéne, mert az usblp modulnak kéne létrehoznia.

[quote:534cb57fea="begin"]Létezik a /dev/usb/lp0 eszköz? Elvileg kéne, mert az usblp modulnak kéne létrehoznia.[/quote:534cb57fea]

meri-home root # ls -la /dev/usb/
total 0
drwxr-xr-x 2 root root 0 Feb 10 07:00 .
drwxr-xr-x 21 root root 0 Feb 10 06:59 ..
crw-rw---- 1 root lp 180, 0 Feb 10 07:00 lp0

hát lehet itt a baki...maciban ilyen szép lila és "-" jel van mellette

Nálam is így néz ki és működik. Igaz nekem Canon S200-as nyomtatóm van, de ez ebben az esetben mellékes.
A cupsból való teszt oldal nyomtatáskor dobja a hibát, vagy valami alkalmazásból való nyomtatáskor?

[quote:080c241d23="begin"]Nálam is így néz ki és működik. Igaz nekem Canon S200-as nyomtatóm van, de ez ebben az esetben mellékes.
A cupsból való teszt oldal nyomtatáskor dobja a hibát, vagy valami alkalmazásból való nyomtatáskor?[/quote:080c241d23]

próbáltam a cupsból, és próbáltam kde-ből a tesztnyomtatást, de mindenhol várakozás

Lassan kezdek kifogyni az ötletekből... Én megpróbálnám újrarakni a nyomtatót, esetleg más driverrel. A kde nagyon kellemes felületet biztosít a telepítéshez, azt is mutatja, hogy melyik porton lóg a nyomtatód.

[quote:5efacf7714="begin"]Lassan kezdek kifogyni az ötletekből... Én megpróbálnám újrarakni a nyomtatót, esetleg más driverrel. A kde nagyon kellemes felületet biztosít a telepítéshez, azt is mutatja, hogy melyik porton lóg a nyomtatód.[/quote:5efacf7714]

rendben megproszalom, igaz ez a szutyok cups a telepitesnel nem jeleniti meg ennek a nyomtatonak a driveret, csak ha kezzel allitom be ugy megy, pedig benne van a listában...

Nagyon hasonló gonddal küzdök , mint meridian.
Van egy HP Lj 1005-ös nyomtató és gyakorlatilag minden drive fennt van , minden látja, és mégsem nyomtat , se rootként , se sehogy, lsusb és ott van, felismeri, tesztet is nyomtat , illetve elküldi, de a nyomtató meg sem nyikkan.
Felraktam a Zsuzsit, bízva abba , hogy a hiper hardware felismerése segít, de ugynaez, látja ott van, kapcsolat, kommunikáció rendben és semmi.
És minden lehetséges szart végig olvastam, a cups-ot már darabjaira szedtem, de semmi.....

[quote:444fba8eee="SAGAL"]Nagyon hasonló gonddal küzdök , mint meridian.
Van egy HP Lj 1005-ös nyomtató és gyakorlatilag minden drive fennt van [/quote:444fba8eee]
Esetleg egy ilyen nem segít?
[code:1:444fba8eee]
#USE="samba cups pam ppds" emerge hpijs
[/code:1:444fba8eee]
Igaz, nekem egy HP Deskjet 3550-essel oldódott meg így a gond, de hátha...

[quote:8bd3bac872="SAGAL"]Van egy HP Lj 1005-ös nyomtató és gyakorlatilag minden drive fennt van , minden látja, és mégsem nyomtat , se rootként , se sehogy, lsusb és ott van, felismeri, tesztet is nyomtat , illetve elküldi, de a nyomtató meg sem nyikkan.[/quote:8bd3bac872]

Helló!

[url=http://www.linuxprinting.org/show_printer.cgi?recnum=HP-LaserJet_1005]A firmware-ét is megetetted vele nyomtatás előtt?[/url]

Szabi

Hali!
Van egy kis gondom! Mint gondolom a címból is kitaláltátok nem megy a nyomtatóm.
Usb-s, hp photosmart 7260.
A rendszerindításnál már hibát jelez:
Jul 22 08:44:42 localhost kernel: printer.c: v0.11: USB Printer Device Class driver
Jul 22 08:44:42 localhost insmod: insmod: a module named printer already exists
Jul 22 08:44:42 localhost insmod: insmod: insmod /lib/modules/2.4.24-7/kernel/drivers/usb/printer.o failed
Jul 22 08:44:42 localhost insmod: insmod: insmod printer failed
Jul 22 08:44:42 localhost insmod: insmod: a module named printer already exists
Jul 22 08:44:42 localhost insmod: insmod: insmod /lib/modules/2.4.24-7/kernel/drivers/usb/printer.o failed
Jul 22 08:44:42 localhost insmod: insmod: insmod printer failed

Mit csináljak vele? :(

[quote:dfef3e0261="KKata"]
Esetleg egy ilyen nem segít?
[code:1:dfef3e0261]
#USE="samba cups pam ppds" emerge hpijs
[/code:1:dfef3e0261]
Igaz, nekem egy HP Deskjet 3550-essel oldódott meg így a gond, de hátha...[/quote:dfef3e0261]

Sajnos nem, fentt van a hpijs is, és ezeket a USE flageket belőttem.
De nem, éppen ezért próbáltam "automata" disztribektől ellesni, hogy hogyan oldják meg, de ott sem akart menni, pedig ahogy

[quote:dfef3e0261="szsz"]Helló!

A firmware-ét is megetetted vele nyomtatás előtt?

Szabi[/quote:dfef3e0261] Szabi barátunk is írja, a ppd file-t megetettem vele, minden esetben , sőt a létező összest kipróbáltam......

Valószínűleg kétszer töltöd be a modult. Egyszer a modutils-en, egyszer pedig a modules-on keresztül. Próbáld meg kiremelni a modules file-ban.
És megnézhetnéd a [b:4b623543a1]lsmod[/b:4b623543a1]-dal, hogy a modul be van-e töltve.

1) milyen disztro ?
2) érd el azt, h csak 1x próbálja meg betölteni
3) cupssal állítsd be a nyomtatót

a modules.conf ban semmit nem találtam, ha arra gondoltál begin.
rmmod-dal kiszedtem , de még így sem akar pengetni

vmiklos: ez egy UHU 1.1.1
hogy érjem el, hogy csak 1x akarja betölteni?
8O

[quote:38064502fc="SAGAL"][quote:38064502fc="szsz"]

A firmware-ét is megetetted vele nyomtatás előtt?

Szabi[/quote:38064502fc] Szabi barátunk is írja, a ppd file-t megetettem vele, minden esetben , sőt a létező összest kipróbáltam......[/quote:38064502fc]
Csak a félreértések elkerülése végett írom le még egyszer, hogy [b:38064502fc]én a nyomtató firmware-ének betöltésére gondoltam, nem a ppd fájlokra![/b:38064502fc]
[quote:38064502fc]The firmware of the printer must be uploaded after turning it on. Note that you cannot simply upload it by commands like "cat sihp1005.img > /dev/usb/lp0". The "foo2zjs" driver package contains a script to do the upload.[/quote:38064502fc] Ha te is így értetted, akkor tárgytalan... :-)

Szabi

ja és rmmod után insmod-dal megint betöltöttem
csak hogy félreértés ne essék

nah jó
nagyon kell a nyomtató
de megvan a részleges megoldás: Van nekem még 3 gépem ezen kívül. de hülye vok
:D
Azért még várom az ötleteket
már backup-olni akartam oszt reinstall mindent

Athes:
A hozzászólásom másik felére nem reagáltál. Az [b:f0004af266]lsmod[/b:f0004af266] mit mond?

printer 8704 0 (unused)
meg megtaláltam az usbcore modulnál is
usbcore 77132 1 [printer usb-storage scanner ehci-hcd usb-ohci]

[quote:b19724690e="Athes"]printer 8704 0 (unused)
meg megtaláltam az usbcore modulnál is
usbcore 77132 1 [printer usb-storage scanner ehci-hcd usb-ohci][/quote:b19724690e]

OK, akkor mi a problem???

Mit jelent hogy nem megy???

A device valahol a /dev alatt van, attol fugg mit hasznalsz (nativ linux namespace/devfs/udev???)

Amugy /dev/usb/lp0
/dev/usblp0
meg hasonlok jöhetnek szóba....

Zsiráf

[quote:d71f644b50="szsz"]
The firmware of the printer must be uploaded after turning it on. Note that you cannot simply upload it by commands like "cat sihp1005.img > /dev/usb/lp0". The "foo2zjs" driver package contains a script to do the upload. Ha te is így értetted, akkor tárgytalan... :-)
Szabi[/quote:d71f644b50]

Erről még öreganyám sem halott! :lol:
Köszönöm, megpróbálom!

[quote:6406d45429="SAGAL"]Erről még öreganyám sem halott! :lol:
Köszönöm, megpróbálom![/quote:6406d45429]

Ha még a nagyanyád sem ha[b:6406d45429]ll[/b:6406d45429]ott! róla, akkor nézd meg végre azt az oldalt, amit az első hozzászólásomban belinkeltem, hátha segít! -> [url=http://www.linuxprinting.org/show_printer.cgi?recnum=HP-LaserJet_1005]A firmware-ét is megetetted vele nyomtatás előtt? [/url]
duhh :twisted:

Szabi

Ezek után fogsz egy böngészőt és URL-nek beírod a [b:a5d276b077]localhost:631[/b:a5d276b077]-et és felviszed a nyomtatót.

[quote:cfcdc3add9="begin"]Ezek után fogsz egy böngészőt és URL-nek beírod a [b:cfcdc3add9]localhost:631[/b:cfcdc3add9]-et és felviszed a nyomtatót.[/quote:cfcdc3add9]

Köszi!
megoldódott :)
localhost:631
utána töröltem onnan a nyomtatót, majd felraktam megint mostmár jó.
köszi szépen

[quote:2947b42005="szsz"][quote:2947b42005="SAGAL"]Erről még öreganyám sem halott! :lol:
Köszönöm, megpróbálom![/quote:2947b42005]

Ha még a nagyanyád sem ha[b:2947b42005]ll[/b:2947b42005]ott! róla, akkor nézd meg végre azt az oldalt, amit az első hozzászólásomban belinkeltem, hátha segít! -> [url=http://www.linuxprinting.org/show_printer.cgi?recnum=HP-LaserJet_1005]A firmware-ét is megetetted vele nyomtatás előtt? [/url]
duhh :twisted:

Szabi[/quote:2947b42005]

Édes barátom! Mondtam, hogy köszönöm, mert már akkor megnéztem és meg is lepődtem, hogy van ilyen.
Sőt annyira utánna jártam a dolognak, hogy a nyomorult HP nem tett a régi 1000-es szériába firmware-t és ugye így most tőtikézni kell.
Tehát nem kell itt duhh-ogni, mondom újra köszönöm, vettem a lapot és az egyszer tényleg jó hogy írtad, mert mielőtt nem küldted a linket nem hallottam róla, hanem a nyomorult linuxprintingen azt írták már 1 éve is , hogy full támogatott.... csak ez valahogy kimaradt, mármint a firmware része.....

+1* köszönöm!

nekem ugyanilyen nyomtatom van gentoo alatt, csak sajna nem sikerül működésre bírni, feltoltam mindent, és beállítottam mindent, a cups-on megjelenik a nyomtato, be vannak töltve a megfelelő modulok, ellenben azt irja ki hogy nincs csatlakoztatva várjak 30 sec-et....mind a 16 usb portot kiprószáltam azért, meg végigolvastam megitn a doksit de nem jutok előrébb, pedig anno mikor ubuntu-t használtam ott siralyul muxott...

vkinek van vmi ötlete ?