MPlayer-1.0pre4: Csak nalam bugizk???

 ( Chip | 2004. április 28., szerda - 15:40 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hali!

Nem tartozik szorosan ehhez a témához, de nem tudom lefordítani az Mplayert sid alatt!
A hibaüzenetem:
cc -c -I../libvo/ -I../../libvo -O4 -march=pentium4 -mcpu=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I. -Inative -I.. -I../libmpdemux -I../loader -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -D_GNU_SOURCE -o vd_xvid.o vd_xvid.c
vd_xvid.c: In function `init':
vd_xvid.c:72: error: `XVID_INIT_PARAM' undeclared (first use in this function)
vd_xvid.c:72: error: (Each undeclared identifier is reported only once
vd_xvid.c:72: error: for each function it appears in.)
vd_xvid.c:72: error: parse error before "ini"
vd_xvid.c:73: error: `XVID_DEC_PARAM' undeclared (first use in this function)
vd_xvid.c:93: error: `ini' undeclared (first use in this function)
vd_xvid.c:94: error: `dec_p' undeclared (first use in this function)
vd_xvid.c:124: error: `XVID_CSP_RGB24' undeclared (first use in this function)
vd_xvid.c:127: error: `XVID_CSP_RGB32' undeclared (first use in this function)
vd_xvid.c:140: error: `API_VERSION' undeclared (first use in this function)
vd_xvid.c: In function `decode':
vd_xvid.c:190: error: `XVID_DEC_FRAME' undeclared (first use in this function)
vd_xvid.c:190: error: parse error before "dec"
vd_xvid.c:204: error: `dec' undeclared (first use in this function)
make[1]: *** [vd_xvid.o] Error 1
make[1]: Leaving directory `/usr/src/MPlayer-1.0pre4/libmpcodecs'
make: *** [libmpcodecs/libmpcodecs.a] Error 2
make -C libmpcodecs
make[1]: Entering directory `/usr/src/MPlayer-1.0pre4/libmpcodecs'
cc -c -I../libvo/ -I../../libvo -O4 -march=pentium4 -mcpu=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I. -Inative -I.. -I../libmpdemux -I../loader -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -D_GNU_SOURCE -o vd_xvid.o vd_xvid.c
vd_xvid.c: In function `init':
vd_xvid.c:72: error: `XVID_INIT_PARAM' undeclared (first use in this function)
vd_xvid.c:72: error: (Each undeclared identifier is reported only once
vd_xvid.c:72: error: for each function it appears in.)
vd_xvid.c:72: error: parse error before "ini"
vd_xvid.c:73: error: `XVID_DEC_PARAM' undeclared (first use in this function)
vd_xvid.c:93: error: `ini' undeclared (first use in this function)
vd_xvid.c:94: error: `dec_p' undeclared (first use in this function)
vd_xvid.c:124: error: `XVID_CSP_RGB24' undeclared (first use in this function)
vd_xvid.c:127: error: `XVID_CSP_RGB32' undeclared (first use in this function)
vd_xvid.c:140: error: `API_VERSION' undeclared (first use in this function)
vd_xvid.c: In function `decode':
vd_xvid.c:190: error: `XVID_DEC_FRAME' undeclared (first use in this function)
vd_xvid.c:190: error: parse error before "dec"
vd_xvid.c:204: error: `dec' undeclared (first use in this function)
make[1]: *** [vd_xvid.o] Error 1
make[1]: Leaving directory `/usr/src/MPlayer-1.0pre4/libmpcodecs'
make: *** [libmpcodecs/libmpcodecs.a] Error 2
dark:/usr/src#

A feltett csomagok amik az xvid-hez kapcsolódhatnak:
dark:/usr/src# dpkg -l | grep xvid
ii libxvidcore2 0.9.2-0.3 MPEG-4 Video encoder
ii libxvidcore4 1.0.0-rc4-0.0 MPEG-4 Video encoder
ii libxvidencore0 0.9.1-woody0.0 MPEG-4 Video encoder
ii linuxvideostud 0.1.7-1 MJPEG-tools GTK graphical user interface
dark:/usr/src#

Mi kellene még neki, hogy menjen?
Eddig mindíg sikerült lefordítani hibaüzi nélkül!

foggalmam sincs mi a hiba, de ha itt nem találsz semmit, akkor írhatnál az mplayer-lisára bugreportot :wink:

[quote:0cde41ae52="gabcsi"]Hali!

Nem tartozik szorosan ehhez a témához, de nem tudom lefordítani az Mplayert sid alatt!
A hibaüzenetem:
[Sok xvid baromságot]
make[1]: *** [vd_xvid.o] Error 1
make[1]: Leaving directory `/usr/src/MPlayer-1.0pre4/libmpcodecs'
make: *** [libmpcodecs/libmpcodecs.a] Error 2
dark:/usr/src#

A feltett csomagok amik az xvid-hez kapcsolódhatnak:
dark:/usr/src# dpkg -l | grep xvid
ii libxvidcore2 0.9.2-0.3 MPEG-4 Video encoder
ii libxvidcore4 1.0.0-rc4-0.0 MPEG-4 Video encoder
ii libxvidencore0 0.9.1-woody0.0 MPEG-4 Video encoder
ii linuxvideostud 0.1.7-1 MJPEG-tools GTK graphical user interface
dark:/usr/src#

Mi kellene még neki, hogy menjen?
Eddig mindíg sikerült lefordítani hibaüzi nélkül![/quote:0cde41ae52]
Igaz, ez csak workaround... De van vmi. értelmes indokod arra, h ezeket a gyagya libeket használd? Tudtommal ffmpeg libavcodec-jében is van xvid support... És ha vmi. ott nem megy, akkor azt a fejlesztők gyorsan javítják is neked...
Nálam semmi ilyen libxvidsuxbaromság nincs fent. Csak eredeti MPlayer forrás (vmi. pár hónapos cvs) és megy minden...
De másik gépen ma tegnap tettem fel a pre4-et, és ott is megy minden, amit eddig próbáltam vele.

Ha megnyugtat nálam is bugos mint állat, bizonyos mpg-eknél néha fagy ( pl ha nyomog egy pause-t (space) -t ) gmplayer-rel. bugriporta sajnos idom nincs, csak itt panaszkodni :)

gcc version 3.3.1 (Mandrake Linux 9.2 3.3.1-2mdk)

./configure --enable-gui -val forgatva eleg sok negativ elmennyel lettem gazdagabb:

Lejatszas kozben ha raklikkelek a GUI-n a play gombra, eltunik a kep.
Ezek utan ha q-val kilepek, nem kapom vissza a shell-t es egy beragadt mplayer task-ot kell kilonom.

Akad par MPG file aminel egyszeruen a sima mplayer (nem gmplayer) nem csinal semmit. Egyszeruen kilep:
[code:1:6ff411509f]
MPlayer 1.0pre4-3.3.1 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 2667 MHz (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/chip/.mplayer/config
Reading /home/chip/.mplayer/codecs.conf: Can't open '/home/chip/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/chip/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/chip/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config

Playing INDO.mpg.

Exiting... (End of file)
[/code:1:6ff411509f]

Mit feleljtettem el update-elni? A hiba az en keszulekemben van? Megjegyzem: a pre3 nem csinalt ilyen 'butasagokat'.

[quote:84483802c6="Chip"]Mit feleljtettem el update-elni? A hiba az en keszulekemben van? Megjegyzem: a pre3 nem csinalt ilyen 'butasagokat'.[/quote:84483802c6]

Sokat segitene, ha a kerdeses filet kitenned valahova (vagy ha nagy, akkor egy reszletet).

Udv!

Ma delutan nyuztam picit, 50-60 db osszevissza mindenfele file, nagyreszt mpg, en semmi kulonoset nem vettem eszre.
(Max. annyit, hogy a caca kimenet nem volt egyenletes.)

Toma_

hát megjegyezném, hogy nálam sincs semmi gond vele... :wink:
de ha valaki venné a fáradságot, és írna rendes bugreportot... benne van a doksiban, hogyan kell :wink:

Nekem többsávos (2 audio, 1 felirat) OGM-eknél nem hajnaldó a 0-s videon és az 1es hangon kívül SEMMIT lejátszani, a -v kiírja hogy van 2-es és 3-as sáv, meg hogy 1 video 2 audio 1 text stream, de ha -aid 2 paraméterrel indítom, azt írja "No audio!", a -sid 3 hasonlóképpen nem eredményez feliratot...
Az 1.0pre3try2-vel MINDEN SIMÁN megy, ugyanazokkal a configure-paraméterekkel, ugyanazokkal a libekkel, ugyanazon a gépen...

Szal sztem kicsit jobban átnézhették volna, mert ez nagyobb buggyűjtemény mint a win95 :)

Na úgy látom, kezdjük érezni Árpi hiányát a projectben... :?

amit fennt írtam, azt elolvashatnátok :wink: