Mplayer teljes képernyő nem megy

Fórumok

Túrtam a google-t és itt is kerestem, de nem tudom mi lehet a megoldás.

Mplayer nem megy teljes képernyővel.
Debian Etch 2.6.18-3 "gyári" kernel

mplayer -vo help


MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 3.06GHz (Family: 15, Model: 4, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
x86-os CPU - a következő kiterjesztésekkel: MMX MMX2 SSE SSE2
Rendelkezésre álló video meghajtók:
	x11	X11 ( XImage/Shm )
	xover	General X11 driver for overlay capable video output drivers
	xvidix	X11 (VIDIX)
	cvidix	console VIDIX
	null	Null video output
	mpegpes	Mpeg-PES to DVB card
	yuv4mpeg	yuv4mpeg output for mjpegtools
	png	PNG file
	tga	Targa output
	pnm	PPM/PGM/PGMYUV file
	md5sum	md5sum of each frame

Nincs xv kimenet, ahogyan látom.
Az

/etc/X11/xorg.conf-ba

belevéstem a

Load "xv"

sort is, de nem változott. A /home/user/.mplayer/gui.conf beírtam

 zoom = "yes" 

Alaplap Intel videokártya (i810). Felraktam (szerintem) minden szükséges dev, X11 és társai csomagot, de nem megy.
Lehet a videokártya nem támogatja teljes képernyős megjelenítést?

Köszönöm a segítséget.

Hozzászólások

Kéne forgatnod egy normális mplayert. Nálam így néz ki a dolog:

mplayer -vo help
MPlayer dev-SVN-r21776-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
x86-os CPU - a következő kiterjesztésekkel: MMX MMX2 SSE SSE2
Rendelkezésre álló video meghajtók:
xv X11/Xv
x11 X11 ( XImage/Shm )
xover General X11 driver for overlay capable video output drivers
gl X11 (OpenGL)
gl2 X11 (OpenGL) - multiple textures version
sdl SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
null Null video output
mpegpes Mpeg-PES to DVB card
yuv4mpeg yuv4mpeg output for mjpegtools
png PNG file
jpeg JPEG file
gif89a animated GIF output
pnm PPM/PGM/PGMYUV file
md5sum md5sum of each frame

98 audió & 216 videó codec

libxv-dev utána újraforgatni?

Szia!

Nekem is volt ilyen, hogy nem ment teljes képernyőn, sőt egyáltalán nem tudtam az ablak méretét változtatni. Ellenben azok a videók, amik alapból nagyobban nyíltak meg, szaggattak, mint állat, pedig ezen a gépen NFS-ezni is lehetett még nem olyan régen :-). Valami ATI mobility-m van.
Sajnos nem tudom a megoldást, de egy biztos: ki akartam próbálni a Berylt (csoda 3D gyorsított ablakkezelő), és a Beryl telepítő wikije szerint installáltam a videókártya drájverét, meg piszkáltam az xorg beállításait, és most már jó (méretezhető ablak, fullscreen, mindenvanitt).
Szerintem az lehet a lényeg, hogy az xv gyorsítást valahogy be kell kapcsolni. Az mindenesetre tuti, hogy az mplayer-t nem forgattam, hanem automatix-szal raktam fel.

Szia!

Nekem is volt ilyen gondom, mplayer -zoom kapcsoloval inditva mukodott a dolog.