Ubuntu fagyi

 ( kupcsik | 2006. július 12., szerda - 10:28 )

Miota Dapperre frissitettem, azota tobbszor is elofordult, hogy lefagyott a laptopom. Jo lenne tudni, hogy masnal is van-e hasonlo problema, vagy az en gepem ilyen kulonleges.

A log fajlokban nem talaltam semmi hibara utalo jelet, egyszeruen leall az egesz rendszer. Ha megy zene, akkor a pufferben levo reszlet ismetlodik. Gyanitom, hogy valami az xorg-gal lehet, mert mindig olyankor tortenik, ha ablakot valtok, vagy uj ablakot hozok letre. De persze nem mondhatom, hogy reprodukalhato, mert eleg ritkan esik meg, hogy lefagy az egesz (mondjuk hetente 2x). De azert eleg idegesito, kicsit Win98-erzes. Ha a gepet magara hagyom (mint altalaban nap kozben), akkor nem tortenik semmi. Ezert gondolom, hogy nem hardverproblema. Szoval masnak is van ilyenje?

Most eszembe jutott, hogy talan az xorg.conf valtozott, majd megprobalom kivenni a dri-t, meg ilyeneket.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Milyen videovezérlő? Nekem a munkahelyi asztali gépen csinálja ugyanezt, az X csontra lockolja a gépet, se billentyűzet se egér, és 100% hajtja a procit. Hálózaton viszont be tudok lépni, ki tudom lőni. A logban egy vagy néha pár sor hibaüzenet van ilyenkor, korábban asszem már írtam is valamelyik fórumba. A kártya nvidia geforce mx440, nv driverrel hiba nélkül megy, viszont bármely nvidiával produkálja a fenti hibát, pedig végigpróbáltam párat, még a legutóbbi legacy-t is. Itthon gef3 ti200 ugyenezzel a rendszerrel hiba nélkül megy - az összes kipróbált driverrel. Nem ubuntu spec, ahogy utánanéztem, azért ha valaki tud megoldás, szóljon :-)!

ATI Radeon Mobility 7500 (M7)

Szerintem az en gepemre nem lehet olyankor bejelentkezni ssh-val, de ezt sajna nem tudom kiprobalni. Nekem a zene fennakadasa azt sugallja, hogy valami a kernelt is megfagyasztja. Ja, es most jut eszembe, hogy volt halozati forgalom a fagyas elott, de utana a alokartya ledje abbahagyta a villogast. Szoval ugy nez ki, hogy total fagyas van.

Nalam is az X fagyott ilyen jelensegekkel, ezutan atkonfigoltam masik driverre es azzal tokeletes. Bar a melohelyi gepemben pl Geforce kartyak fagynak csontra, csak tudnam miert. Valszeg az alaplap AGP vezerloje a ludas.

--
A nyúl egy igazi jellem. Ott ül a fűben, de akkor sem szívja!

Milyen vezérlő? Az én melóhelyi gépemben nforce2-es van, aranyos lenne, ha amiatt fagyna :-)

Ezt majd megnezem. Nekem ilyen van:

dmesg | grep agp
[17179600.104000] Linux agpgart interface v0.101 (c) Dave Jones
[17179600.112000] agpgart: Detected an Intel i815 Chipset.
[17179600.116000] agpgart: AGP aperture is 64M @ 0xe8000000
[17179639.668000] agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
[17179639.668000] agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
[17179639.668000] agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
[17190898.880000] agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
[17190898.880000] agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
[17190898.880000] agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode

Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected VIA P4M266x/P4N266 chipset
agpgart: AGP aperture is 64M @ 0xe8000000

--
A nyúl egy igazi jellem. Ott ül a fűben, de akkor sem szívja!

Hmm, ezek eléggé különböznek, nem lehet, hogy bizonyos kártyákkal/chip-el bugzik inkább? Bár amikor utánajártam, nem találtam ilyen info-t, elég misztikus ez az egész. Gondoltam hűtés elégtelenségre is, de pasztázás+ventilátor felszerelés sem segített.

Jaja, arra en is gondoltam.

Most azt vettem eszre, hogy a GLcore-t elobb probalta meg betolteni, mint a glx-et, es emiatt hianyolt valami glx kiterjeszteseket (EE). (Xorg.0.log) Megcsereltem a sorrendjuket a xorg.conf-ban, es a hibauzenet eltunt. Ezutan intenziven hasznalom majd par napig, es meglatjuk, hogy ez volt-e a baj.

nekem intel vga val csinálta.


Ha nem birod elolvasni akkor nem kell!


compaq deskpro p-866,512 ram,60gb hdd, Microsoft Windows XP Profesional SP3

OS: Dapper

VGA + driver:
root@alderaan:/home/trey/portal# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X700 Generic
OpenGL version string: 2.0.5814 (8.25.18)

Napi használat: 12-15 óra

Probléma: egy szál se

--
trey @ gépház

Már nyitottam erre én is egy témát, nálam egy IBM THinkPad X24-esen és egy X31-esen is csinálja úgy, ahogy a téma szerzője leírta. Van hogy fél óra múlva fagy le van hogy 6 óra használat után, és nálam is ablak műveletekre, vagy pl desktop váltásra, tipikusan mikor egérrel kattintgatok... Mióta kde-t használok meg QT-s cumókat (3 napja), azóta nem fagyott, de majd még meglátjuk...

Nálam wmaker és xfce-vel is csinálja, és mint írtam, csak azon a gépen, itthon nem.

detto. xfce
Szerintem ez valami alacsonyabb szintu cucc lehet, olyasmi, ami kozvetlenul a memoriaba ir, es ott valamit osszekever. Ezert gondoltam a direct renderingre (bar nem tudom, hogy pontosan mi az :). De elobb most megcsereltem a GLcore es a glx-et, aztan ha akkor is fagy, akkor majd kiszedem a drm-et.

De bakker ki kene talalni hogy mi az, mert allati ciki, hogy ugy fagy a linux, mint anno a 98.

nekem sima ati van nem fglrx, és avval csinálja :(

Nálam is lefagy folyamatosan a dapper tényleg az fglrx miatt lehet mert ha váltok drivert (vesa) akkor viszont semmi baja! Nálam már a telepítés is lefagyott mert a live cd belső ati drivere sem tetszett a kártyának, de aztán sikerült feltenni!

Az fglrx-et ki lehet zárni, mert nekem olyan nincs. Régi ATI kártya, és csak open driverrel megy. Még ma nem fagyott egyelőr

Sikerült esetleg valakinek már megtalálni a hiba okát mert baromi idegesítő ez a random lefagyás!

Nalam is fagyogat az ubuntu hasonlo tunetekkel az fglrx fennlete ota, (probaltam az ati oldalarol a binarisat is a helyzet ugyanez), van meg egy erdekes problema: az usb-s egerem valamilyen megfontolasbol csak ugy elmegy, a kovetkezo uzenettel:
"GlidePoint at isa 0060/serio4/input0 lost synchronization throwing 1 byte away."
\o/

udv

Sracok egy tuti nem ati a hibas
Sony VAIO VGN-FE11S nvidia go 7400, 2Gb DDR2 RAM inteles cucc duo core proci, szoval tok mas mint amit eddig irtatok, es ott is fagyizott ezerrel.
megoldasom az volt, hogy letoroltem. es visszaraktam eredeti windowst. az nem fagy, vmware player felrak, es pcbsd vmware iso hasznal :)

És ezt még le is írod? Én szégyellném magam :)

en nem... amugy is ez lett volna...
sajnos a programok amiket hasznalok windows ala vannak vagy osx alatt, de nincs macem, viszont unix manias vagyok, ezert van freebsd fent vmware-el mert akkor mindig hasznalhatom.

Jó, azzal nincs baj, csak ezt így megoldásnak nem nevezném.

Most nem mindegy, hogy milyen megbizhatatlan OS-t hasznal az ember?

Olvasd el, mit irtam. Nem az OS-sel van bajom, hanem azzal, hogy nem megoldast postolt a forumba. Szerintem meg lehet oldani a gondunkat (csak elobb tudni kene, hogy pontosan mi az). Az, hogy letorlom az OS-t es teszek helyere valami mast, az a problema megkerulese, de nem megoldasa. Igy mar remelem vilagos, hogy mit akartam mondani. Nem akarom, hogy OS flame legyen a forumbol, inkabb koncentraljunk a lenyegre!

Szerintem is koncentráljunk a lényegre :) Amúgy még mindig nem fagyott mióta kdm-et és kde-t használok csak qt-s cucokkal...

Nem tudom... akkor ezek szerint a desktop kornyezettel lenne a gond? de akkor miert van XFCE-vel meg GNOME-mal, sot wmakerrel is?

Én csak státusz riportolok :) Lehet hogy fél óra múlva lefagy... Amúgy meg lehet, hogy a gdm-el is gond van, gőzöm sincs :(

En eddig mindig upgradeltem a Hoary vagy Warty ota, minden nepszeru grafikus felulettel kiprobaltam es nem volt veluk gond. Aztan Dapperre valo upgrade ota jottek a problemak. Toroltem az egeszet, felraktam egy Breezy-t, majd azt upgradeltem. Akkor is jottek a gondok. Aztan mar csak Breezy-t, akkor is jottek a gondok. Lehet, hogy mar valahol itt el van rontva valami es azt viszik tovabb? Bevallom, kiserletezos tipus vagyok, tobbnyire meg is szoktam talalni a hibak okat, de sokkal tobb bosszusagot okozott mar idaig, mint oromot, ugyhogy hagyom a francba az egeszet (ezert is irtam korabban azt, amit).

nekem lenne 1 tippem a megoldásra:
azért csak tipp mert még csak pár napja nem fagy az ubuntu

xorg.conf:
dri modul kivétele
a nem használt két eszközt kivenni (a végén a serverlayoutból is)
maradtak a következők: egér, bill, videokártya és monitor
a másik kettőre már nem emlékszem h mi volt
!!a serverlayout után van egy olyasmi hogy "dri mode"(vagy fordítva) én azt úgy ahogy van kitöröltem !!
a videokártya driverét átírtam (nálam nv helyett nvidia és telepítve nvidia-glx csomag)

ezen kívül sztem érdemes még a legújabb ubuntu kernelre váltani, lehet az is segít a dolgon

ez csak az én tippem, mindenki saját felelősségére használja!

En az elejetol fogva valami ilyesmire gyanakodtam, hogy a direct rendering lesz a ludas.

Ha jol ertem, akkor a dri eleg szorosan osszefugg az openGL-lel, mert az X ezt hasznalja az ablakok megjelenitesere. Ahogy azt mar ketten is irtuk, a fagyas mindig ablakmuveletek kozben tortenik. Ahogy fent emlitettem, az en xorg.conf-omban volt egy glx-GLcore csere, es emiatt az openGL nem toltodott be rendesen (EE az Xorg.0.log-ban). Nem tudom, hogy mikor kerulhetett be a hiba, de lehet, hogy upgrade-kor. Vagy a Breezy nem volt ennyire erzekeny ra.

Miota helyes sorrendben vannak a modulok, azota meg nem volt fagyas. Ez egy estes intenziv ablakhasznalatot jelent :)

Akinek volt/van ilyen fagyasa, az meg tudna nezni, hogy rendesen betoltodik-e a GL?

Itt van ket ubuntu bug a temaban. Ugy latszik, hogy az illetoknek is ATI kartyajuk van. Bar ha jol emlekszem, valakinek volt itt nv is.

https://launchpad.net/distros/ubuntu/+bug/50687
https://launchpad.net/distros/ubuntu/+source/xserver-xorg-driver-ati/+bug/16873

Az elso eset gyakorlatilag ugyanaz, mint az egyem, es a sracnak szinten fel van cserelve a GLcore-glx a conf fajlban. A masodikban viszont nincs. Persze nem biztos, hogy ugyanaz a bug. Javasoljak, hogy a dri-t vegyuk ki a configbol, akkor nem fagy.

Egyebkent mar ket este telt el fagyas nelkul. De meg ez sem jelent semmit sajna.

Eddig ugy nez ki, hogy nalam a "dri"kiszedese, megoldott minden fenn emlitett problemat:)
De azert nyugtaval dicserjuk a napot...

udv.

ezek szerint akkor bugos a dri? Mert az ugye nem megoldas, hogy kiszedjuk. Pl a celestia meg a gogleearth eleg lassan futna nelkule...

Nos már majdnem egy hete ment fagyásnélkül a laptopom, viszont mikor elindítottam a gimp-et, egyből lefagyott, majd utána újra indítottam, és megint tettem egy próbát a gimp-el, és megint elhasalt...

memtest volt?

volt, nincs baj vele...

Eszembe jutott egy dolog: nekem bizonyos gtk2 témáktól történt még valahogy tavaly random fagyás. Nincs valami ilyen beállítva? Nekem ha jól rémlik az e17 volt, de akkor másról is olvastam.

Lehet, hogy az új Human thweme lesz a hibás?
Nekem például furcsa szineket vesznek fel a gombok néha, de fagyani azért nem fagy...

--
TheReplaced, Жизнь гладиатора - КОЛИЗЕЙ!

A fene tudja, lehet, bár én nem a default témát használom. Mindenesetre abban biztos vagyok, hogy legalább egy gtk2-s ablakkal piszkálódtam épp mindig, amikor megfagyott. Most adtam neki még egy esélyt, legfrissebb kernel ment fel úgyis, legacy driverrel, hátha. Ha fagy, teszek egy próbát az NvAGP opciókkal, aztán ha az se segít, várom a nyár végét, amikoris hozzák az új kártyát meg a sok RAMot :-).
szerk.: Fagyi volt kb 8 óra elteltével. Most "NvAGP" "1" opcióval megy, majd meglátjuk...

Hali!

Bocsi, hogy újra felvetem a témát, de sikerült már valami biztos megoldást találni a random fagyásokra! Már a Kubuntuval is megpróbáltam, de sajnos a Live CD is lefagy! Az Ati lehet a hibás, nekem egy Club3D Radeon 9700 pro kártyám van (Abit IS7-E lapon)!

Csak most találtam erre a témára, bár már indítotam egy másikat.

Nekem is fagyokat a kubuntu, de csak mióta felraktam a stabil verziót, a fejlesztőivel soha nem csinálta, frissítések után sem (kár, hogy újraraktam).

Nekem csak az X száll el, igaz egér, bill nem reagál.
Konzolról be tudok jelentkezni, kdm stop /start -al mehet tovább, bár a előző kdm-be futó alkalmazások nem álnak le.

A Xorg.log-ban ez van:
Fatal server error:
Caught signal 11. Server aborting

de bővebben: http://hup.hu/node/27750

Ápdét:
A glx modulok helyes sorrendben torteno betoltese nem oldotta meg a problemamat, mert egy het utan ujra lefagyott ugyanugy. A dri kivetelevel egyelore nem volt fagyas tobb mint egy hete. Szeretnek bugreportolni, de igy nem lehet, hogy fogalmam sincs, hogy mi a gond :-/ Azt megse mondhatom, hogy neha lefagy az X :)

Be tudsz lépni hálózatról? Meg kéne nézni a dmesg-ben mi van olyankor. Az alapján lehetne bugreportolni talán. Nekem egy "NVRM Xid..." kezdetű hiba ugrik elő a sorban, ebből azt sejtem, hogy xorg+nvidia driver+ez a kártya nem fér össze. Mivel otthon másik nvidia kártya, de ugyanez a driver és xorg verzió hiba nélkül megy, fogalmam sincs, hogyan tudnám bugreportolni...

Mar fent leirtam.

nekem is fagyogat az ubuntu, csak gondol 1et és csontrafagy.
igaz hogy az öcsém használja netezésre, de már panaszkodik, hogy megfagy, szóval ott tartok hogy visszacserélem debianra,mert a testing stabilabb mint a stabil ubuntu :D

Celeron-M 1400Mhz, 768M, Debian SID, 2.6.17

Nálam ez segített:

# /etc/X11/xorg.conf

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility M6 LY [Radeon Mobility 9000]"
Driver "ati"
BusID "PCI:1:0:0"
Option "RenderAccel" "off"
EndSection

Nekem VIA PN800 fagyott.
A megoldás az volt, hogy a 386- os stock kernelt raktam fel, ugyanis kikísérleteztem, hogy a gépemen csak 686 fagyott (K7- et nem probaltam, mert Intel procim van.), volt hogy fél órával indulás után, de máskor napokig nem kellett kikapcsolni a notit.. Most, pár verzióval később, újra tesztelem a 686 kernelt, eddig 5 óra uptime- nál tartok..

UPDATE: ~16 óra uptime.
UPDATE2: ~19 óra uptime

Szerintem kernel probléma van.
Nálam fagyott frissen forgatott 2.6-os kernel fagyott, ha P4-esre volt forgatva, atomstabil, ha a gyári (Mepis) 386-osra fordítottat használom.
Eleinte a HT-re gyanakodtam, azt kikapcsoltam biosból, de ezután egy 20GB-os másolásnál adta be a kulcsot (Frugalware-t azért kalapáltam le, mert az gyakorlatilag 10 perc alatt produkálta a fagyást, és használni akarom a gépem, nem reszelgetni [ezért lett mepis]).
Lehet hogy visszatérek Slackware-re + 2.4-re, ott sose volt random kemény fagyás...

Lehet, hogy végre képesek voltak javítani a bugot, bár nem akarom elkiabálni a dolgot.
Most itt tartok:
$ uptime
11:52:08 up 1 day, 15:55, 2 users, load average: 0.44, 0.42, 0.30

Ujabb fejlemenyek:
A fent elhangzott javaslatok kozul kiprobaltam kettot: letiltottam a dri modult az xorg.conf -ban, es felraktam a 386-os kernelt. Most kapaszkodjatok meg: ugyanugy fagy, mint elotte. Ritkan, de nem ritkabban. Tehat ezek a dolgok nem segitenek. Nalatok hogy all a dolog?

Akkor nem csak nekem fagy.NVIDA 6800 GT - NVIDA-legacy es ~5-10 percnel nem birja tovabb es csontra fagy halozatrol se lehet elerni.+ firefox is csontra szokta fagyasztani csak tudnam mert...
-------------------------------------------------
No Security in this Crazy World! by Hunger

Igy oldottam meg a fagyasokat, es a fentebb emlitett problemaim:
-ujraforgattam a kernelt, es a benne levo DRI -t kiszetódtem, modulkent sem maradt
-feltettem ati 8.27-es drivert
-aticonfig --initial --input=/etc/X11/xorg.conf
-rebut

viola, megy minden...

udv

Nálam akkor fagy az Ubuntu 6.06, amikor karakteres felületre váltok, és utána vissza a grafikus felületre. A kép felső része fekete színű lesz, és abszolút megáll a rendszer, hálózatról sem lehet belépni. Ezt leszámítva stabilan működik, random fagyás nincs.
Konfigom:
Intel 845PE chipset P4 1,8Ghz
(Asus) ATI Radeon 9550GE
Ubuntu 6.06 (kernel 2.6.15-26-686)
fglrx-ből pedig az ubuntu csomagja van.(8.25.18)

A fagyásról a /var/log/Xorg0.log a syslog, és még a messages is hallgat.

Egyéb ötlet, hogy hol keressem a hibát?
Előre is köszi

"Egyéb ötlet, hogy hol keressem a hibát?"
Ott hogy ATI Ragyidon kártyád van, és feltetted hozzá a gyári meghajtót. Nekem is csinálja. Vagy ez, vagy nincs 3D.

--
TheReplaced@Zenwalk - 540,000 Degrees Fahrenheit

Továbbra sincs javulás. Legújabb ötlet: hagyni Dappert a fenébe, és frissítettem Edgyre. Eddigi tapasztalatok:
- gyors indulás
- xserver nem indult -> újra kellett rakni, mert leszedte az xserver-xorg csomagot, nade legalább kis Debian-fíling, már kezdett unalmas lenni, hogy minden meg magától.
- Gyorsabbnak tünik
- 3 óráig nem fagyott. Ha majd ha 2 hét múlva se vindózkilencvennyolckodik, akkor talán elkezdek kicsit örülni. Nálatok?

Nem tudom, erdekel-e meg valakit a tema, de azert leirom. 2-3 het Edgy hasznalat utan, valamint 4-5 nap folyamatos hasznalat utan nem volt ujabb fagyas, tehat ugy tunik, hogy az upgrade nalam megoldotta a rejtelyes problemakat.

Persze az Dapper LTS kiadas, szoval attol a bugot bekuldtem, de szerintem nem adtak ki senkienk. Mondjuk sok infot nem is tudtam rola adni...

Szervusztok!
Sajnos kezdő vagyok lefagyások javításának terén is, ennek megfelelően nehéz eset is.

Megoldható az, hogy egy rendszeresen lefagyó linuxot megjavítson az ember fia?

Újonnan telepített Ubuntu 10.4-em, Lucid Lynx-em vagyon, már az NVIDIA saját meghajtóját is leszedtem, de a legváltozatosabb helyzetekben kegyetlenül cserbenhagy a rendszer.
Van hogy egyszerűen mc-ben egy könyvtárat akarok megnyitni egy külső adathordozón, van hogy bongészés közben. Ha új programot indítok el, és be akarom állítani, sokszor akkor is.
Fagyás után semmilyen gombot nem fogad el, sokszor az egér üzemel, és általában a háttérben mennek tovább az esetleges konzolos programok.

A hardver lenne a hibás? Vagy egy vagy több rossz csomag?
A hardver:
Alaplap ASUS P7H55-M Pro Intel H55, FSB1600 ATX
Processzor INTEL Core i3-530 2,93GHz
Memória 2 GB DDR3-1333 Kingston
VGA ASUS ENGT220/G/DI/1GD2(LP)
Ház Codegen M619-CA táp nélkül
Merevlemez Samsung 1 TB SATA2
Optikai megh. Samsung SH222A DVD-RW SATA

Hogyan tudnám meghatározni a hiba mibenlétét? Milyen fájlokat kell megvizsgálnom ehhez? Van esély javulásra, vagy kuka. Nagyon-nagyon sok időm ment már el a telepítésekre, de semmit sem ért az egész, ha ilyen abszolute megbízhatatlan a rendszer.
Röviden: rendesen el vagyok kenődve, és nagyon megköszönöm, ha tudtok irányt mutatni.
Va

Magic SysRq gombokra sem reagál?
http://en.wikipedia.org/wiki/Magic_SysRq_key
Nekem akkor csinált ilyesmit, amikor badsectoros volt egy vinyóm, de azt egyből látni a konzolra hányt hibaüzenetek miatt.
-------------------------------------------
Dell Vostro 1015 // Ubuntu 10.04 //

Futtass 1 memtestet! Próbáld az X-et sima vesa driverrel, és ha tudsz, próbálj ki 1 másik vga-t.
A tápodról nem írtál semmit, ugye nem Codegen?

> BERUS
Motor: Linux Mint - Isadora

Házikó: Codegen M619-CA táp nélkül
Tápegység: Coolink 400W
Köszi, a többit próbálgatom hamarosan.

Tudom hogy alapvető kérdés, de van a gnome-ban olyan rész, ahol grafikus módon át tudomvesá-ra állítani a grafikus meghajtót? Amit leltem a neten, az nemigen működött.

Fogalmam nincs...
Ubun mondjuk gnome-terminal -> sudo nano /etc/X11/xorg.conf -> Section "Device" -> Driver "nvidia helyett Driver "vesa" esteleg Driver "nv".

> BERUS
Motor: Debian/GNU Linux - Lenny

Más OS-sel csinálja?

Az Ubuntu elég khm "kísérleti" rendszer.

Hű azt nem próbáltam. Meg lehet azt nézni a mostani rendszer leszedése nélkül es?

Live CD, esetleg kölcsön/csere merevlemez.
De ha driver hiba van, arra nemnagyon lesz megoldás, az összes mainstream disztro hasonló kernel/Xorg verziókat használ.

nuvazze!
FreeNAS helyett valaki ezt a "kísérleti"-t ajánlotta szervernek - igaz, eddig jó volt a nyúzópróba alatt.

menjek vissza UHU 2.1-re? ott nincs lvm2! 3TB raid6 van nálam terítéken.

Remélem, grafikus felület, hangkártya és egyéb etvaszok nélkül nem lesz gond.

Olybá tűnik itt a nagyhalál. Következtessek arra, hogy a merevlemezem egy fontos része valószínűleg bekrepált? Remélem jól látható látható a ezen a képen.
Va

Miért pont erre következtetsz? Én ebből pl. arra következtetek, hogy eső lesz.

hogy jön ide a merevlemez bekrepálása?

Úgy hogy nem értek hozzá. :) Ezek szerint nagyon nem erről lenne szó? Friss live CD-t próbálok ma este vele. Ti estelge tudtok valamilyen meghatározott gondra következtetni ebből?

ebben nincsen semmi hiba, de a teljesen random fagyások szinte biztos, hogy hardverhibára utalnak. nincs esetleg valami rendszer a fagyésokban? valami konkrét művelet, amikor mindig megismételhetően lefagy? mert az lehetne bug... de ha teljesen random a dolog, akkor szerintem inkább hardverhiba, túlmelegedés, ilyesmi lehet. át kéne nyálazni a logokat fagyások után, hátha van valami infó.

Az a baj, hogy az ezen a képen látható képernyőkéen nem lép túl egy centit sem. Semmit sem csinál. Nem bútol tovább. De újra tudom indítani, az igaz. Tehát nem fagy le. Csak nem tudom használni.
Hol találom én ezeket a logokat? Egy fix könyvtárban gyűlnek?
Más események is gyanúsak. Alternate telepítővel próbáltam helyreállítani a rendszert, de a root fájlrendszer beállításánál bekrepált, azt írtqa, hogy nem tud valamilyen köteggel (dev/sd1 talán?) apcsolatot teremteni.
Nincs valami olyan program, ami a lemezterület sértetlenségét ellenőrzi? Az alternate lemezről amit néztem, az is elakadt egy hibánál. de ott valami ./ fájlról írt, amit nem tudtam értelmezni.

mikor megáll, át tudsz váltani egy konzolra? (például ctrl+alt+f1) ha igen, akkor nem fagyott le, csak nem indul el a grafikus felület.
logok a /var/log könyvtárban. ami érdekes az a syslog, dmesg, kern.log, Xorg.log, gdm.log.
lemez ellenőrzése: használd a lemez gyártója által biztosított (letölthető) tesztprogramot, az a legbiztosabb. (esetleges garanciális esetben is az a mérvadó) használható még ezen kívül a dd parancs, amivel végig lehet olvastatni a lemezt (pl.: 'dd if=/dev/sda of=/dev/null bs=256k'), vagy a smartmontools ('smartctl --test=long /dev/sda'), vagy a badblocks parancs.

Át tudok váltani konzolra.
És a konzolon futtattam az aptitude nevű programot, ami szépen leszedett sok általa szükségtelennek tartott programot (ami között volt olyan is, amire azért szükségem lenne, de sebaj, újratelepítem) és ezek után elindult. Gyanús volt ez ügyben egy glib ... nevű csomag.
Röviden, az el nem indulás rész rendbejött, bízom benne, hogy a fagyások is ritkulna, de egy lemezellenőrzést azért még csapok.
Nagyon köszönöm a hozzászólásaitokat!
Valek

semmi, sry. álmos vagyok

Nos. Nem volt nehéz újból lefagyasztani, és újraindítás után gyorsan a log fájlokat kiszedegettem. Nem nagyon mondanak nekem semmit sem mit érdemes figyelni, Ide tettem őket. Remélem hordoznak magukban adatokat.

Ezt a NOUVEAU drivert muszáj erőltetni, netán valami spéci kártyához kell?

Video driver?
Ilyen a videókártyám: ASUS ENGT220/G/DI/1GD2(LP) Szerintem ez nem spéci.
Nem tudom miért ez települt. Eleinte az NVIDIA driverét használtam, aztán leszedtem. VESÁ-ra kellene átállnom? Hogyan tudom én azt megtenni? Ubuntu 10.4.
Melyikből derül ki egyébként a driver mibenléte?
Va

Az Xorg old logjából. Ott látszik az is, hogy szoftveres a dri, mi halt le, stb.
Errefelé az Nvidia drivert dícsérik sokan, hogy az használható linuxon, szerintem azt kellene felraknod.
Mondjuk azt sem vágom, miért szerveres kernelt használsz, szóval érdekesen sikerült felraknod a 10.4-et imho.

A szerveres kernelt asszem én baltáztam el. Emiatt is lehet akár fagyás gondolom. Azt egy másik telepítésével simán meg tudom oldani, nem?
Viszont azzal az nvidia driverrel, amit a rendszer talált magának szintén szépen lefagyott az egész ugyanígy.
Talán a vesa driver segítene, ha tudnám hogy hogyan kell megétetni a rendszerrel. Merre keressek?

Ja, a generic kernelt felrakod és kész, de nem hiszem, hogy amiatt fagyna.
A vesa driver semmire sem jó, de ha ki akarod próbálni, akkor be kell írni az xorg.conf-ba a Section "Device" részhez, hogy Driver "vesa".

(http://ubuntu.hu/node/14890)

Nem látszik valami hardver gebasz?
Elnézést az alapok hiányáról tanúskodó kérdésért, de hiányoznak az alapok.
(Köszi szépen! Azért megnézem a vesát is. Baj tán nem leszen belőle.)

Nem láttam olyat, bár nem is néztem meg csak az Xorg logot.
Ott vannak ilyenek:

(II) AIGLX error: dlopen of /usr/lib/dri/nouveau_dri.so failed (/usr/lib/dri/nouveau_dri.so: cannot open shared object file: No such file or directory)
(II) AIGLX: reverting to software rendering
(II) AIGLX: Screen 0 is not DRI capable
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so

Meg a legvégén a Backtrace.
Hogy hardveresen szar e a videó vagy szoftveresen, azt passzolom innen, de tutira vga-xorg valami. IMHO!