Ha hangot akarsz a gépedből felejtsd el a Linuxot!

Fórumok

Korábban minden nap 2-3 órát tököltem azzal, hogy egy nforce2-es ac97 hangkártyát beállítsak suse 9.1 majd 9.3 linuxon.
Nem jött össze: 2ch hang volt meg clone a hátsókon, de nem 5.1! Feladtam.

Most vettem 1 új hangkártyát sb live 24bit, illetve már a suse 10 van fenn!

A helyzet nem változott, a linux megint csak kudarcot vallott, hiába az újabb verzió... nem bír megbírkózni egy 5.1-es hangkártyával...

Nem értem, hogy egy gf6600gt-t miért lehet 1 fájl futtatásával játékra bírni, közben egy hangkártyára meg rámegy a fél életem!!!

LINUX SUX

Igaz hogy a vinfos gyenge, de hardvertámogatásban a linux alulmúlja!

5 éve próbálok átállni linuxra, de az ilyen sz*rakodások mindig visszatántorítanak...

Akinek van működő megoldása sb live 24bitre, azt köszönettel veszem... ha akkor még lesz linuxom :(

Hozzászólások

HA HANGOT AKARSZ A GÉPEDBŐL FELEJTSD EL A LINUXOT!!!

lol

En sosem ertettem, hogy miert akar minden laikus atallni, mert a linux az trendi vagy mi, meg egyebkent is, sokkal jobban mutat. Ha ennyi raforditas mellett sem sikerult beloni, akkor fizesd meg a windowst, amihez az eszkoz gyartoja biztos megirta a drivert.
Nincs abban semmi, ha nem sikerul beloni, ne hasznald akkor.
Nezzuk csak. 5 ev... a windows xp home meg mittudomen 20-25k huf. Azt hiszem jobban megeri, ha megveszed.
Azt sem ertem, hogy miert sux a linux? (az mar masik kerdes, hogy tenyleg az vagy nem). Tru64, solaris, qnx meg anyamtyukja*unix is az mert nem tamogatja/nem tudsz valamit beloni? Sok hulye vilagvezeto ceg meg rabizza magat... ja.
A masik faszsagod pedig az hogy a windows jobb hardware tamogatasban. Nem jobb, lehet hogy egybol tudod hasznalni, de nem fogja 100% kihasznalni valoszinuleg vagy ugyanugy nem fogod tudni hasznalni mig nem rakod fel a hozzaadott drivereket. 100% akkor fogja kihasznalni, ha a cucc gyartoja altal kiadott drivereket/userspace utilokat felrakod. Az pedig nem a linux vagy mas hibaja, hogy csak windowsra fejlesztenek drivert. Oket kell szidni, nem pedig a linuxot vagy mast...

F@szert kell ilyen cimet adni a temanak???

Ez a Linux mindenaron mindenre eleve jo nagy bullshit.

Mellesleg az, h SUSE alatt nem megy, meg neked nem megy, kb semmit nem jelent.

Ket lehetoseg van:
- vagy olyasmit akarsz, ameddig a Linux eddig meg egyaltalan nem jutott el,
- vagy nem kerested eleget a megoldast, vagy esetleg nem tudtad megcsinalni.

You suck! ;-)

Itt szerintem nem hardvertámogatottságról van szó, hanem (amit deta is írt) nincs normális driver. amugy, nemtudom miket próbáltál, de nekem is nforce2-es alaplapim van, és egy sima _alsamixer_ beállítás volt az egész van (benne állítható 2-4-6channel)

PS.:persze linuxnak is kell az alaplap drivere...

waxy2 kicsit el vagy tevedve. A Windows azokat a hw-ket tamogatja amelyik gyartoja elkuldi a drivert az MS-nek.
A linux ennel tobbet. :) Csak kevesen kuldik el :P

Teny, hogy a Linux tudatos hardver vasarlasra keztet, de szvsz ezzel csak jol jar minden Linux felhazsnalo, fuggetlen attol, hogy olykor kenyelmetlenseget okoz.

Miért nem olyan kártyát vettél amiről tudtad, olvastad, hogy normálisan megy linux alatt.
Nekem sincs hang most ET alatt, pedig régebben volt, de sz@r ez a linux nem jegyzi meg a beállításaimat, ha új rendszert telepítek szűz vinyóra ;-)
Amúgy olvasok README, fórum meg etc. és kérdezek ha bajom van, nem pedig felhúzom magam, hogy ez se az se megy. Ha valami nem megy linux alatt és fontos akkor bebútolok win és megoldom, ha ott "egyből" és jobban megy. Ennyi meg egy bambi.
--
Slackware current mert az nekem jó...

nekem gond nelkul ment nforce2 ac97 5.1be. mondjuk az debian volt, de nem szamit. MENT.

Nem gagyi, sz*ros Soundblastert kell venni, nagyon egyszerű.

Hát, van jópár hangkártya, ami nem gagyi, lehet válogatni. Nekem eddig Linux alatt kifogástalanul ment a gépben:
- GUS Ace
- GUS Max (ráadásul ezeknél a báziscímet kézzel kell állítgatni!)
- Terratec Aureon Fun 5.1 (ennek gyönyörű hangja van)

Ami már kevésbé jó minőségű (zajos):
- GUS PnP
- VIA alaplapi AC97

Ráadásul ezeket mind OSS-szel használtam/használom, mert egy jól belakott rendszert nem volt kedvem fölrúgni és az ALSÁ-val pöcsölni. A Terratec kártyával zenét hallgatok csak egy szimpla sztereó erősítőn, nem használom térhatású üzemmódban.

VIA alaplapi AC97

Már megilyedtem, hogy nem sorolja fel senki. Nekem sima stereo headset van rákötve, mert annyira nem érdekel a multimédia, de azért zenét szoktam hallgatni, meg néha megnézek 1-1 filmet. Ja meg játékhoz azért jól jön... :) De hozzáteszem, hogy red hat 8 alatt nem sikerült belőni az akkori alsa-val... ;) FC4 már gond nélkül felismerte...

ööö szvsz az SB Live 5.1 (emu10k1) támogatottsága az egyik legjobb, de nem szóltam ¬_¬

nforce2 AC97hez meg van nyílt (ALSA/snd-intel8x0) és zárt (ld nvidia.com) driver is, MINDKETTŐVEL működik az 5.1, szal ekkora lamert mint ez még az életben nem láttam. Ill. láttam már, de még annak sem volt ekkora szája.
PP vigyázz, trónkövetelő ;)

Kerek 10 eve linuxozok, de meg eddig 1 hangkarival talalkoztam, ami nem szolalt meg (az is vmi hipergagyi vot).
/pill live 5.1 muzsikal a gepemben _5.1_-ben...
Szoval nem igazan ertelek...
Igaz nem german suzit hanem magyar bagolyt hasznalok, de szol.....
Ja, ot ev alatt ennyire nem eljutni.... akkor te nem is igazan foglalkoztal a dologgal...

PS: 1 szemelyes velemeny: aki linux alatt is a kattingatos qt eloteteket keresi 1 valami hardver, konfig beallitasara, az lehet tenyleg jobban jar windows-zal.... Konzol nelkul linuxot hasznalni keptelenseg.

Tibi

Tibi!

Ahogyan olvastalak, rögtön felderültem. 10 év linux és csak egy hangkártya ami nem ment, ráadásul baglyot használsz! :)

Szóval be kellene lőnöm egy Gravis ultrasound classic-ot. Még ISA és nem PNP. A címet jumperrel, viszont a többit (IRQ, DMA, stb.) szoftveresen lehet állítani, dos-ban volt még rá program. A lényeg, hogy már rábírtam a megszólalásra Bagoly alatt, csak éppen 2 mp után elkezd visítani és vinnyogni. elhallgattatni csak a gép kikapcsolásával lehet.

Kérlek segítsél, ha tudsz, hogy rendesen menjen a cucc. Ha még infóra van szükséged, küldök szívesen.

Czifi

Köszi a választ Tibi. Bagoly 1.2 van fent. Arra már rájöttem sok olvasgatás után, hogy ha én ezt a cuccot működésre akarom bírni, akkor bizony kézzel kell a megfelelő alsa modult betölteni. Na ez is meglenne, de mivel nem vagyok otthon, csak hétvégén tudom megnézni, hogy pontosan melyik modulokat töltögetem. Egy biztos, hogy a gusclassic köztük van. Ezt meg be kell paraméterezni rendesen, de csak a I/O címet tudom megadni neki pontosan, mert a többit nem lehet jumperrel beállítani, hanem állítólag szoftveresen megy. De fogalmam sincsen mi van most beállítva. :( Kb. találomra írogattam be értékeket (megnéztem a defaultot), meg is szólalat, de az előzőekben leírt jelenséget tapasztaltam.

Zsiráf! Köszi a linket, de azt hiszem ezen már túl vagyok. :(

Czifi

Nem ertelek... Nekem soha semmi bajom nem volt a Classik-okkal (ACE + 2-3 classic-ot nyuztam).

Az IO cimen kivul mast nem is kell beallitani... De ha akarsz, akkor arra figyelj (szerintem), hogy URES DMA-t es IRQ-t adj neki... Nem egeszseges, hogy ha tobb eszkoz hasznalja ISA eseten ugyanazt az IRQ-t. A legjobb, ha a BIOS ertesere adod, mely IRQ-t akarod az ISA-nak dedikalni. Megprobalhatod a COM2 IRQ-jat (mar ha nincs masodik COM portod -- tiltsd le a BIOS-ban...)

Ha kezzel kell a megfelelo ALSA modult betoltened, akkor valami nagyon el van kettyentve az UHU(d)-ban, talan untanna kene nezni valami alsa-conf -nak...

Zsiraf

p.s.: ha meg kerdezel, akkor az a minimum, hogy leird mit tettel eddig az ugy erdekeben... kulonben nem erdemelsz mast mint RTFM-et... :-) Bocsesz....

Köszi a választ Zsiraf!

Az UHU teljesen friss telepítés volt. Semmit sem állítottam benne. Mégsem ismerte fel. :(

Ezt a bios-os dolgot még megpróbálom. Tehát a lényeg, hogy kiválasztok egy jópofa irq-t és szépen beállítom. A classic meg majd kitalálja, hogy neki ezt szántam? Nem teljesen tiszta nekem a classicnál, hogy mikor pnp és mikor nem az. A leírásában (eredeti) az szerepel, hogy nem az.

Továbbiakat jövő héten tiudok. Addig is köszönöm.

Üdv.
Czifi

p.s.: Megértem, hogy linket küldtél, sőt vártam is. Ha egy olyan linket kapok, amit még nem olvastam és segít akkor annak örülök! Jelenleg csak tájékoztattalak, hogy ezt már speciel olvastam. :)

Sajnos a régi alaplapok nagyrészének bios-a nem tudott nem PnP kártyáknak IO címeket Irq és Dma csatornákat lefoglalni. Az összes új alaplap már tudja, de azokban már ISA busz nincs, legalábbis fizikailag.
Amikor egy rendszeren egyszerre vannak jelen pnp és non-pnp eszközök, abból sok irq dma ütközés adódik. Ki kellene próbálnod Dos alatt is a kártyádat. És megnézni ott milyen Irq és Dma értékekkel szólal meg.
Majd azokat beállítani linuxon is.

Khhmm.... Nem tudom milyen alaplapja van, mert termeszetesen nem kozolte velunk... (valoszinu van benne ISA slot is ha mar a kartyad bedugta)... A BIOS-nem is "foglal" le, csak ha ismeri a PnP-t akkor megprobalja a kartyakat ugy beprogramozni, hogy ne utkozzen... A problema akkor van, ha a gepen ul PnP es [b]nem PnP kartya... A Bios a PnP-krol tudja, hogy mit hasznal/hasznalhat de a nem PnP-krol egyaltalan nem... Illetve, ha te megmondod neki, akkor azokat kihagyja...

Na jo, a problema meg az is lehet, hogy a PCI/ISA megszakitasok khmm... altalaban ugy elnek egyutt, hogy a PCI az ISA-ra mappolodik, s ha tobb eszkoz hasznalja u.a. a megszakitast, es meg a te ISA-sod is u.a.-zt akarja hasznalni, akkor megszivtad...

A DOS-os reszt nem ertem, ha modulba vannak a dolgok, akkor rmmod / modprobe uj beallitasokkal, s vegigprobalgatja... Amugy a Linux PnP resze nem biztos, hogy UA a beallitasokat fogja megtenni, mind a BIOS.

Zsiraf

Pont ez irtam, ha a biosban nem lehet manuálisan lefoglalni a bejumperelt Irq stb. értékeket, akkor nem fug tudni róluk és simán kiosztja más PnP egységeknek. Az ily módon kialakuló Irq Dma megosztás pedig biztos, hogy működőképes eszközöket eredményez.
Dos-on azért érdemes kipróbálni, mert ott az eredeti Gus installal lehet tesztelni egyáltalán működni fog-e a kártya. Az ha jól emlékszem, addig próbálgatja autodetect-el a lehetőségeket még jó nem lesz. Igen, linux-on ettöl még nem biztos hogy jó lesz. A Gus tipikusan sok erőforrást szeret lefoglalni magának. Ráadásul Dos alatt sok alaplapi, vga stb. device nem is működik driver hijján. Ha ott sem megy a Gus akkor linux-on sem fog. Természetesen lehet modprobe rmmod-al is próbálgatni a lehetőségeket.

A GUS-on nem KELL! bejumperelni az IRQ/DMA ertekeket, mivel azt a szoftware tudja beallitani, tehat nem is erdemes lefoglalni.... A DOS meg azert nem jelent semmit, mer pl. ha az USB portjai vannak arra az IRQ-ra mappolva, amit a GUS-nak ad, akkor DOS alatt nem jon ra, hogy IRQ utkozes van...

Az eredeti GUS install NEM probalgatja, hanem beallitasz valamit o meg leteszteli.. szerencses esetben nem crash-el ossze :-) No de o is azt mondja, ilyenkor reboot oszt meg egyszer (ja a crash-es IRQ/DMA fail-nak van veve:-)

Azt a sok eroforrat nem ertettem... Boven megel egy IRQ/DMA parossal... csak akkor koll ket DMA, ha full-duplex szeretnel lenni... Memoriat nem ker, az van neki, processzort nem ker, az van neki, mi ebben a sok????

Azert azt szogezzuk le, a GUS megy Linux-on pont. A probalgatas arra vonatkozik, ha baratunk nem tudja a /proc/interrupts es a /proc/dma file-okbol kikeresni, hogy mi nem jo. Utanna nem probalkozni kell, hanem beallitani...

Zsiraf

Bocs Polesz, de ebben az esetben a legjobb olvasmany a GUS USER MANUAL :-) Mivel az jobban tudja, hogy mit tud a GUS es mit nem...

pl.: ftp://ftp.gravis.com/Public/Sound/Drivers/GUS&MAX/GUSMAN21.ZIP
(Ja, Word Perfect 6.0-ban van ;-), na jo, ha jol emlexem TXT-ben is megvolt meg talan Word2.0-ban is a driver floppy-kon)
A classic/ACE/MAX-hoz nem volt driver CD -- tudtommal, csak 6 floppy...

Zsiraf

Nekem is működik egy Gravis Ultrasound egy régebbi ISA PC-ben, amit pont A Gus miatt fogok megtartani. Igaz az PnP és így a dma irq beállításokat isapnp-vel kellett beállítani.
A te eseteben mindenképp Alsa drivert érdemes választani, amit egyébként Jaroslav Kysela eredetileg pont a Gravis Ultrasound kártyákhoz írt. Olyan jól sikerült, hogy ma már ez a standard hangdriver linuxon.
Mivel nem PnP kártyáról van szó valószínűleg az /etc/modules.conf-ban kell beállítanod a használni kívánt irq dma-t.
Itt találsz még infot a beállítással kapcsolatban:

1
2

ps. megvannak a driver floppy-k vagy install CD a Gravis Usound classicodhoz? Jól jönne nekem a doxbox-hoz, mert az csak a classik Gus-t emulálja.

Ismerem, ott kezdtem a keresést. Azok csak update-ek, ami a dos drivereket illeti. Ráadásul nem tartalmazzák a midi instrument fileokat sem, amitől igazán Garavis a gravis. Timidity-ből ugyan ki lehet szedni, az is Gus midi fileokat használ alapból, de már nem emlékszem hova kellene kézzel bepakolnom őket. Egyébkét is kell az updatenek az eredeti driver.

ps.: RTFTIFOFT
ps.2: Read The Fucking Txt Info Files On Ftpserver Too :-))

Bammeg... nem tudom miert toltom veled az idomet....

te olvastad azokat a kibaszott txt file-okat????



                  Advanced Gravis Computer Technology Ltd.

  Copyright (C) 1993,1994,1995 by Advanced Gravis Computer Technology Ltd.
                           All Rights Reserved
=================================================================

GUS411.ZIP is an upgrade from 3.5x to 4.11.   This upgrade requires the patch 
set from your original install disks.  If your original install version is 
not version 3.5 or better, you need the 6 files listed as GUS411A.ZIP through 
GUS411F.ZIP which is a full install set including patches.  

This file does not contain MIDI instrument patches which are required.
=================================================================


Ez szerinted mi a faszt jelent????

Ráadásul nem tartalmazzák a midi instrument fileokat sem, amitől igazán Garavis a gravis. Telleg???? Nem mondod... Amugy azokat a Gravis Patch-eknek hivta..

Amugy ja.. azok nincsenek ott:


...
 553		To work SoftOSS will require GUS compatible
 554		patch files to be installed on the system (in /dos/ultrasnd/midi). You
 555		can use the public domain MIDIA patchset available from several ftp
 556		sites.
 557	
 558	        ******************************************************************
 559		IMPORTANT NOTICE! The original patch set distributed with the Gravis 
 560		Ultrasound card is not in public domain (even though it's available from
 561		some FTP sites). You should contact Voice Crystal (www.voicecrystal.com)
 562		if you like to use these patches with SoftOSS included in OSS/Free.
 563	        ******************************************************************
...

(valahol az interneten :-))
Ha neked koll egy egyazegyben jo patchset talan nezd meg ezt..

http://www.anime.net/~goemon/timidity/goemon.tgz

Ha a "legjobb" patchset-et akarod akkor meg ez:

http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/eawpats12_full.tar…

S ha mar patch-ek, talan vess egy pillantast a

ftp://ftp.gravis.com/Public/Sound/Patches/ helyre. Itt van egy ket patchset-toredek...

Azutan itt is korulnezhetsz:
http://www.slackware.com/~alien/slackbuilds/TiMidity++/build/00README.s…

A freepatch-et is megnezheted: http://freepats.opensrc.org/
no meg ezt is: http://alsa.opensrc.org/index.php?page=FreePats

Zsiraf

p.s.: de jo voltam hozzad... Hmm.. Persze csak nosztalgiabol tettem...

Nagyon hálás vagyok, hogy ennyi időt szánsz rám. Bár írtam pár demot anno GUS-ra, talán képben vagyok a témában.
"This upgrade requires the patch set from your original install disks"
Ezen mit nem lehet érteni? Az upgradehez szükséges az patch set az eredeti install lemezekről. Nekem pont azok kellenek, az eredeti install lemezek. - Ha régebbi install lemezeid vannak akkor előbb kell 6 másik file is stb. -
A timidity-t is írtam fent így valószínűleg ismerem az gus-ra épülő eawpats-ot is. És szádékosan kerültem a Gravis Patch szó használatát, mert ez a szó unix környezetben már mást jelent, gondoltam egyeseknek zavaró lehet.
Nekem azért kell az eredeti install lemez, mert úgy egyszerűen megtudom milyen Gravis Patch fileokat kell a C:\ultrasnd\midi\ helyre tenni. A timidity alkönyvtárakba rendezi a pacth fileokat, a GUS nem úgy csinálta úgy emlékszem, régen volt már.

Zozo!

Az install CD-t le tudom másolni, vagy az ISO-t fel tudom tölteni neked, ahová akarod.

Köszönöm a segítséget. Az a helyzet, hogy sokat próbálkoztam, de nem sikerült eltalálnom még a helyes beállításokat. Ez egy DTK alaplap, van benne egy 466 MHz proci meg néhány isa slot is. A BIOS tudja a PnP-t így ki lehet vele jelölni néhány IRQ-t az ISA slotoknak.

Végigolvastam a fórumot és azt hiszem nekiállok az új infók birtokában továbbpróbálkozni.

Sajnos ahol a GUS van, ott nincs net, és fordítva. :(

Akkor pontositsunk egy kicsit... Mit akarsz te tulajdonkeppen?? Mar ha annyira kepbe vagy????
Mit varsz a GUS install-tol??? Ugyanis ha halvany emlekeim nem csalnak a setup util, a playfile, es a playmidin kivul, csak par emul TSR van a lemezeken.

Az upgrade meg olyan upgrade, hogy minden benne van termeszetesen, kiveve a patch-ek, mint ahogy irja is. Mivel a patch-eket nem upgradel-i. A patch-ek ugyanis mint mar fentebb ideztem nem a Gravis tulajdona, hanem az EYE&I Productions-tol licencelte anno egy patchset/kartya alapon. Ezert nincs benn az upgrade-ba, hiszen ha valakinek van kartyaja akkor mar megvan...
Persze ezel a Gravis se nagyon foglalkozott, ugyhogy sokaig toluk is le lehetett tolteni, dehat az ido mulasaval kisebb erdeklodes s gondolom helyhiany miatt kiirtottak az ftp szerverukrol (ja a teljes propatch set is fonnvolt anno... )

Ha patch-eket akarsz egyszeruen, akkor mint emlitettem toltsd le a http://www.anime.net/~goemon/timidity/goemon.tgz es masold a \ultrasnd\midi konyvtarba...

Ha régebbi install lemezeid vannak akkor előbb kell 6 másik file is stb. Igen a masik 6 "file" a hat lemez a patch-ekkel :-)

Amugy az, hogy milyen file-ok kellenek es hova az teljesen konfiguralhato (csak hogy felfrissitsem az emlekezetedet az otthonos temaban) a \ULRASND\MIDI\DEFAULT.CFG file-on keresztul:

# Release #3 05/05/93
# This is the default configuration file.  All lines beginning with a # are
# treated as comments.
# 
# This file contains a list of all of the intstruments and their program
# numbers that may be used to play a midi file.  Program #0 is the default
# instrument and must be in every configuration file even if the midi file
# doesn't use that program number.
# 
# Each line must have a program number, a space, and then the patch file name
# for that instrument.  Optionally, a volume number from 0 to 100 may follow,
# and then a detune number in semitones
#
# Revisions:
#           06/29/93 - #45 is now TREMSTR
0 acpiano
1 acpiano
...
127 applause
128 pistol
129-256 begin_multipatch default blank
        27 highq
        28 slap
        29 scratch1
        30 scratch2
...
        87 surdo2
end_multipatch

169 override_patch
        39 snare1 use_note 38
end_multipatch

Hmm.. Persze ez kisse munkas lehet, de hat a sikerert meg kell szenvedni. De barmilyen file-okat oda lehet tenni, csak a config-ba kell bejegyezni oket. Es kerdes, hogy a playmidin es a doom-on kivul, ki hasznalta?? ;-) Persze, lehet tobb config-ot is csinalni, ha jol emlekszem a playmidi a kovetkezokeppen dolgozott:
ha az adoott konyvtarban volt filename.cfg akkor az alapjan toltogette be a file-okat, ha az nem volt akkor a default.cfg talan a konyvtarban, vagy ha ez se volt akkor a MIDI konyvtarban levot...

Zsiraf

p.s.: szoval nyugodtan toltsd le az "upgrade"-et installd DosBox-ban. Ekkor mar latod a DEFAULT.CFG-t a MIDI konyvtarban... utana rakogathatod a patch-eket,irogathatod at a config-ot...

Ekkora egy f...t. Mi az istennek akar ez áttérni linuxra? Javaslom neki, hogy rakja át a winfosban egyik slotból a másikba az SB kártyáját, aztán fogok majd röhögni, mikor az "új eszközt megtalálja a winfos, de nem tudja felrakni a driverét, mert már egy "másik" eszköz használja. :)
Nálam Debianon soha semmi gond nem volt. Nekem nforce-os ASUS-os alaplapom van ac97-el és minden megy jól egy "next-next-next-finish" install után. Anyámék gépébe a winfos alá három napig küzdöttem bele az SB kártyát. A felénél olyan ideges lettem, hogy bebootoltam linuxba, hogy majd ott, de ott meg nem kellett semmit sem csinálnom, mert működött. A Sony-Ericsson telefonomat, ha bedugom az usb-re linux alatt jön minden szar fel (modem, usbstorage, digitalcamera, stb.), de winfos alatt két óra izzadás volt a saját cdjével beizzítani.
Szóval én most elkezdek nyavajogni, hogy a WINFOS SUX.
Ha valaki ennyire nagyon szerencsétlen, hogy öt év alatt eddig, jut inkább ne akarjon áttérni. Én nem is értem minek próbálkozik. Én sem próbálkozom a winfossal.

Én sem értem mit szenved szegény ember.

SuSE 9.0 alatt simán működött az Nvidia SoundStorm 2. Nem volt vele problémám. Amikor átálltam SoundBlaster Audigy 2 ZS-re, egy kattintás volt a telepítés (az is csak egy üzenet volt, hogy az új hangkártya telepítve van). Szépen fut klón módban azoknál a programoknál, amelyek sztereo kimenetet adnak, amelyek meg többet adnak ki magukból ott szépen szétválasztódnak a csatornak, megy 4.1-ben és 5.1-ben is. Szóval nem értem a problémát.
Vagy lehet hogy neki is megy, csak sztereo kimenetű programokkal próbálkozik, és ezért nem veszi észre?

Igazán nem értem miért kell folyton felvenni a kesztyűt, amikor világosan olvasható, hogy az illető csak szidni jött a linuxot. Nem kérdezett semmit, távozott. Egymásnak igazoljátok azt, ami nektek egyértelmű.
(p.s.: Én is csak tódítottam rajta egyet.)

Hat mar ne is haragudj, en pl 5.1 es hanggal nezem a filmeket, es DTs muzsikat hallgatok debian alol, es knoppix Live alol is.SB live 5.1 es hangkartyaval digitalis kimeneten. Hasznalj ALSA-t es olvass utana mielott hulysegeket irsz!

Hát, nem is tudom... kb 50 gépet üzemeltetek linuxal, telefonos callcenter központban. Asterisk-el megy a telefon ISDN kártyával, és Plantronics USB headsettel. Jelenleg 2.4-es kernellel, ja és a kliensgépeken a megbízó kívánságára nem használunk egereket. Az össz probléma, ami fellép, hogy a gyakori kikapcsolgatások miatt (nem tudom erről leszoktatni a csajokat) időnként reggelente néhány gépen helyre kell tenni az ext2 filesystemet.
Na most képzeljétek el , ha mindezt Winxp alatt kellett volna megcsinálnom.... Vajon hány szervizest kellene (rajtam kívül) foglalkoztatni még ehhez az 50 géphez? :)

Nem vagyok akkora cybergyerek, hogy nálam az 5 év napi 24 órában a linuxot jelentse. De tény, hogy kb. 5 éve raktam fel az első linuxot a gépemre, akkor néhány YaST-os beállításnál hülyére fagyott a gépem, akkor azt mondtam, hogy köszönöm nem kérem, fagyogató op. rendszerből van már 1. Aztán később egy újabb SuSe változatot próbáltam meg és az sem volt ok, telepítés után a grafikus felület a kezdő felhasználó számára tabu maradt.

Azt gondoltam, hogy talán fejlődik az évek során a (SuSe) linux annyit, hogy a legtöbb gépben már helyet kapó alap hardvereket támogatja (nem fűnyíróra gondolok, hanem vga, lan, snd, semmi több), ezért feltettem a 9.1-et majd a 9.3-at, de sajna tévedtem.

A kérdésem még mindig az, hogy HA a vga-nál meglehet 1xűen oldani a telepítést, akkor miért kell vért izzadni egy (vagy 2) hangkártyánál???

Aki veszi a fáradságot, hogy összehasonlítja, mit kell csinálni a 6600gt-m beállításához és mit az sblive24bit-hez, az tudja mire gondolok.

Rendben, tudomásul veszem, hogy nem minden hardver megy minden disztron. Mivel én már csak ilyen f@sz vagyok, hogy linuxot akarok, ezért mondjátok meg, hogy ahhoz hogy hangja legyen a gépemnek linux alatt:
- melyik disztrot használjam és/vagy
- melyik hangkártyát vegyem meg?

Nem nagyon érdekel, hogy nagy cégek repülőgépet, vagy atomerőművet működtetnek-e *n*x rendszereken, én csupán zenét akarok hallgatni, és néha játszani az ET-val. Az viszont kizárt dolog, hogy én a billy fiúnak jattoljak.

Senki nem faszozott le. Csak kicsit csúnya dolog suxolni egy os-t, mert egy distro és a Te együttlétedből nem jön hang. Szerintem nem nagy jatt a billy fiúnak az a 30ezer azér, ha ennyire akarsz zenét hallgatni meg játszani.
Az 5 éve felraktam a linuxot nem jelenti azt hogy öt éve foglalkozol a linux-szal. Pláne, hogy nagy kitartással viseltettél iránta és kiakasztottad a guglit a sok kereséssel.
Az évek során annyira fejlődött a linux (és nem a suse, ami ugye egy a megszámlálhatatlan dsitro közül), hogy még a kenyérpirítómat is rábízhatom, lásd fentebb a mobilom történetét.
A VGA-d telepítése pedig semmiben nem különbözik a hangókártyáétól. Csinál kernelmodult, meg X modult, aztán bemásolja ahova kell. A hangkártyadriverekkel ugyanez a helyzet. De a legtöbb alapban bent van a kernelben. És ez nem azt jelenti, hogy mindegyik gyártó xy terméke, ahnem az a sok chipset amit ezek használnak atermékeikben. Ezért sem kell drivereket telepíteni, mint a win esetében ha ugyanaz a chipset, de más a gyártó meg a neve. Aztán fölrakja ugyanazut a hülye, mert az ini-jében vagy hol, máshogy hívják.
Hidd el felmegy az a hangkártya suse-ra is. Valószínüleg valamilyen modult nem tölt be induláskor. Az SB-nél egész sok minden van, meg az alsa-nál is, amire figyelni kell. Csak mondjuk az ide irogatás helyett el kellene menni a suse-s fórumra, meg használni kellene a guglit.
Ide már azzal kell jönni, hogy minden okés a fórum alapján, csak azt mondja a kernelmodul betöltésekor hogy "ide meg leírod mit is mond". Mert a sok olvasástól, már tudod, hogy hogy működik, hogy mi az a kernelmodul, meg hasonlók. Fel tudsz tenni kérdéseket suxolás helyett.
Én sem suxoltam volna a winfost amúgy ha Te nem teszed. Én bevallom, hogy fingom sincs hozzá. A feleségemet szoktam megkérni, hogy ha valami nem megy, mert még ő is jobban ért hozzá, mint én. Ettől még nem mondom hogy teljesen használhatatlan, mert játszani lehet vele (ha az asszony segít elindítani :) ).

Na fígyú autóápoló (Wax) én egy diflexiás horvátanyanyelvű hűtőgépész vagyok és csak a magyar oldalakon edig mindig kaptam terméktámogatást a közöségtől. Nekem egy Nforce 3 -as alaplapom van 64 bites gépel. Van webkamerám 2 nyomtatóm és egy lapolvasóm 1 hálókártyám plusz az alaplapí hálókártyám, Valamint az alaplapí 8 csatornáshangkártyán kivűl még egy 5.1 -es, igaz nem egy atom szuper hanem egy gagyi amit digitalizálásra vetem és azthitem előszőr hogy sima (2000HF). A Nevre winter nights al szoktam néha játszani. Egész királymodon lehet hallani amikor oldalról vagy hátúlról lopakodik valki.

Ezt mind beűzemeltem. Google és fórumok segítségével. Mint írtam nem Cyber programozó hanem hűtőgépszerelő szakmunkás vagyok.

3 év elég volt nekem a dolgokra.

1. Kérdezni tudni kell.

2. Probállj ki minél több LŰinuxdisztribuciót. Más megközelítésből látod a feladatot.

3 IQ-t nem tudunk adni, csak biztatni ha tanúlsz legalább nemhalszmeg hűlyén. A legtőbb valás a tanúlásí folyamatokról szól.

4 töltsd le a www.nvidia.com ról az nforce 2 driverjét és telepítsd majd használd az alaplapí kártyát.

A fent leírtak nem a közöség hanem az én gondolataimat véleményemet tartalmaza.

A kritika jóbító szándékal érted és nem ellened szűletet. Ha nem tudsz a Linuxal mit kezdeni lehet te magad nem vagy Linuxkompatíbilis.

Egy előadáson azt mondták tökéletes program nincsen, sőt tökéletes programcsomag sincsen! Viszont van olyan egy adott csoport számára az elfogadhatóságiküszöbön lévő programcsomag. Tőbb programcsomag felhasználó csoport létezik. Vannak nagy csoportok pl. Unix szerű és nem Unix szerű. Van Gnome és KDE valamint Xfce és még sorolni lehetne.

Keresdmeg melyik csoporthozz tartozol keresd meg azt amelyik olyan mintha neked írtákvolna nem vagyunk egyformák.

Űdvőzlettel Joco a Hűtőgépház ból.

Ja és A'rpi nicjét ne használd mert rengeteg Mediapleyer rajongó olvasa hup-ot.

3 IQ-t nem tudunk adni, csak biztatni ha tanúlsz legalább nemhalszmeg hűlyén. A legtőbb valás a tanúlásí folyamatokról szól.

fígyú, edig, közöségtől, gépel, alaplapí, kivűl, vetem, azthitem, előszőr, hátúlról, beűzemeltem, tanúlsz, hűlyén, legtőbb, tanúlásí, jobító, ... meguntam.

A lista idaig: valami gagyi ess, utanna egy AWE32 -> alaplap csere no isa -> VIA AC3, utanna LIVE 5.1 mind csont nelkul. most is azt halgatom :)
A hiba nalad van nem az OS-sel, a forumindito cimre pedig van egy jo tanacsom, ha legkozelebb elakadsz akkor azt ird pl: ez a disztrib alatt ezzel meg azzal van problemam, valaki segitsen pls.

Egy dologra nem találtam választ se a hozzászólásodban, se a témaindításban.
Miért szeretnél linuxot használni?

Tényleg kíváncsi vagyok, és nem arra, hogy a win fizetős és csak azért sem fizetem ki, utálom Bill Gates-t, meg a rendszert. Ez szerintem olyan menő szöveg.
Ha itt nem priv. is válaszolhatsz :)

Bátyám mindig is linuxos volt.....ezért kicsi koromtól kezdve láttam a "jó" példát!
Csak azt láttam hogy gyors és nincs vírus, ingyenes....ezek télleg tetszettek.

Ugyanakkor abban az időben csak a játékok érdekeltek, ezért nem igazán vonzott a téma....nomeg nehének is tünt......

Ennyi káb a háttere.....a linuxos érdeklődésemnek....

Most pedig szeretnék minél ügyesebb lenni a témában....csak kevés rá az időm, ezért amit megtanulok hamar el is felejtem, mert nem hasnzálom

ezért kérdezek sokat.... :D

meg a solaris-t, meg a plan9-et, meg sorolhatnad sokaig...
ennek nincs kozossegi informacio tartalma

sok minden van amiben a linux most mar jobb mint a windows
(a 3.51 NT kernel thread schedulere peldaul messze felulperformalta az akkor linux utemezot, de persze azt igazi programozo irta)
ha ezeket a jobb tulajdonsagokat nem veszed eszre/nem hasznalod, akkor nincs ra szukseged

ha lusta vagy (mint en) akkor veszel egy laptop-ot rajta gyari windows es az asztalon ott hibernalod, ha megis windows kell

amugy nekem forditott tapasztalatom van: egy elektromosvilagbol vasarolt (gagyi: C-Media Electronics Inc CM8738) a windows driver-rel csak 2 hangszorot kepes hasznalni akarhogy pocogtetem az amugy impressziv hifi rack-re hajazo userinterface-t amit a gyarto adott hozza megsem meyg, mig a linux (2.4.31 slackware10.2.0) siman hasznalja kapcsolgatja alsaconf-fal vagy a kde mixer-rel
mas kerdes, hogy se a windows, se a linux nem kepes a mikrofon jack-et bemenette tenni :)
de erre van a laptop amin megy a skype, SD kartya olvaso, DVD iro... ha eppen kell

"sok minden van amiben a linux most mar jobb mint a windows
(a 3.51 NT kernel thread schedulere peldaul messze felulperformalta az akkor linux utemezot, de persze azt igazi programozo irta)"

jah, anno ezert egy darabig a kernel+gcc fiuk kicsit szorosabban dolgoztak, hogy gyorsuljon a dolog. a verseny jo.

Elég szánalmas ez a hiszti. Barátnőm öccse egyedül, segítség és angoltudás nélkül felrakta a SuSE-t, és azóta legfeljebb olyan kérdései vannak, hogy "erre a feladatra melyik programot érdemes használni?", vagy "melyik forrást kell ehhez megadni" szóval ilyen egy-két mondatos, telefonon elhadart segítségekkel is tökéletes elvan. Tizenkét éves a srác.

Amennyire én tudom, nem volt vele különösebb gondja, egyedül az nvidia-t kellett kicsit hegeszteni. Gagyi MX 440-ese van, aminek szar a supportja, és kicsit erőltetni kell a YaST2-ben, mire rendesen hajlandó működtetni. Én az ugyanilyen kártyámnál nem is erőltettem, úgy sem játszom, inkább (nv) driverrel hajtom. Nem tudom, pontosan hogyan oldotta meg, én akkor épp záróvizsgára tanultam ezerrel, ezért nem tudtam ezzel foglalkozni. Kicsit küzdött vele, és most megy rendesen neki.

Mással nem igazán volt gondja, inkább csak apróságok, de megoldotta őket. Nem kellett nagyon varázsolnia a srácnak, sőt, valójában még soha nem volt ilyen stabilan működő rendszere, pedig ugye "előbb klikkel-aztán olvas" típusú user, mint általában a 12 évesek...

Most csak azt kérném katintsatok a topoknyító nicjére és egy lekövetést kérjetek az általa inditot topicokról. Anyiban kamúzót, hogy 5 éve mindenesetre több mint 40 hete ezel görcsől és ez itt a hupon dokumentálva van.

Joco te hogy tanultad meg a linuxot? Értelmezd már légyszives az írásomat, ha közben figyeltél, hogy hozzászólok néha... ezen az öt éven vagy fennakadva... pedig világosan leírtam, hogy akkor raktam fel először linuxot a gépemre, de akkor még idáig sem juttottam, hogy a hanggal legyen bajom, mert lefagyott az a sz@r.

Elolvastam az ajánlott "A Linux nem Windows" c. cikket, egyetértek vele, de: ha arról van szó, hogy a linuxnál azt kell megtanulni, hogy mit csinálok, nem azt mint a winfosnál, hogy hogyan csinálom, anélkül hogy tudnám mit csinálok, akkor miért érzem mégis ezt minden leírás olvasásánál: le van írva hogyan csináljam, de hogy mit csinálok, arról egy szó sincs!!!

Ezek a leírások 100%-osan csak azoknak érthetők akik már értenek a linuxhoz, de azoknak meg már minek... ("hogyan"-oknak hívják őket és nem "miért"-eknek)

Az a kevés iq-m ami meg van az ahhoz volt eddig elég, hogy azokat a dolgokat, ahol szerencsém volt és szó szerint egyeztek a történések a leírással megoldottam. De most is az alsa oldalán lévő leírás szerint próbálnám felrakni az újabb drivert (mert UHU-ra cseréltem a SuSe-t, de ez odáig sem jutott, hogy rájöjjön, hogy van hangkártyám!!! a nyomorult), de elakadok ezzel:

/usr/src/alsa/alsa-driver-1.0.11rc3/acore/rawmidi.c:48: error: initializer element is not constant
/usr/src/alsa/alsa-driver-1.0.11rc3/acore/rawmidi.c:48: error: (near initialization for `__param_arr_midi_map.num')
/usr/src/alsa/alsa-driver-1.0.11rc3/acore/rawmidi.c:50: error: initializer element is not constant
/usr/src/alsa/alsa-driver-1.0.11rc3/acore/rawmidi.c:50: error: (near initialization for `__param_arr_amidi_map.num')
make[4]: *** [/usr/src/alsa/alsa-driver-1.0.11rc3/acore/rawmidi.o] Error 1
make[3]: *** [/usr/src/alsa/alsa-driver-1.0.11rc3/acore] Error 2
make[2]: *** [_module_/usr/src/alsa/alsa-driver-1.0.11rc3] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.9-19'
make: *** [compile] Error 2

(szóval így görcsölök 43 hete... Egyébként erre meg hogy keressek a google-n?! vazze')

(szóval így görcsölök 43 hete... Egyébként erre meg hogy keressek a google-n?! vazze')

arcbol egy kicsit vissza kene venni...
google bolond ! be ne masolj valamit a hibauzenetbol, mert hazavagja a rendszeredet !
gondolom ez mar megvolt:
Advanced Linux Sound Architecture - Sound Blaster Live 5.1. emu10k1 [ alsa-project.org ]

A legutobbi szivasom egy notebook hangrendszerevel volt, a sajatommal (Neomagic Magicmedia 256), de egy keves RTFM utan megtanultam beuzemelni azt is. Elso rendben csak OSS/Linux-szal ment, es nagyon meguntam, hogy indulaskor kiir egy csomo rizsat, hogy regisztralj, hanem 4 honapig hasznalhatod ingyert. Majd kicsit tobb RTFM utan sikerult meginditani az OSS/Free ad1848 modullal. Eredetileg kellett volna menjen snd-cs4232-vel, de valamiert nem tolti be nekem a modult. Letezik snd-nm256 is, de az en lapimmal hala Istennek nem mukodik, mert nem ugy hasznalja a chipet, ahogy kellene, elvileg kellene egy codec chip melle, hogy tudjon menni. Amugy a chip egy erdekes darab, laptopokban lattam csak, egyben egy 2.5 MB-os videochip es hangchip. Eleg ahhoz, hogy 1024x768-ban DivX-et nezzen az ember, de ebben ki is merulnek a kepessegei.
---
Hey! Where'd my terminal go?

"A helyzet nem változott, a linux megint csak kudarcot vallott, hiába az újabb verzió... nem bír megbírkózni egy 5.1-es hangkártyával..."
Talan Te vallottal kudarcot es nem birsz megbirkozni _egy_ 5.1-es hangkartyaval ?

Nem az 5 éven vagyok fent akadva, hanem azon valaki idejár 43 hete és még nem kapot választ a hangkártyakérdésre. Olvasd el a hackerhowtot.
Ott leírják ,hogy kell kérdezni ahozz ,hogy a közöség értelmesen válaszóljon. Nekem anyi szerencsém azért akadt értek kicsit a dos hoz és ahoz viszonyitotam nem a prozor hoz.

>> Ha hangot akarsz a gépedből felejtsd el a Linuxot!
így van, tökéletesen elég ha beruházol egy olcsó tápra

Ha hulye vagy hozza bazdmeg akkor nem kell hasznalni te divatmajom idiota balfasz!

synapse

Nekem is problémám van az alaplapi hangkártyámmal. A mély hangok nagyon torzak. Lehet ez beállítási probléma?

/Annyit még szeretnék hozzátenni a topichoz, hogy a linux tényleg nem amatőröknek való, mint én is vagyok :) ! Bár az biztos, hogy sok tekintetben sokkal használhatóbb mint a Windows (jómagam nem vagyok feladni a játékaimat szóval amíg fel nem növök, marad midkettő :)] Szóval kedves waxy2, ha DVDzni akarsz egy 70 másodperces rebootal kel számolnod :P/

Sziasztok!

Azt hiszem hasonló a problémám mint a topic indítójának......
Van egy ASUS A7N8X-E DELUX alaplapom....integrált hangkártyával......
Kubuntut használok........

A filmek és a zene rendelkezik hanggal, de a játék alatt nem megy......
ha az még ad támpontot akkor egy Genius Home Theater SW 5.1-em van (csak azért jelzem mert tudom hogy ez a cucc sok problémát szokott okozni....bár nem hisszem hogy itt ez lenne a gond)

Szóval ha van valami tipp akkor légyszíves............előre is kösz
Ha lehet akkor egyszerűen, mert nem szeretnék kernelt forgatni és más hasonló nyalánkságokat.....

Köszi

Rossz topicba írtad, mert ez egy FUD téma :)

Különben a "játék" (gondolom Q3 vagy ilyesmi) valószínűleg nem éri el a kártyát, mivel valami lefoglalja (gyakori gond az elavult OSS-t használó programoknál).
Ha KDE-d van, akkor artsdsp-vel, ha Gnome-od, esddsp-vel indítsd:

artsdsp /ahova/telepitetted/jatek_indito_binarisa

Akkor amit az elozobe akartam meg upgradelni:

"Es? Az csak egy API. Amugy azert irjak OSS-re, mert azt a legeccerubb hasznlani, nem kell kulso lib, ami - szokas szerint - minden major verzioban szokas szerint valtozo API-t implemental... "

---
pontscho / fresh!mindworkz

Valószínűleg az asztali hangdaemon (mivel a zene, film megy rendesen), azzal meg sokat nem tud csinálni, ha kiirtja, ugyanott van, vagy inkább még hátrébb...

A valódi megoldást a sw-fejlesztőknek kéne végre meglépniük:
1. normális sw mixer ALSA-ba amin az OSS emulátor is átmegy, gondolom nem egyszerű, ezért kell a dsp wrapper...
2. ALSA vagy legalább SDL support a játékokba, ez a legelőnyösebb...

Ha egy program többplatformos, akkor el kéne felejteni az elavult/platformfüggő komponenseket (pl OSS), tessék SDL-t használni.

Ha egy program linux-only (mint pl. egy zárt forrású játék), akkor szintén el kéne felejteni az OSS-t, már régóta az ALSA az alap és a támogatott a kernelben (az OSS obsolete, ha egyátalán még bennvan).

"a linux megint csak kudarcot vallott, hiába az újabb verzió..."

ocsem, te olyan hulye vagy, hogy faj. Fizessel a szaros windowsodert, ha akarsz supportot, vagy esetleg beszeld ra a gyartot, hogy adja ki a hardware leirasat. Amig ezek nincsenek meg, addig ne a linuxot fikazzad, mert nem tehet rola.

synapse

Nekem a hangkari belövése KB. enyi volt.
# alsaconf
sok enter és kész.
(mind a két kártyám, talán egy 2-est befirkáltam valahova)

Bezzeg a régi szép időkben, mennyit lehetett tökölni az isapnp -vel, és testvéreivel.
Kicsit csalódott voltam, hogy rögtön ment. :)
------
gentóhuszár

Hogy fejlodott-e a linux?Es sux?Muszaj leirnom. Anno 7 evvel ezelott feltelepitettem a pcworld cd mellekletet suse 6.4-et. Egy hetig ultem a gep elott mire bellitottam a grafikus feluletet. Tovabbi 1 het volt mire kicsikartam a hangot abbol a sz@r ESS1868-bol mert ha jol emlekszem a kernel (2.2.14) meg akkor nem tartalmazta hozza a drivert. ALSA-t kellett forditanom hozza. Persze mindezt total kezdokent, es talan meg konnybe is labadt a szemem hogy megszolalt. De addig b@sztam a rezet mig meg nem csinaltam, mert hajtott a kivancsisag.Most beteszem az Ubuntu CD-t 6 klikk, es fenn van, van hang, jol van beallitva a grafikus felulet. Huh. Barmelyik friss linux disztribucioval nem sikerul megszolaltatnia valakinek a hangcsipjet, hat annak en sem tudom javasolni ezt a sux oprendszert.

Ja, az volt nekem is, voodoo3 2000, meg van meg ma is. Ma egy letunt kor emlekeztetojekent orzom. Valoban, nem volt egyszeru a quake 2-t opengl-ben jatszani vele, pedig ugymond kernel szinten "supported" volt.

Miért pont 9.1 / 9.3 ?
Én az SB kártyákkal soha nem szívtam - mondjuk nem is használtam SuSE-t soha; az viszont elég hihetetlen, hogy nem tudsz 5 év alatt belőni egy hangkártyát sem.
Nekem a cémédia négypontegyes hangkártya is valamiért pöccre megy UHU -n, minden csatornán. Tudom, fujj UHU...

--
//:wladek's world

Nem tudom miért bántotta szegényt mindenki. Szerintem teljesen jól csinálta. Nekem senki nem válaszolt, neki egyből egy egész fórum :) Következőre én is így csinálom :)