[MEGOLDVA] Centos 7 vs. hpvsa b120i érdekesség

Fórumok

***UPDATE***

Akit esetleg még érint.

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_fc9cb2b56d8…

Közben megérkezett nagynehezen. Bár a HP yum repokba még nem látom.
Időm még nem volt letesztelni. Majd 2018ban :)

***UPDATE***

Nos, adott egy sima egyszerű HP Proliant szerver, b120i -s vezérlővel.

Centos 7 rajta, HPVSA modullal hajtva.

Eddig nem is lenne gond. A vezérlő csodásan működik, toolal lekérdezhet, status ok, stb.

Viszont, ilyesmi fogad reboot után:

https://tardis.hu/le/centos_hpvsa_stop.jpg

Ami érdekesség, hogy

kernel-3.10.0-693.2.2.el7.x86_64
kernel-3.10.0-514.26.2.el7.x86_64

A -514-es kernel verzióval teljesen jól elindul minden. Viszont amint a -693-as kernel szeretne betöltődni a fenti "kép" fogad.

Ötlet? szaladt bele valaki ilyesmibe ?

(btw HP yum repok berakva, nincs újabb hpvsa driver HP oldalról)

Előre is kösz :)

Hozzászólások

Nem HP fuggo. Torold le a kernelt es tedd ujra vagyujabbat. Dell perc h330 is csinalt ilyesmit.

Hát meg lehet próbálni :) Bár ugye ez "stock-kernel" by centos. (még csak nem is centosplusból való)

Amit nem értek, hogy itt ugye main kernel verzió váltás nem igazán történt. Vajon mi mászhatott félre a két kernel esetében? Ugyan az a major.minor verzió, csak épp a centos féle -release szám változott. Bár lehet át kellene böngésznem a changelogot ehhez a csomaghoz, hogy ugyan milyen patch került be, ami ilyesmit okozhat.

hpvsa driver meg ugye by-default nem forgatható újra, mivel azt a hp szállítja :)

Egyelőre még tanakodom mi legyen. Azt lehet marad a -5XX szériás kernel és csókolom.

CentOS az hogy main kernel csak egy kifejezés.

Backportok miatt egyre kevesebb köze van a megadott számú kernelhez, és sajna éppen emiatt előferdülnek ilyen gondok.

Én és jártam már így CentOS 6, egy kernel frissitíés után a régi dell perc5 vagy perc6 pár perc után kernel pánikolt. Először azt hittem megadta magát a vezérlő. El is kezdték kutatni az utódját, közbe bootoltam a régebbi kernellel. Azóta is inkább azzal megy :D

Fedora 26, Thinkpad x220

Na ja, itt is valami hasonló lehet. A legfrissebb HP driver rhel7u3 (azaz 7.3 -as) ezáltal centos 7.3 -as. Abban még az -5xx kernel volt. Egy HP support ticketet lehet ellövök azért, hogy tervezik-e u4 -es driver kiadását, vagy hagyjam a francba :)

Azért köszi mindenkinek a válaszokat!

btw, csak egy kis extra infónak + selfnote.

https://community.hpe.com/t5/ProLiant-Servers-ML-DL-SL/Drivers-for-B120…

https://bugs.centos.org/view.php?id=13943

Mondjuk a centos bugreport annyira nem is érdekes, mert ott a HP support megszakértette, hogy ők nem támogatnak CentOS-t. Az mind1 is, mivel centos kernel == rhel kernel.

RHEL bugreportot viszont még nem találtam, de ahogy az első linken látszik, RHEL 7.4 -nél is vannak gondok.

Szóval marad a "várakozás" + a -5XXx -es kernel amíg méltóztatik a HP frissíteni a repoban a hpvsa drivert.

Mondjuk ez a legérdekesebb rész az egészben:

SLES 12 SP3 was released on September 7th, the HPE driver was released on September 15th.
On September 15th a new driver for SLES 11 was released.

Is Red Hat no longer supported? I haven't been able to patch my system for four months, despite some security flaws.

^^ SLESnél valahogy tudták követni "szinte azonnal" az új SP csomagot, míg RHEL esetén ez valahogy elmaradt. Pedig 7.0-7.3 -ig teljesen szépen jöttek az új driverek. (bár lehet SLES-éknél Novell odatolt egy kis lóvét a HPnak hogy na gyorsan gyorsan :) )

Ez a b120i egy ipari hulladék. Nem lehet valahogy HBA módba kapcsolni? És akkor el lehet felejteni a bohóckodást a driverekkel.

bta a raid1 nem féllábú.

array A (SATA, Unused Space: 0 MB)

logicaldrive 1 (931.5 GB, RAID 1, OK)

physicaldrive 1I:0:1 (port 1I:box 0:bay 1, SATA, 1 TB, OK)
physicaldrive 2I:0:2 (port 2I:box 0:bay 2, SATA, 1 TB, OK)
physicaldrive 3I:0:3 (port 3I:box 0:bay 3, SATA, 1 TB, OK, spare)

Csak a driverével van gondom + azzal, hogy ezen ül az egész OS.. Értem én hogy valahogy átlehetne vinni ... De azt nem igazán "fizetik" ki :)

btw, teszt megvolt.

Sima boot (ráadásul a mostani fixelt kernellel)

Linux xxxx.XXXXX.xxxxx 3.10.0-693.11.6.el7.x86_64 #1 SMP Thu Jan 4 01:06:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

[ 7.661552] hpvsa - driver version:1.2.16-114
[ 7.661557] hpvsa - raidstack version:6.00C

Bár volt egy kis érdekesség, első reboot valamiért megakadt, de azt én csesztem el a grub-default entryk miatt még a régi kernellel akart volna bootolni.

Bocs hogy felhozom a topicot, RHEL/Centos 7.5 miatt.

kernel x86_64 3.10.0-862.el7 cr 46 M

Valakinek tapasztalat a fenti raid konfigurációban hpvsa modul megdöglik vagy nem döglik meg ezzel a fajta kernellel? :)

(HP oldalán még semmi)