Suse 9.1 GCC

 ( zorgi | 2004. december 31., péntek - 0:44 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

[quote:775bb4a685="Lakosimi"]Szerintem (így első blikkre) :? nincs feltéve nálad a gcc-devel csomag. Viszont ha tévednék, akkor a telepítő CD vagy DVD gyökérkönyvtárában kell lennie egy ARCHIVES.gz fájlnak (de ls-R.gz biztos van), ami egy komlett fájllista a lemezen lévő rpm csomagok tartalmáról.
Ebben rálelsz, hogy melyik rpm csomagot kell még feltenni.

Legvégső esetben az FTP szerveren van ilyen fájl ahonnét telepíhető a SuSE Linux. (van több ilyen is)
Például itt "[i:775bb4a685]nem messze[/i:775bb4a685]" :-)
ftp://ftp.fsn.hu/pub/linux/distributions/suse/suse/i386/9.1/ARCHIVES.gz

Nézz bele és meglesz a megoldás :P[/quote:775bb4a685]
nekem "masodik blikkre" is ugy tunik, hogy a glibc-devel csomag hianyzik.
ARCHIVES-turkalastol szerintem egyszerubb: [url]http://rpm.pbone.net[/url], tud keresni csomagnevre es csomagtartalomra is.

Szia,

Suse 9.1 alatt a legegyszerubb modszer, hogy megnezd mi van telepitve es telepitsed ami hianyzik, a kovetkezo:

- elinditod a YaST-t (System -> YaST)
- keri a root jelszot (ha eppen nem rootkent vagy belepve)
- a Software menunel rakatintasz az Install and Remove Software ikonra
- kinyilik egy uj ablak
- a Search ablakba beirod gcc es rakatintasz a Search gombra
- a joboldali ablakban megad mindent ami a gcc-hez tartozik, ami ki van pipalva az telepitve van mar
- kipipalod azt amire szukseged van, berakod a Suse CD-t a meghajtoba es Accept

Jo munkat es Boldog Uj Evet a Suseval!

kbela

[quote:eacd3436c9="zsirfeka"]
nekem "masodik blikkre" is ugy tunik, hogy a glibc-devel csomag hianyzik.
ARCHIVES-turkalastol szerintem egyszerubb: [url]http://rpm.pbone.net[/url], tud keresni csomagnevre es csomagtartalomra is.[/quote:eacd3436c9]

Csak egy apró észrevétel: Én úgy gondolom, hogy ha mancinéni adta a sütemény receptet, akkor tőle kérdezem meg, hogy az evőkanál cukor vajon úgy értendő, hogy 5dkg? Persze lehet ezért cukrászhoz is menni :-) :P

Viszont talán a mancinéni ottvan a szomszédban, a cukrászhoz meg le kell menni ...

Az ARCHIVES.gz-ben találtam meg vagy 20-30 fájlt eddíg, márminthogy milyen csomagban keressem, mit tegyek fel ezért.

Elég tehát letölteni az ARCHIVES.gz-t (igaz ez 9MB) és utánna ragyogóan lehet benne [b:eacd3436c9]mc[/b:eacd3436c9] kontra F7-tel keresni és találni a későbbiekben is.
:roll:
Nem :?:

Sziasztok!

Köszi a hozzá szólásokat...
1. Újra telepítettem a linuxot, de nem ajánlja fel a developer vagy fejlesztői lehetőséget....

2. a search ablakba beírva a gcc-t a gcclib és cpp jelenik meg mind kettő ki van pipálva...

De hiába próbálom használni nem műxik....

Elképzelhető hogy nem jól használom...
Azt áruljátok el hogy kell....:)

Egyébként próbáltam Mplayer-t telepíteni abba van makefile és azt írja hogy nem good a gcc version telepítsek egyet...

Szóval letöltöttem a 3.4.3-at de nem tudom telepíteni mert nem rpm file....
Ebbe is segíthetnétek

köszi

[quote:cf55faec3a="zorgi"]Sziasztok!

Köszi a hozzá szólásokat...
1. Újra telepítettem a linuxot, de nem ajánlja fel a developer vagy fejlesztői lehetőséget....

2. a search ablakba beírva a gcc-t a gcclib és cpp jelenik meg mind kettő ki van pipálva...

köszi[/quote:cf55faec3a]

Mert 9.1 pro-d van, amit vagy magazinok mellékletéről vagy máshonnan húztál le. Ez a verzió kimondottan otthoni ismerkedési feladatokra lett készítve. Ezért nincs benne semmi fejlesztői csomag. A megoldás az, hogy internetre kellene tenni a géped. A yast vezérlőközpontban van egy olyan, hogy telepítési forrás megadása. Itt add meg azt, hogy ftp://roxen.integrity.hu/pub/suse/i386/9.1/
Leszedi a csomagokat, és lesz mindened:)

Sziasztok!

Először is BUÉK mindenkinek....
Újabb probléma, először is ha a c progimat fordítani akarom ezt kapom vissza hiba üzenetnek....(letöltöttem a frissítéseket)

zorgi@linux:~/public_html/SajatC> cpp szulo.c bla
szulo.c:10:19: stdio.h: Nincs ilyen fájl vagy könyvtár
szulo.c:11:21: sys/sem.h: Nincs ilyen fájl vagy könyvtár
szulo.c:12:21: sys/msg.h: Nincs ilyen fájl vagy könyvtár
szulo.c:13:23: sys/types.h: Nincs ilyen fájl vagy könyvtár
szulo.c:14:21: sys/ipc.h: Nincs ilyen fájl vagy könyvtár
szulo.c:15:21: sys/shm.h: Nincs ilyen fájl vagy könyvtár
szulo.c:16:20: stdlib.h: Nincs ilyen fájl vagy könyvtár
szulo.c:17:20: signal.h: Nincs ilyen fájl vagy könyvtár
szulo.c:18:20: unistd.h: Nincs ilyen fájl vagy könyvtár
szulo.c:19:18: time.h: Nincs ilyen fájl vagy könyvtár
zorgi@linux:~/public_html/SajatC>

Illetve a programot ha lefordítom 7.3 alatt akkor ott jól működik viszont a lefordított program 9.1 alatt nem működik helyesen...

Mi lehet a probléma???

köszi

Egyáltalán ezek az include file-k benne vannak alapba a 9.1-be vagy ez hülye kérdés?
Vagy csak az elérési utat kellene megadni???

:(((
Bonyolult...

[quote:cdf40c6543="zorgi"]Egyáltalán ezek az include file-k benne vannak alapba a 9.1-be vagy ez hülye kérdés?
Vagy csak az elérési utat kellene megadni???

:(((
Bonyolult...[/quote:cdf40c6543]

A SuSE 9.1 (amiben benne vannak ezek) 5 cd-s vagy 1 dvd-s. Neked ilyened (professional változat) van?

[quote:f2269416dc="zorgi"]Egyáltalán ezek az include file-k benne vannak alapba a 9.1-be vagy ez hülye kérdés?
Vagy csak az elérési utat kellene megadni???

:(((
Bonyolult...[/quote:f2269416dc]
rakd fel a glibc-devel csomagot

És honnan szedjem le....mert már minden csomagot felraktam...online frissítettem és ha még mindig nincs fent akkor mi a teendő???
:((((
Ha nem kényszerből használnám a linuxot asszem elegem is lenne ebből a bénázásból....
De sajna muszály kigyúrni magam belőle...:(

[quote:e9604a04c4="zorgi"]Sziasztok!

Először is BUÉK mindenkinek....
Újabb probléma, először is ha a c progimat fordítani akarom ezt kapom vissza hiba üzenetnek....(letöltöttem a frissítéseket)

zorgi@linux:~/public_html/SajatC> cpp szulo.c bla
szulo.c:10:19: stdio.h: Nincs ilyen fájl vagy könyvtár
szulo.c:11:21: sys/sem.h: Nincs ilyen fájl vagy könyvtár
szulo.c:12:21: sys/msg.h: Nincs ilyen fájl vagy könyvtár
szulo.c:13:23: sys/types.h: Nincs ilyen fájl vagy könyvtár
szulo.c:14:21: sys/ipc.h: Nincs ilyen fájl vagy könyvtár
szulo.c:15:21: sys/shm.h: Nincs ilyen fájl vagy könyvtár
szulo.c:16:20: stdlib.h: Nincs ilyen fájl vagy könyvtár
szulo.c:17:20: signal.h: Nincs ilyen fájl vagy könyvtár
szulo.c:18:20: unistd.h: Nincs ilyen fájl vagy könyvtár
szulo.c:19:18: time.h: Nincs ilyen fájl vagy könyvtár
zorgi@linux:~/public_html/SajatC>

Illetve a programot ha lefordítom 7.3 alatt akkor ott jól működik viszont a lefordított program 9.1 alatt nem működik helyesen...

Mi lehet a probléma???

köszi[/quote:e9604a04c4]

Szia! :roll:

Szerintem (így első blikkre) :? nincs feltéve nálad a gcc-devel csomag. Viszont ha tévednék, akkor a telepítő CD vagy DVD gyökérkönyvtárában kell lennie egy ARCHIVES.gz fájlnak (de ls-R.gz biztos van), ami egy komlett fájllista a lemezen lévő rpm csomagok tartalmáról.
Ebben rálelsz, hogy melyik rpm csomagot kell még feltenni.

Legvégső esetben az FTP szerveren van ilyen fájl ahonnét telepíhető a SuSE Linux. (van több ilyen is)
Például itt "[i:e9604a04c4]nem messze[/i:e9604a04c4]" :-)
ftp://ftp.fsn.hu/pub/linux/distributions/suse/suse/i386/9.1/ARCHIVES.gz

Nézz bele és meglesz a megoldás :P

Hali mindenkinek!

Mondjátok már el hogy miért nem műxik a gcc a suse linux 9.1 alatt?
Próbáltam új gcc-t telepíteni letöltöttem de nem bírom telepíteni...
Mi a titok? Hogy kell?
1 hete telepítettem Linuxot úgyhogy részletesen magyarázzátok már el....

[quote:bbf61d3285="zorgi"]Hali mindenkinek!

Mondjátok már el hogy miért nem műxik a gcc a suse linux 9.1 alatt?
Próbáltam új gcc-t telepíteni letöltöttem de nem bírom telepíteni...
Mi a titok? Hogy kell?
1 hete telepítettem Linuxot úgyhogy részletesen magyarázzátok már el....[/quote:bbf61d3285]

Szia! :roll:

Bocs, de valahogy nem egészen világos nekem a dolog :oops:

Ugyanis ha a telepítésnél a "[b:bbf61d3285]Developer[/b:bbf61d3285]" vagy Fejlesztői csomagösszeállítást jelölöd ki, akkor felteszi a GCC-t is neked, nomeg még egy rakás csomagot ami kell.

Csak egy "kis" ízelítő:

> automake-1.6.3-30 OK
> autoconf-2.53-134 OK
> bin86-0.14.9-428 OK
> binutils-2.12.90.0.15-44 OK
> bison-1.35-40 OK
> ctags-2002.7.18-29 OK
> cvs-1.11.1p1-220 OK
> flex-2.5.4a-41 OK
> glibc-devel-2.2.5-154 OK
> gcc-3.2-39 OK
> libstdc++-devel-3.2-39 OK
> gcc-c++-3.2-39 OK
> gdb-5.2.1-50 OK
> gettext-0.11.5-28 OK
> gperf-2.7.2-334 OK
> libtool-1.4.2-330 OK
> libxml-1.8.17-91 OK
> make-3.79.1-393 OK
> ncurses-devel-5.2-389 OK
> strace-4.4-211 OK
> xdevel-4.2.0-178 OK
> yacc-91.7.30-602 OK
> zile-1.6.1-209 OK
> zlib-devel-1.1.4-44 OK
> gcc-g77-3.2-39 OK
> gcc-info-3.2-39 OK
> hwinfo-5.35-0 OK
> makedev-2.6-144 OK
> pkgconfig-0.12.0-85 OK
> checkinstall-1.4.1.hu-2 # Ez sem árt :-)
> zip-2.3-477 OK.

> compat-2002.8.15-22 OK
> freetype2-devel-2.0.9-78 OK
> mesaglut-devel-4.0.3-59 OK
> libpng-devel-1.2.4-34 OK

> qt3-3.0.4-8 OK
> qt3-devel-3.0.4-8 OK
> qt3-non-mt-3.0.4-7 OK

gcc-objc-3.2-39.i586.rpm OK plusszként feltéve
libobjc-3.2-39.i586.rpm OK plusszként feltéve
libmng-devel-1.0.4-41.i586.rpm OK plusszként feltéve kellett a qt3-devel-3.0.4-8 -nek

Ha ezek fentvannak akkor nem érhet (túlnagy) meglepetés :P

Persze jelen esetben ez egy SuSE 8.1-hez lett feltéve....